LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2006, 05:49 PM   #1
(sh)Sneaky Mogs(sh)
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Rep: Reputation: 0
Question Makin KDE work for Me


I have been trying with all my might to switch to Slackware - I have used Suse with success in the past - and I have installed it on my machine. It says that I have KDE installed in the /opt/kde folder but I cant get it to boot to kde and I cant start kde at all. I would really like to get this working as I have trouble in the text interface of things - I am relatively new to the Linux interface even though I have used SUSE for 2 years now - and I would just like to get this to work.

Thank you.
(sh) Sneaky Mogs (sh)
 
Old 10-13-2006, 05:53 PM   #2
raska
Member
 
Registered: Aug 2004
Location: Aguascalientes, AGS. Mexico.
Distribution: Slackware 13.0 kernel 2.6.29.6
Posts: 816

Rep: Reputation: 30
Hi there
After logging in, have you tried to type
Code:
startx
Also you might want to read the Slackbook, it's a nice place to start with Slackware

Last edited by raska; 10-13-2006 at 05:56 PM.
 
Old 10-13-2006, 06:03 PM   #3
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware 13.37
Posts: 573

Rep: Reputation: 58
If you need to change window managers to KDE, then at the command line type:
Code:
xwmconfig
before typing
Code:
startx
to start XWindows.
 
Old 10-13-2006, 08:15 PM   #4
Michielvw
Member
 
Registered: May 2005
Location: Leicester,UK
Distribution: Slackware
Posts: 108

Rep: Reputation: 19
Quote:
Originally Posted by (sh)Sneaky Mogs(sh)
I have been trying with all my might to switch to Slackware - I have used Suse with success in the past - and I have installed it on my machine. It says that I have KDE installed in the /opt/kde folder but I cant get it to boot to kde and I cant start kde at all.)
What you are probably looing for is a change of runlevel. Slackware defaults to runlevel 3

edit /etc/inittab and look for the following line
Code:
# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:
and change it to:

Code:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:
Next time you boot your machine it will boot up to KDM, enter your username/password . and you should enter kde
 
Old 10-13-2006, 10:16 PM   #5
BeerIsGood
LQ Newbie
 
Registered: Aug 2005
Location: Emerald, Queensland, Australia
Distribution: Kubuntu => moving => Debian 6
Posts: 27
Blog Entries: 1

Rep: Reputation: 0
Lightbulb

Another way to skin the cat, is to edit your /etc/lilo.conf kernel entry and add an "append" line:
Code:
image = /boot/vmlinuz
  label = linux-graphical
  append = 4
  read-only
image = /boot/vmlinuz
  label = linux-console
  read-only
As you can see, you can then have two options linked to the same kernel image, one going to graphical login, and one to the text console. I put the graphical one at the top of the list so it's the "default" if the lilo menu times out. Don't forget to run "lilo" though.
 
Old 10-14-2006, 03:00 AM   #6
(sh)Sneaky Mogs(sh)
LQ Newbie
 
Registered: Oct 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you to everyone that has posted. This has been very helpful for me and I hope that it helps others in the future.

(sh) Sneaky Mogs (sh)
 
  


Reply

Tags
kde, slackware, slackware11


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error message when makin kernel colly Linux - Software 1 07-07-2004 04:25 PM
Makin Gift work PRIEST Linux - General 5 02-06-2004 06:38 AM
Makin the use of Samba safe herc Linux - Software 1 01-29-2004 02:21 PM
Makin an installer soulsniper Linux From Scratch 3 05-09-2003 03:49 AM
script and makin' a shortcut jefftrwmy Linux - Software 1 05-13-2002 07:01 AM


All times are GMT -5. The time now is 10:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration