LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-14-2013, 09:40 PM   #31
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196

There are three possible phases during the boot procedures:

1. The machine displays shitty enlarged text (BIOS does that).

2. The machine displays the default font.

3. The machine displays the font chosen in /etc/rc.d/rc.font file.

So at the end you should see the font registered in that file.

If that doesn’t work inspect /etc/rc.d/rc.font file and make sure that the only non-commented line is:

setfont -v ter-132n.psf.gz

Then run the command:

chmod 755 /etc/rc.d/rc.font

(It makes that file executable.)

Finally run that file:

/etc/rc.d/rc.font

As a result you should see the enlarged font.

After the reboot that should work as well.
 
1 members found this post helpful.
Old 03-14-2013, 10:21 PM   #32
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Original Poster
Rep: Reputation: Disabled
that did it. thanks
 
Old 03-14-2013, 10:54 PM   #33
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Great!

In the spare time read “Slackware Linux Essentials” (so called: “SlackBook”):

http://www.slackbook.org/html/book.html

or:

ftp://ftp.slackbook.org/slackbook/slackbook-2.0.pdf

It’s extensive (284 pages in the PDF version) but worth to know.

LinuxQuestion.org is a great source of the knowledge as well but you know that already.
 
Old 03-15-2013, 06:07 AM   #34
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Original Poster
Rep: Reputation: Disabled
@ w1k0 thanks you. i've noticed theres alot of reading in linux... i notice your in poland so i have to leave you with a polish joke...what does a polish bride get on her wedding night thats long and hard? a last name!
 
Old 03-15-2013, 07:20 AM   #35
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by myglide View Post
i notice your in poland so i have to leave you with a polish joke...what does a polish bride get on her wedding night thats long and hard? a last name!
It wasn’t fair to ask me the question and give me the answer very close to it. I hadn’t the chance to try to guess the right answer (or to think up the new one).

I heard a few really good jokes in my life but because of the very bad memory I can’t tell you none of them.

So I translated for you a comic strip by Polish artist Marek Raczkowski. I like that strip very much. It’s made up of four pictures:

1. A man walks in the park and spots a little boy in a hooded red raincoat carrying a blue bucket which squats on the path here and there.

2. Man: “What do you do, boy?”. Boy: “I collect dogs poops”.

3. Man: “It’s very nice. Here you overlooked one of them”.

4. Boy: “I have such one already”.

(I hope my translation is correct.)
 
Old 03-16-2013, 06:34 AM   #36
eloi
Member
 
Registered: Nov 2010
Posts: 195

Rep: Reputation: 50
Quote:
Originally Posted by TobiSGD View Post
OFFTOPIC: That is a nice looking font. I am not very knowledgeable about fonts, may it be that this is not an Unicode font? I use some Unicode characters in my shell prompt, but they are only displayed as blocks with the Terminus font, is there a way to correct that?
I use utf8 too. After a Slackware fresh install I run this to
fix some encoding issues:

Code:
#!/bin/sh
# Fix fonts on Slackware

[ `whoami` != "root" ] && echo "You must be root" && exit 1

fontpath=/usr/share/fonts
installed="100dpi 75dpi OTF Speedo TTF Type1 cyrillic misc"

# Clean cache
rm /var/cache/fontconfig/* 2>/dev/null

# Clean fonts.* files
find $fontpath -name fonts.scale -delete
find $fontpath -name fonts.dir -delete
find $fontpath -name encodings.dir -delete

# Regenerate
for i in $installed; do
	mkfontdir $fontpath/$i
	mkfontscale $fontpath/$i
done

cd $fontpath/encodings
mkfontdir -n -e .
cd $fontpath/encodings/large
mkfontdir -n -e .

fc-cache --really-force --system-only --verbose
These encoding issues give problems with some X applications and
window managers (using utf-8).

I wish it will be useful.

.
 
1 members found this post helpful.
Old 03-16-2013, 05:13 PM   #37
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by TobiSGD View Post
OFFTOPIC: That is a nice looking font. I am not very knowledgeable about fonts, may it be that this is not an Unicode font? I use some Unicode characters in my shell prompt, but they are only displayed as blocks with the Terminus font, is there a way to correct that?
To see the X Window terminus font which use UTF8 encoding run that command:

cat /usr/share/fonts/misc/fonts.dir | grep '^ter' | grep 'iso10646'
Code:
ter-x12b.pcf.gz -xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso10646-1
ter-x12n.pcf.gz -xos4-terminus-medium-r-normal--12-120-72-72-c-60-iso10646-1
ter-x14b.pcf.gz -xos4-terminus-bold-r-normal--14-140-72-72-c-80-iso10646-1
ter-x14n.pcf.gz -xos4-terminus-medium-r-normal--14-140-72-72-c-80-iso10646-1
ter-x16b.pcf.gz -xos4-terminus-bold-r-normal--16-160-72-72-c-80-iso10646-1
ter-x16n.pcf.gz -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1
ter-x18b.pcf.gz -xos4-terminus-bold-r-normal--18-180-72-72-c-100-iso10646-1
ter-x18n.pcf.gz -xos4-terminus-medium-r-normal--18-180-72-72-c-100-iso10646-1
ter-x20b.pcf.gz -xos4-terminus-bold-r-normal--20-200-72-72-c-100-iso10646-1
ter-x20n.pcf.gz -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
ter-x22b.pcf.gz -xos4-terminus-bold-r-normal--22-220-72-72-c-110-iso10646-1
ter-x22n.pcf.gz -xos4-terminus-medium-r-normal--22-220-72-72-c-110-iso10646-1
ter-x24b.pcf.gz -xos4-terminus-bold-r-normal--24-240-72-72-c-120-iso10646-1
ter-x24n.pcf.gz -xos4-terminus-medium-r-normal--24-240-72-72-c-120-iso10646-1
ter-x28b.pcf.gz -xos4-terminus-bold-r-normal--28-280-72-72-c-140-iso10646-1
ter-x28n.pcf.gz -xos4-terminus-medium-r-normal--28-280-72-72-c-140-iso10646-1
ter-x32b.pcf.gz -xos4-terminus-bold-r-normal--32-320-72-72-c-160-iso10646-1
ter-x32n.pcf.gz -xos4-terminus-medium-r-normal--32-320-72-72-c-160-iso10646-1
To use them in a convenient way put at the end of /usr/share/fonts/misc/fonts.alias file the following section:

Code:
ter-x12b -xos4-terminus-bold-r-normal--12-120-72-72-c-60-iso10646-1
ter-x12n -xos4-terminus-medium-r-normal--12-120-72-72-c-60-iso10646-1
ter-x14b -xos4-terminus-bold-r-normal--14-140-72-72-c-80-iso10646-1
ter-x14n -xos4-terminus-medium-r-normal--14-140-72-72-c-80-iso10646-1
ter-x16b -xos4-terminus-bold-r-normal--16-160-72-72-c-80-iso10646-1
ter-x16n -xos4-terminus-medium-r-normal--16-160-72-72-c-80-iso10646-1
ter-x18b -xos4-terminus-bold-r-normal--18-180-72-72-c-100-iso10646-1
ter-x18n -xos4-terminus-medium-r-normal--18-180-72-72-c-100-iso10646-1
ter-x20b -xos4-terminus-bold-r-normal--20-200-72-72-c-100-iso10646-1
ter-x20n -xos4-terminus-medium-r-normal--20-200-72-72-c-100-iso10646-1
ter-x22b -xos4-terminus-bold-r-normal--22-220-72-72-c-110-iso10646-1
ter-x22n -xos4-terminus-medium-r-normal--22-220-72-72-c-110-iso10646-1
ter-x24b -xos4-terminus-bold-r-normal--24-240-72-72-c-120-iso10646-1
ter-x24n -xos4-terminus-medium-r-normal--24-240-72-72-c-120-iso10646-1
ter-x28b -xos4-terminus-bold-r-normal--28-280-72-72-c-140-iso10646-1
ter-x28n -xos4-terminus-medium-r-normal--28-280-72-72-c-140-iso10646-1
ter-x32b -xos4-terminus-bold-r-normal--32-320-72-72-c-160-iso10646-1
ter-x32n -xos4-terminus-medium-r-normal--32-320-72-72-c-160-iso10646-1
I don’t like these fonts too much. I prefer -misc-fixed-* instead (I registered them in fonts.alias as well).

To display the information about the console terminus fonts see README.terminus file:

Code:
names   mappings                covered codepage(s)

ter-1*  iso01, iso15, cp1252    ISO8859-1, ISO8859-15, Windows-1252
ter-2*  iso02, cp1250           ISO8859-2, Windows-1250
ter-7*  iso07, cp1253           ISO8859-7, Windows-1253
ter-9*  iso09, cp1254           ISO8859-9, Windows-1254
ter-c*  cp1251, iso05           Windows-1251, ISO8859-5
ter-d*  iso13, cp1257           ISO8859-13, Windows-1257
ter-g*  iso16                   ISO8859-16
ter-i*  cp437                   IBM-437
ter-k*  koi8r                   KOI8-R
ter-m*  mik                     Bulgarian-MIK
ter-p*  pt154                   Paratype-PT154
ter-u*  koi8u                   KOI8-U
ter-v*  all listed above        all listed above and many others (about 110
        and many others         language sets), 8 foreground colors

names   style

ter-*n  normal
ter-*b  bold
ter-*f  framebuffer-bold
Try these fonts one by one in the console mode using the commands such as:


setfont -v ter-116n.psf.gz
setfont -v ter-216n.psf.gz
.
.
.
setfont -v ter-u16n.psf.gz
setfont -v ter-v16n.psf.gz


Check which one displays properly your special characters. Then customize the font size.

At the beginning make sure that your /etc/lilo.conf includes the append line appending vt.default_utf8=1 (Slackware default is 0):

Code:
append=" acpi_osi=Linux apm=1 pcie_aspm=force vt.default_utf8=1 resume=/dev/sda4 acpi_sleep=s3_bios,s3_mode"
and your /etc/profile.d/lang.sh includes the following non-commented line (it’s commented by default in Slackware):

Code:
export LANG=en_US.UTF-8
It seems that’s all.
 
1 members found this post helpful.
Old 03-19-2013, 08:34 AM   #38
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
TobiSGD,

I hope my answer solved your problem ultimately. If not feel free to ask me the question. Then we could try to finish that.

(I overlooked your original question -- I spotted it in the reply by eloi -- that explains the delay in the answer.)
 
Old 03-20-2013, 04:51 AM   #39
eloi
Member
 
Registered: Nov 2010
Posts: 195

Rep: Reputation: 50
Quote:
Originally Posted by w1k0 View Post
TobiSGD,

I hope my answer solved your problem ultimately. If not feel free to ask me the question. Then we could try to finish that.

(I overlooked your original question -- I spotted it in the reply by eloi -- that explains the delay in the answer.)
Some explanation.

The problem I found is encodings.dir files are not well
generated at installation time. That confuses X with some
encodings. I ignore if it's directly related or can fix the
TobiSGD issue but I judged useful to post it.

My workaround is a bit "brute force". Surely you can
improve it.

Can it be considered a bug report in Slackware folklore?
 
Old 03-20-2013, 06:42 AM   #40
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
eloi,

You encountered some issues, you solved them, and that works for you. That’s good.

You published your solution and now the other folks can solve their problems as well. That’s great.

To make your hint more complete disclose here which encodings and which applications caused the issues and describe these issues a bit. It’ll be wonderful.

***

A prank time: “eloi, eloi, lama sabachthani?”.
 
Old 03-20-2013, 07:02 AM   #41
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
For me it is simple as that: The chars I use in my prompt (frowning face, smiling face) are not available in the Terminus font, but since I use a framebuffered CLI only on one machine and I like to keep my machine's configurations consistent I simply keep it with the standard font for now, maybe I will change the font in the future (and with that the prompt), but now I have no plans for that.
Nonetheless I nice lession about fonts, thanks.
 
Old 03-20-2013, 07:16 AM   #42
myglide
Member
 
Registered: Mar 2013
Location: Texas
Distribution: slackware 14.0
Posts: 58

Original Poster
Rep: Reputation: Disabled
My God, my God, why hast thou forsaken me?


MENE, MENE, TEKEL, UPHARSIN...
 
Old 03-21-2013, 04:10 AM   #43
eloi
Member
 
Registered: Nov 2010
Posts: 195

Rep: Reputation: 50
Quote:
Originally Posted by w1k0 View Post
eloi,

You encountered some issues, you solved them, and that works for you. That’s good.
Not exact. Search on internet.

Quote:
You published your solution and now the other folks can solve their problems as well. That’s great.

To make your hint more complete disclose here which encodings and which applications caused the issues and describe these issues a bit. It’ll be wonderful.
I was concise because I didn't want to extend an off-topic comment.

***

Quote:
***

A prank time: “eloi, eloi, lama sabachthani?”.
I've found this:

http://youtu.be/1E16_9nJ50M

HA, HA, HA, I ignored that (eloi is about the time machine).
Courious. God is angry because of my bad propaganda and is
playing with me! .

Last edited by eloi; 03-21-2013 at 04:52 AM. Reason: grammar
 
Old 03-21-2013, 08:14 AM   #44
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
Quote:
Originally Posted by eloi View Post
I was concise because I didn't want to extend an off-topic comment.
Quote:
Originally Posted by eloi View Post
Can it be considered a bug report in Slackware folklore?
The bug report includes the description of the bug. It isn’t off-topic. Off-topic was the puzzle part and the moderator split the thread into two parts. The other one is here. It’s moderator’s job.

So if you’d like to finish your “bug report” disclose here which encodings and which applications caused the issues and describe these issues a bit. In the other case different people could try your solution to solve the problems which aren’t related to it.

***

As I mentioned in the post #37 I don’t like X Window version of the terminus font so I stayed with -misc-fixed-* font which is much more readable in 9x15 size than ter-x16n. After a few days I switched back from the console ter-216n terminus font to the standard lat2-16 font – it’s much more readable as well. As I can recall in a remote past I tried terminus font and I switched back to my standard fonts. The terminus font is simply too delicate to be well readable.

As the terminus developers claim: it’s “a clean, fixed width bitmap font, designed for long (8 and more hours per day) work with computers”. Maybe it’s designed for such a purpose but it doesn’t meet the users’ expectations concerning the readability so it’s poorly designed though I have to admit that it looks very nice. Unfortunately the nice appearance doesn’t matter.

Last edited by w1k0; 03-23-2013 at 08:18 AM. Reason: moving things to the right place
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make backend resolution larger than frontend? Willrandship Linux - Desktop 4 11-17-2010 08:52 PM
How to strip a specific part of text from a larger file? pepsi_max2k Programming 10 03-27-2009 04:00 AM
make OpenBSD's text console larger? gani *BSD 4 09-20-2004 11:44 PM
shell text fonts are larger than normal??? tsw Mandriva 8 05-12-2004 07:01 PM
How do I make my Linux Partition larger? SeXuaLSoYBeaN Linux - Software 1 10-17-2003 08:34 AM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration