LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   make text larger? (http://www.linuxquestions.org/questions/slackware-14/make-text-larger-4175454068/)

myglide 03-14-2013 10:03 AM

make text larger?
 
Can I make the text larger from the command line without changing monitor resolution?

Habitual 03-14-2013 10:10 AM

what terminal emulator are you using?

myglide 03-14-2013 10:41 AM

iono just installed 14.0 and am using it from the command line

sizemj 03-14-2013 12:01 PM

Have you started X (issued the command startx)?

myglide 03-14-2013 01:53 PM

thank you for your reply. yes I have, but i would like to do know if i can change the settings from the command line as stated. i have also viewed the man page for font. however i have been unable to get any of the commands to work from either the user acct. i created or from the root user acct.

volkerdi 03-14-2013 02:58 PM

I think your best bet is to install the ap/terminus-font package from -current (it won't conflict with anything in 14.0), and then try some of those fonts, like this one:

Code:

setfont ter-120b

myglide 03-14-2013 03:35 PM

thank you for your reply. i dont know how to do that yet. i get that ap/terminus-font package is a package to be installed. is -current a file it will create or one that is already there? I'm just trying to make the text larger when the system boots up and the command line comes up, its kind of small because im thinking the high resolution of my monitor. iono

volkerdi 03-14-2013 03:55 PM

Quote:

Originally Posted by myglide (Post 4911705)
thank you for your reply. i dont know how to do that yet. i get that ap/terminus-font package is a package to be installed. is -current a file it will create or one that is already there? I'm just trying to make the text larger when the system boots up and the command line comes up, its kind of small because im thinking the high resolution of my monitor. iono

-current is the development version of Slackware. The terminus-font package isn't in Slackware 14.0.

Here's what you need to do to try this:

Code:

cd /tmp
lftpget ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/ap/terminus-font-4.38-noarch-1.txz
installpkg terminus-font-4.38-noarch-1.txz
setfont ter-120b

You can check out the other fonts in /usr/share/kbd/consolefonts, too. If you like the result, add the setfont line to your /etc/rc.d/rc.local script and you're good to go.

TobiSGD 03-14-2013 04:29 PM

OFFTOPIC: That is a nice looking font. I am not very knowledgeable about fonts, may it be that this is not an Unicode font? I use some Unicode characters in my shell prompt, but they are only displayed as blocks with the Terminus font, is there a way to correct that?

Didier Spaier 03-14-2013 05:01 PM

Quote:

Originally Posted by TobiSGD (Post 4911730)
may it be that this is not an Unicode font?

I would check the availability of the characters you need in that font. According to this page, version 4.38 (shipped in -currrent) contains 879 characters. The README file in the source tarball lists the code pages included and I assume that the /uni directory includes:
(1) For every code page, the UTF-8 encoding of the characters of that code page
(2) In the 10646-1 file, the UTF-8 encoding of all 879 included characters.

So to make sure, just "grep <UTF-8 hexadecimal code of the needed character> /uni/10646-1" to check.

myglide 03-14-2013 05:03 PM

thank you for reply. get1: access failed: 550 failed to open file (pub/slackware...etc....tzx)get1: not connected...forgot to mention i havent figure how to connect to interweb yet looks like it woulda work though

myglide 03-14-2013 05:20 PM

strike that last reply. I open KDE and it seem i am abale to connect to the interweb maybe i typed something the wrong way when i entered the code
or maybe i'm not connected at the command line iono

w1k0 03-14-2013 06:16 PM

I tried the following command on my 16801050 screen:

xterm +sb -fg black -bg white -geometry 279x85+0+0 -fn 6x12

The font 6x12 seems reasonable. If it’s too small or too big for you try instead the other one from the following:

head -n 25 /usr/share/fonts/misc/fonts.alias
Code:

! $Xorg: fonts.alias,v 1.3 2000/08/21 16:42:31 coskrey Exp $
fixed        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
variable    -*-helvetica-bold-r-normal-*-*-120-*-*-*-*-iso8859-1
5x7          -misc-fixed-medium-r-normal--7-70-75-75-c-50-iso8859-1
5x8          -misc-fixed-medium-r-normal--8-80-75-75-c-50-iso8859-1
6x9          -misc-fixed-medium-r-normal--9-90-75-75-c-60-iso8859-1
6x10        -misc-fixed-medium-r-normal--10-100-75-75-c-60-iso8859-1
6x12        -misc-fixed-medium-r-semicondensed--12-110-75-75-c-60-iso8859-1
6x13        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
6x13bold    -misc-fixed-bold-r-semicondensed--13-120-75-75-c-60-iso8859-1
7x13        -misc-fixed-medium-r-normal--13-120-75-75-c-70-iso8859-1
7x13bold    -misc-fixed-bold-r-normal--13-120-75-75-c-70-iso8859-1
7x13euro    -misc-fixed-medium-r-normal--13-120-75-75-c-70-iso8859-15
7x13eurobold -misc-fixed-bold-r-normal--13-120-75-75-c-70-iso8859-15
7x14        -misc-fixed-medium-r-normal--14-130-75-75-c-70-iso8859-1
7x14bold    -misc-fixed-bold-r-normal--14-130-75-75-c-70-iso8859-1
8x13        -misc-fixed-medium-r-normal--13-120-75-75-c-80-iso8859-1
8x13bold    -misc-fixed-bold-r-normal--13-120-75-75-c-80-iso8859-1
8x16        -sony-fixed-medium-r-normal--16-120-100-100-c-80-iso8859-1
9x15        -misc-fixed-medium-r-normal--15-140-75-75-c-90-iso8859-1
9x15bold    -misc-fixed-bold-r-normal--15-140-75-75-c-90-iso8859-1
10x20        -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso8859-1
12x24        -sony-fixed-medium-r-normal--24-170-100-100-c-120-iso8859-1
nil2        -misc-nil-medium-r-normal--2-20-75-75-c-10-misc-fontspecific

If your screen is smaller or bigger than mine customize 279x85+0+0 parameter. The first value is for the width and the second for the height.

***

Misunderstanding. I read just the first post and I guessed that you’d like to put more text on the screen. Meanwhile your goal is opposite. So you could try the bigger font such as 9x15 decreasing the values in 279x85+0+0 parameter. That concerns X Window of course.

In my case the right command is the following:

xterm +sb -fg black -bg white -geometry 186x68+0+0 -fn 9x15

TobiSGD 03-14-2013 06:26 PM

@Didier Spaier: Thanks for your explanation. Seems that the characters used by me (frowning face and smiling face) are not included.

w1k0 03-14-2013 06:48 PM

By the way. If you use UTF8 encoding put at the end of /usr/share/fonts/misc/fonts.alias the following section:

Code:

5x7int        -misc-fixed-medium-r-normal--7-70-75-75-c-50-iso10646-1
5x8int        -misc-fixed-medium-r-normal--8-80-75-75-c-50-iso10646-1
6x9int        -misc-fixed-medium-r-normal--9-90-75-75-c-60-iso10646-1
6x10int        -misc-fixed-medium-r-normal--10-100-75-75-c-60-iso10646-1
6x12int        -misc-fixed-medium-r-semicondensed--12-110-75-75-c-60-iso10646-1
6x13int        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
6x13boldint    -misc-fixed-bold-r-semicondensed--13-120-75-75-c-60-iso10646-1
7x13int        -misc-fixed-medium-r-normal--13-120-75-75-c-70-iso10646-1
7x13boldint    -misc-fixed-bold-r-normal--13-120-75-75-c-70-iso10646-1
7x14int        -misc-fixed-medium-r-normal--14-130-75-75-c-70-iso10646-1
7x14boldint    -misc-fixed-bold-r-normal--14-130-75-75-c-70-iso10646-1
8x13int        -misc-fixed-medium-r-normal--13-120-75-75-c-80-iso10646-1
8x13boldint    -misc-fixed-bold-r-normal--13-120-75-75-c-80-iso10646-1
9x15int        -misc-fixed-medium-r-normal--15-140-75-75-c-90-iso10646-1
9x15boldint    -misc-fixed-bold-r-normal--15-140-75-75-c-90-iso10646-1
10x20int      -misc-fixed-medium-r-normal--20-200-75-75-c-100-iso10646-1

and use the command such as:

xterm +sb -fg black -bg white -geometry 186x68+0+0 -fn 9x15int


All times are GMT -5. The time now is 04:52 PM.