LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2014, 03:34 AM   #1
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
Question make -j doesn't work on Slack64 14.1


Hi,

I'm on a Core i3 laptop.

I installed a bunch of SBo packages, and i'm now compiling a kernel.
I have 4 visible processors, but make -j8 still use only one at a time or 25% of each.

I don't know where to start to debug.
 
Old 04-27-2014, 05:15 AM   #2
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,753

Rep: Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271
you can try to check it with htop for example. You should see several build commands running parallel. You also can try to use -j16 or -j1 to see if there were any differences.
 
Old 04-27-2014, 12:34 PM   #3
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,494

Rep: Reputation: 437Reputation: 437Reputation: 437Reputation: 437Reputation: 437
What does "echo $MAKEFLAGS" output?
 
Old 04-28-2014, 12:27 PM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
It outputs blank.

Tried to change it, nothing.
Also tried to increase the -j, nothing.

Last edited by Linux.tar.gz; 04-28-2014 at 12:34 PM.
 
Old 04-28-2014, 12:45 PM   #5
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
WTF !!! I realized i have the same problem on another machine !

I was able to compile a kernel yesterday with 4 cpu, today i can't (i'm using the same host kernel).
 
Old 04-28-2014, 04:46 PM   #6
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,494

Rep: Reputation: 437Reputation: 437Reputation: 437Reputation: 437Reputation: 437
Quote:
Originally Posted by Linux.tar.gz View Post
It outputs blank.
OK, it's not overriding what you are attempting to use, so that's good.

Quote:
Tried to change it, nothing.
What does that mean?

[/QUOTE]Also tried to increase the -j, nothing.[/QUOTE]

Well, here's a quick test: Grab the source for clisp and apply the patche that I mention here.

You'll want to not force "make -j1 blah" that I have in the last code block of the post. You can keep it at "-j7" or whatever.

If you run that slackbuild and it fails, then you can be pretty sure that you are running multiple compile jobs.
 
Old 04-30-2014, 10:38 AM   #7
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,753

Rep: Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271Reputation: 1271
Just please tell me how do you know "make -j8 still use only one at a time"? Have you tried htop or top or something similar?
 
Old 05-01-2014, 02:45 AM   #8
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Original Poster
Rep: Reputation: 86
I look at both gkrellm and top.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Make doesn't work. Again! Darrell22 Linux - Kernel 2 03-01-2010 01:24 AM
[Slack64] Logitech 7-button mouse -- how to make TILT buttons (tilt-wheel) work? GrapefruiTgirl Linux - Hardware 2 08-31-2009 10:27 AM
make Xconfig doesn't work, make menuconfig does work Debian/KDE bucovaina78 Linux - Kernel 1 10-15-2008 01:26 PM
compiling tar.bz2... "./configure make make install" doesn't work dodo1983 Linux - Newbie 7 08-17-2004 12:34 AM
'make' doesn't work with my Zipslack Corado Linux - Newbie 2 02-23-2004 02:33 PM


All times are GMT -5. The time now is 05:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration