LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Make a sound card default. (http://www.linuxquestions.org/questions/slackware-14/make-a-sound-card-default-274592/)

darkarcon2015 01-06-2005 10:22 AM

Make a sound card default.
 
How can I change which sound card my computer sees as the default one? Right now it's the "Dummy" card which doesnt even exsist, yet it is there and it's set as default. Can I just erase it somehow? Thanks for any help.

Peacedog 01-06-2005 05:54 PM

What card are you using? What does your /etc/modules.conf look like?
good luck.

darkarcon2015 01-06-2005 06:04 PM

My "card" is the Integrated SoundStorm on my NF7-S. And my "modules.conf" is empty.

Peacedog 01-06-2005 06:15 PM

Could you post the output from the following commands please?

/sbin/lspci -v

and

/sbin/lsmod

What kernel are you using? do you have a /etc/modprobe.conf, if so, what does it contain?
good luck.

darkarcon2015 01-06-2005 06:32 PM

Output of "lspci -v"
Code:

00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Memory at d0000000 (32-bit, prefetchable) [size=128M]
        Capabilities: [40] AGP version 3.0
        Capabilities: [60] #08 [2001]

00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
        Subsystem: nVidia Corporation: Unknown device 0c17
        Flags: 66Mhz, fast devsel

00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Capabilities: [48] #08 [01e1]

00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: 66Mhz, fast devsel, IRQ 5
        I/O ports at c400 [size=32]
        Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
        Memory at e5080000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        Memory at e5083000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4) (prog-if 20 [EHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 5
        Memory at e5086000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [44] #0a [2080]
        Capabilities: [80] Power Management version 2

00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        Memory at e5087000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at b000 [size=8]
        Capabilities: [44] Power Management version 2

00:05.0 Multimedia audio controller: nVidia Corporation nForce MultiMedia audio [Via VT82C686B] (rev a2)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
        Memory at e5000000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [44] Power Management version 2

00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 5
        I/O ports at b400 [size=256]
        I/O ports at b800 [size=128]
        Memory at e5081000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 00009000-0000afff
        Memory behind bridge: e3000000-e4ffffff

00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2) (prog-if 8a [Master SecP PriP])
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0
        I/O ports at f000 [size=16]
        Capabilities: [44] Power Management version 2

00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3) (prog-if 10 [OHCI])
        Subsystem: ABIT Computer Corp.: Unknown device 1c00
        Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 10
        Memory at e5084000 (32-bit, non-prefetchable) [size=2K]
        Memory at e5085000 (32-bit, non-prefetchable) [size=64]
        Capabilities: [44] Power Management version 2

00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 32
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
        Memory behind bridge: e0000000-e2ffffff
        Prefetchable memory behind bridge: d8000000-dfffffff

01:07.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 03)
        Subsystem: Linksys: Unknown device 0015
        Flags: bus master, fast devsel, latency 32, IRQ 10
        Memory at e4000000 (32-bit, non-prefetchable) [size=8K]

02:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0041 (rev a1) (prog-if 00 [VGA])
        Subsystem: Unknown device 3842:a343
        Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 10
        Memory at e0000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Memory at e1000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0

Output of "lsmod"

Code:

Module                  Size  Used by
nls_cp437              5632  1
vfat                  10880  1
fat                    38336  1 vfat
usb_storage            59968  1
ndiswrapper            70016  0
ipv6                  212064  21
uhci_hcd              27920  0
eth1394                16904  0
nvidia_agp              5788  1
ohci_hcd              18436  0
ehci_hcd              27012  0
nvnet                  67620  0
forcedeth              12032  0
nvsound              1532296  0
ohci1394              29828  0
ieee1394              89528  2 eth1394,ohci1394
shpchp                92140  0
pciehp                89836  0
nvidia              4815540  12
nls_utf8                1792  2
ntfs                  113388  1
evdev                  7168  0
agpgart                26920  2 nvidia_agp
psmouse                17544  0

I am using kernel 2.6.7 and I go have a "modprobe.conf" which contains the following:

Code:

alias char-major-195* nvidia
alias wlan0 ndiswrapper


Peacedog 01-06-2005 06:37 PM

Did you install the alsa packages? If so, have you tried alsaconf as root or su - from a terminal?
good luck.

darkarcon2015 01-06-2005 06:59 PM

Quote:

Originally posted by Peacedog
Did you install the alsa packages? If so, have you tried alsaconf as root or su - from a terminal?
good luck.

Yes, I have the alsa packages because my sound card works. My problem is that a Dummy card is set to the default spot and I don't want that. I also tried "alsaconf" and it said "No supported PnP or PCI card found."

Peacedog 01-07-2005 06:39 AM

By default spot, do you mean the ~/.asoundrc file has it set as the deault card? If so this may help.

http://alsa.opensrc.org/index.php?page=FAQ026

good luck.

darkarcon2015 01-07-2005 02:48 PM

Quote:

Originally posted by Peacedog
By default spot, do you mean the ~/.asoundrc file has it set as the deault card? If so this may help.

http://alsa.opensrc.org/index.php?page=FAQ026

good luck.

Hum, I don't seem to have that file or "/etc/asound.conf" on my computer. But, I know ALSA is working because I see the following message in my "dmesg"

Code:

ALSA device list:
  #0: Dummy 1
  #1: NVidia nForce2 at 0xe5081000, irq 5


Peacedog 01-07-2005 05:13 PM

Try adding this to your /etc/modprobe.conf.

alias snd-card-0 nvsound

You'll have to reboot for the changes to take effect. If it doesn't work you can always edit the file again and remove the line.
good luck.


All times are GMT -5. The time now is 04:00 AM.