LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-10-2004, 12:48 AM   #1
cswake
LQ Newbie
 
Registered: Oct 2004
Location: Atlanta, GA (USA)
Distribution: Slackware
Posts: 6

Rep: Reputation: 0
make: *** No rule to make target 'gconfig'. Stop.


Hi,

Let me say hello as this is my first time posting to the forums! I've been wading my way through linux and just have not been getting any breaks.

I'm in the process of updating the kernel using the guide shown here:
hXXp://shilo.is-a-geek.com/slack/kernel14.html

I'm at the point where I had extracted the latest stable kernel to its own folder in the /usr/src directory. The structure I see is as follows:

/usr/src/linux-2.6.8.1
/usr/src/linux-2.6.8.1/arch
/usr/src/linux-2.6.8.1/arch/...
/usr/src/linux-2.6.8.1/include
/usr/src/linux-2.6.8.1/include/...

So I'm assuming the extraction went fine. I created a shortcut called 'linux' in the /usr/src folder and pointed it to the 2.6.8.1 folder. After switching to /usr/src/linux, I run the command "make gconfig" and get this response:

make: *** No rule to make target 'gconfig'. Stop.

Searching google I only found one person making mention that this command should be run as the root, which I did.

Help?

Last edited by cswake; 10-10-2004 at 12:50 AM.
 
Old 10-10-2004, 01:05 AM   #2
DaHammer
Member
 
Registered: Oct 2003
Location: Planet Earth
Distribution: Slackware, LFS
Posts: 561

Rep: Reputation: 30
How did you create the shortcut? Anyway, try moving directly into /usr/src/linux-2.6.8.1 and then run the make command.
 
Old 10-10-2004, 01:16 AM   #3
cswake
LQ Newbie
 
Registered: Oct 2004
Location: Atlanta, GA (USA)
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: 0
I made the shortcut in KDE just dragging and dropping. Going directly into the /usr/src/linux-2.6.8.1 folder and running the "make gconfig" command results in the same error... (still under the root)
 
Old 10-10-2004, 01:47 AM   #4
DaHammer
Member
 
Registered: Oct 2003
Location: Planet Earth
Distribution: Slackware, LFS
Posts: 561

Rep: Reputation: 30
Ok, not sure what you did dragging and dropping as I seldom use X. Anyway, drop the GUIs for a moment and start a bash prompt. Then move to the /usr/src directory:
Code:
cd /usr/src
Remove what you unpacked earlier:
Code:
rm -rf linux-2.6.8.1
Re-unpack the source:
Code:
tar zxvf /path/to/linux-2.6.8.1.tar.gz
Move into the source directory:
Code:
cd linux-2.6.8.1
Now run your perfered kernel configuration utility, "make xconfig", "make gconfig", "make menuconfig", etc or "make help" for options.

BTW, you really don't need the linux shortcut/link pointing to the linux-2.6.8.1, it should probably point to the original kernel source instead, assuming you have that installed. Either way, you can make as follows:
Code:
cd /usr/src
rm linux
ln -s linux-2.6.8.1 linux

Last edited by DaHammer; 10-10-2004 at 02:01 AM.
 
Old 10-10-2004, 12:13 PM   #5
cswake
LQ Newbie
 
Registered: Oct 2004
Location: Atlanta, GA (USA)
Distribution: Slackware
Posts: 6

Original Poster
Rep: Reputation: 0
Followed you there, except to unpack the source I had to run:
Code:
tar xjvf linux-2.6.8.1.tar.bz2
menuconfig works without trouble, but gconfig and xconfig run into errors and halt. Guess that'll be another thread if I can't figure it out.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lopster v1.2.2 make error: No rule to make target `m4/glibc21.m4' Kropotkin Fedora 0 10-31-2004 11:19 AM
Error "make: *** No rule to make target `install'. Stop." help Ohmn Mandriva 8 07-02-2004 07:02 PM
Error: *** No rule to make target 'all'. Stop aa2bi Linux - Newbie 6 06-08-2004 12:55 PM
*** No rule to make target `modules'. Stop. kmack2001 Linux - Newbie 9 02-16-2004 01:02 PM
No rule to make target `/mkspecs/default/qmake.conf', needed by `Makefile'. Stop Julianus Linux - General 0 12-21-2003 07:17 AM


All times are GMT -5. The time now is 11:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration