LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-28-2002, 07:55 PM   #1
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Rep: Reputation: 30
macromedia flash plugin on mozilla / tunrning off /anti-aliasing problem


hello !
1. how can i install macromedia flash on mozilla ? recently installed it and the readme talks only about the netscape browser
2. how can i turn off my computer without using buttons ( actually i'm not abble to swich it at all , i have to turn off the stabilizer ) from what i remember i could do it on mandrake and i still can on windows , so i guess it's not a machine problem .
3. i turned on anti aliasing for fonts but i can't get to see fonts properly on console . any tips?

thanks for any help
 
Old 04-29-2002, 03:13 AM   #2
CARTMAN
Member
 
Registered: Feb 2002
Location: Turkiye
Distribution: Pardus
Posts: 147

Rep: Reputation: 15
1- Put *.so and *.class file in the /path/to/mozilla/plugins
2- I didnt understand your question
3- Check your /etc/X11/XftConfig add your fonts dir there so that all available fonts gets anti-aliased.
 
Old 04-29-2002, 09:31 AM   #3
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
thanks a lot CARTMAN
well my computer doesn't shut down ( when i halt as root i won't be abble to shut it with the on/off button )and once i could , now i have to turn the power off ( don't know how you call it , the device that prevents eletrical damage to the computer and it's between the machine and the eletric plug ) i saw yesterday something similar in NKSL thread ( apm bios or something ) sorry but my head aches ( i got a bad cold )
hope this helps in any way
 
Old 04-29-2002, 10:07 AM   #4
Richard James
LQ Newbie
 
Registered: Apr 2002
Location: Australia
Distribution: Slackware
Posts: 21

Rep: Reputation: 15
APM advanced power managment and ACPI Advanced Computer Power Interface or something. These are BIOS services that enable the operating system to do funky things like turn the computer off. The ATX power supply in a modern computer can be turned on and off with the motherboard. This is why the power switch goes to the motherboard instead of the power supply like in a AT system.
To get a ATX system to shutoff the Operating system must call a certain BIOS routine and the motherboard does the rest. Unfortunatley Linux seems to be flawed in the modern kernels in regard to this (or slackware does). To configure a kernel to turn off a machine you must compile in APM support under General. Then when you issue a "halt" command the kernel should turn the PC off.
On my computer though (and on others) it doesn't work and instead says power off. This means it didn't work and I can't get it to work yet. Works fine on my 486 laptop but not my Athlon grrr.
 
Old 04-29-2002, 10:19 AM   #5
Richard James
LQ Newbie
 
Registered: Apr 2002
Location: Australia
Distribution: Slackware
Posts: 21

Rep: Reputation: 15
I just got APM working on my ASUS A7V 133 here is what I did.
In the Kernel --> General Options are the APM options. I had "APM" compiled as well as "Use real mode APM BIOS call to power off". So I looked at the help for the power off one and it said this is for stuffed bioses so I though maybe I should turn it off. Now I only have "APM" Advanced Power Management BIOS support compiled in with no options and it halts fine.
 
Old 04-29-2002, 12:39 PM   #6
CARTMAN
Member
 
Registered: Feb 2002
Location: Turkiye
Distribution: Pardus
Posts: 147

Rep: Reputation: 15
If you want to use APM support you have to disable SMP ( Symmetric Multi Processor ) support in kernel which is on by default .
 
Old 04-29-2002, 04:33 PM   #7
jamaso
Member
 
Registered: Oct 2001
Location: brasil
Distribution: mdrk 8.0,redht7.1,debianpotato
Posts: 615

Original Poster
Rep: Reputation: 30
Thanks

I have two questios :
1- i found these two dir at /etc/X11/XftConfig like you said CARTMAN :


Quote:
Check your /etc/X11/XftConfig add your fonts dir
how do i know which one is mine ? thanks
---------------------------------------------------- #
# XftConfig
#
# Use with Type1 and TrueType fonts
#

dir "/usr/X11R6/lib/X11/fonts/Type1"
dir "/usr/X11R6/lib/X11/fonts/truetyp

#
# alias 'fixed' for 'mono'
#
match any family == "fixed" edit family =+ "mono";

#
#Check users config file
#
includeif "~/.xftconfig"

#
# Substitute TrueType fonts for Type1 versions
#
match any family == "Times" edit family += "Times New Roman";
match any family == "Helvetica" edit family += "Verdana";
match any family == "Courier" edit family += "Courier New";

#
# Use TrueType fonts for defaults


match any family == "serif" edit family += "Times New Roman";
match any family == "sans" edit family += "Verdana";

#
# Use monotype.com (andale) face where possible
#
match
any family == "mono"
all slant == roman
all weight < bold
edit
family += "monotype.com";
#
# otherwise, use courier
#
match any family == "mono" edit family += "Courier New";

#
# Alias between XLFD families and font file family name, prefer local fonts
#
match any family == "Charter" edit family += "Bitstream Charter";
match any family == "Bitstream Charter" edit family =+ "Charter";
match any family == "Lucidux Serif" edit family += "LuciduxSerif";
match any family == "LuciduxSerif" edit family =+ "Lucidux Serif";
match any family == "Lucidux Sans" edit family += "LuciduxSans";
match any family == "LuciduxSans" edit family =+ "Lucidux Sans";

-------+(Jed 0.99.12) Emacs: XftConfig (Text) 30/72 5:26pm----------------
 
Old 05-01-2002, 07:42 AM   #8
CARTMAN
Member
 
Registered: Feb 2002
Location: Turkiye
Distribution: Pardus
Posts: 147

Rep: Reputation: 15
You see this part:
Quote:
dir "/usr/X11R6/lib/X11/fonts/Type1"
dir "/usr/X11R6/lib/X11/fonts/truetyp"
if your TTF fonts is in /path/to/TFF
add an entry like

dir "/path/to/ttf"

then run xftcache as root dont forget to add Load "freetype" to Modules section of /etc/X11/XF86Config then restart X it should work...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macromedia Flash Firefox Plugin Tarrin Linux - Software 2 02-23-2005 07:57 PM
Macromedia Flash / Mozilla problem with certain websites. Can you get them to work? holyroller1 Linux - Software 3 01-18-2004 12:02 AM
[Mozilla 1.4] Anti Aliasing GUI / Fonts 4hp Mandriva 2 09-02-2003 08:56 AM
Disable anti-aliasing in Mozilla? raeven Linux - Software 0 03-20-2003 10:44 AM
Galeon can't use Macromedia Flash Plugin? Amerist Linux - Software 8 09-15-2002 05:19 AM


All times are GMT -5. The time now is 07:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration