LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-17-2008, 12:04 PM   #1
ayoung
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Rep: Reputation: 0
m-audio rev51 pcm no sound


I'm using a m-audio revolution 5.1 sound card and using the digital out to my receiver to play sound. I can't get the sound to work on my kde desktop. I'm in the audio and cdrom group. I already ran through alsaconf, alsamixer, and alsactl store commands. I made sure the pcm options were all unmuted in the playback section. I did have a problem with alsaconf loading the onboard sound, but I fixed that by blacklisting the kernel module snd_intel8x0 or something like that. Where do I go from here?
 
Old 01-17-2008, 01:26 PM   #2
ayoung
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I was messing around creating a .asoundrc file and after deleting it, I got this error:

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Device or resource busy)
The sound server will continue, using the null output device.
 
Old 01-17-2008, 02:14 PM   #3
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
It might be busy because some other program is occupying /dev/dsp. This could be Arts (KDE mixer) if you use KDE. Try playing sound in init 3 mode without desktop environment started (you can use aplay, mpg123, mpg321, etc..)
 
Old 01-17-2008, 02:52 PM   #4
ayoung
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
When i try aplay I get:

aplay: set_params:900: Sample format non available
 
Old 01-17-2008, 11:45 PM   #5
ayoung
LQ Newbie
 
Registered: Jan 2008
Posts: 4

Original Poster
Rep: Reputation: 0
As far as I can tell,there aren't any other programs using my sound device. I used the command "lsof |grep snd" and got:

xine 8455 alex 5u CHR 116,0 13864 /dev/snd/controlC0

which is the only program running. Xine still gives me the busy device error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
optimal pcm sound setting ? H_TeXMeX_H Slackware 5 04-18-2007 10:57 AM
Why I have to turn PCM and master sound levels all the way up? J3N7iL Linux - Hardware 8 02-23-2006 07:37 PM
Recording PCM audio - SUSE 10 tanke Linux - Newbie 1 01-19-2006 02:19 AM
No Pcm Sound Out ericfurn Mandriva 6 12-22-2004 03:26 PM
(sound) PCM to audio CD? carboncopy Linux - Software 2 07-09-2004 08:07 AM


All times are GMT -5. The time now is 06:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration