LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-01-2013, 01:49 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Rep: Reputation: 212Reputation: 212Reputation: 212
Question LXDE-Panel


Every now and again I notice weird things with LXDE, programs in the panel will be acting weird, not sure exactly how to explain it but an example is if I have Firefox running it will 'be flashing' as if I am holding down a key and it is 'pulsing', even though I am not even touching the keyboard and mouse. The main issue though is the icon that lists all programs, sometimes I have to refresh LXDE to get it to list again, or sometimes destroy the local directory and start fresh to get listings back, I managed to at least get a screen of that.

LXDE programs suddenly missing (lower left of the screen):
LXDE_Taskbar-ISSUE.jpeg

Now it is normal:
LXDE_Taskbar-ISSUE2.jpeg

Anyone who uses LXDE seen this behavior before? I am using Ponce's LXDE packages.
 
Old 09-01-2013, 07:02 PM   #2
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Hi Jeebizz,

I too am using lxpanel (although I'm using the official releases that LXDE releases). Usually if it's flashing there was some sort of activity in that program that triggers it (e.g. someone messages me on Facebook in Pidgin while it's minimized or when I've got a different program in the foreground).

As for the menu applet not listing all programs/applications available, I don't know about.
 
Old 09-01-2013, 07:37 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
Thing is it was just firefox, no addons for facebook or anything. It was really acting erratic - firefox was minimized but the panel was acting like firefox was constantly reloading the page, even though I had it on a blank page... I guess I could try downloading lxde itself, but I'm too lazy to compile it right now.
 
Old 09-02-2013, 12:56 PM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
if you create a fresh new user and so you use lxde with a fresh profile, does the same behaviour show?
are you using these packages (I suppose you have slackware64-14.0)?

Last edited by ponce; 09-02-2013 at 12:58 PM.
 
Old 09-02-2013, 02:33 PM   #5
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
Quote:
Originally Posted by ponce View Post
if you create a fresh new user and so you use lxde with a fresh profile, does the same behaviour show?
are you using these packages (I suppose you have slackware64-14.0)?
Using these: http://ponce.cc/slackware/slackware64-14.0/lxde/ and yes even after I recreate the profile it happens. I am also running Slackware14.0-64bit with multilib (Alien Bob's multilib). It seems to be random/intermittent - it also usually happens after closing a program like firefox, or any window that is fullscreen. I know that still doesn't sound like a lot of info but thats all I got.

Last edited by Jeebizz; 09-02-2013 at 02:37 PM.
 
Old 09-03-2013, 12:09 AM   #6
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
you can edit the file
Code:
~/.config/lxsession/LXDE/autostart
and redirect its output in a file, so you can inspect it
Code:
@lxpanel --profile LXDE >> /tmp/lxpanel.log
 
Old 09-03-2013, 12:34 AM   #7
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
That file does not exist:

Code:
slackuser@slackmachine:~$ ls -al .config/lxsession/
total 12
drwx------  3 slackuser users    8 Apr 30 20:02 ./
drwxr-xr-x 31 slackuser users 4096 Jul  1 22:38 ../
drwx------  2 slackuser users 4096 Jun 17 18:41 LXDE/
slackuser@slackmachine:~$ ls -al .config/lxsession/LXDE
total 8
drwx------ 2 slackuser users 4096 Jun 17 18:41 ./
drwx------ 3 slackuser users    8 Apr 30 20:02 ../
-rw-r--r-- 1 slackuser users  491 Jun 17 18:41 desktop.conf
slackuser@slackmachine:~$
 
Old 09-03-2013, 12:53 AM   #8
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
should be copied automatically from the xdg folder ( /etc/xdg/lxsession/LXDE/autostart ) if not there when you start lxde: you can also copy it manually into ~/.config/lxsession/LXDE/autostart but that's probably a sign that something is behaving strange... are you running a Slackware full install?
Quote:
Originally Posted by Jeebizz View Post
even after I recreate the profile it happens.
if you haven't done it already don't recreate your user profile, please try creating a new different user ( with the default additional groups for desktop use pressing the up arrow during the adduser run, see also http://docs.slackware.com/slackbook:users ) and check if ~/.config/lxsession/LXDE/autostart is there after starting lxde with this new user.

Last edited by ponce; 09-03-2013 at 01:21 AM.
 
Old 09-03-2013, 12:16 PM   #9
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
Quote:
Originally Posted by ponce View Post
are you running a Slackware full install?
Yes, it is a full install.

Quote:
Originally Posted by ponce View Post
if you haven't done it already don't recreate your user profile, please try creating a new different user ( with the default additional groups for desktop use pressing the up arrow during the adduser run, see also http://docs.slackware.com/slackbook:users ) and check if ~/.config/lxsession/LXDE/autostart is there after starting lxde with this new user.
Ok I will try that and see.
 
Old 09-03-2013, 12:21 PM   #10
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
So I created a new user, and I don't even have ./config/lxsession , this is all I have:

Code:
bash-4.2$ ls -al .config
total 8
drwxr-xr-x  7 testuser users   40 Sep  3 11:16 .
drwx--x--x 12 testuser users 4096 Sep  3 11:16 ..
drwxr-xr-x  2 testuser users    8 Sep  3 11:16 blueman
drwx------  3 testuser users    8 Sep  3 11:16 lxpanel
drwx------  2 testuser users    8 Sep  3 11:16 lxterminal
drwxr-xr-x  2 testuser users    8 Sep  3 11:16 openbox
drwxr-xr-x  3 testuser users    8 Sep  3 11:16 pcmanfm
bash-4.2$ whoami
testuser
bash-4.2$

Last edited by Jeebizz; 09-03-2013 at 03:41 PM.
 
Old 09-03-2013, 01:00 PM   #11
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
with testuser do you have still the firefox flashing?

forget about automatic copying, I think I was remembering from the behaviour of a previous lxpanel version or just doing a little confusion, sorry
but still you can copy the /etc/xdg/lxsession directory into ~/.config/ and edit as you like (so it will override the original into /etc): for example you can edit ~/.config/lxsession/LXDE/autostart like this
Code:
#@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE
@xscreensaver -no-splash
@xterm
and at the next X start lxde will start without panel but with an open xterm: into this launch the panel with this command
Code:
lxpanel --profile LXDE
this way you will be able to see the output of lxpanel into the xterm.
if you launch firefox from the panel you will see the output from it into the xterm too (as it will be a subprocess of the panel itself): watch for which output you got when you see the panel flashing.

Last edited by ponce; 09-03-2013 at 01:08 PM.
 
Old 09-03-2013, 02:43 PM   #12
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
That did not work for me. I copied everything to ~/.config , and edited autostart. startx and xterm came up, but as soon as I typed
Code:
lxpanel --profile LXDE
I got an error:

Code:
bash-4.2$ lxpanel --profile LXDE
There is already an instance of LXPanel.  Now to exit
bash-4.2$
This is my autostart, just like yours:

Code:
#@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE
@xscreensaver -no-splash
@xterm
I guess LXDE is still defaulting to the /etc/ directory instead of ~. Thats another thing I noticed with LXDE, not really much in ~ , all settings, wallpapers, etc, are in /etc/.

Last edited by Jeebizz; 09-03-2013 at 02:44 PM.
 
Old 09-03-2013, 03:30 PM   #13
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
you can also exit the running lxpanel with
Code:
lxpanelctl exit
 
Old 09-03-2013, 03:48 PM   #14
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,085

Original Poster
Rep: Reputation: 212Reputation: 212Reputation: 212
Oh ok, well I started it, and I noticed again the programs disappeared in my 'testuser' profile. This is the output:

Code:
bash-4.2$ lxpanel --profile LXDE

(lxpanel:3819): Gtk-CRITICAL **: IA__gtk_container_set_border_width: assertion `GTK_IS_CONTAINER (container)' failed

(lxpanel:3819): Gtk-CRITICAL **: gtk_box_pack: assertion `GTK_IS_BOX (box)' failed

(lxpanel:3819): Gtk-CRITICAL **: gtk_box_pack: assertion `GTK_IS_BOX (box)' failed

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

** (process:3821): WARNING **: removed previous socket file /tmp/.menu-cached-:0-testuser

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE

(lxpanel:3819): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE
I don't know if you can replicate it, but as soon as I launched ksnapshot to take a screencap again, the program listing returned.
 
Old 09-03-2013, 04:29 PM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,478

Rep: Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904Reputation: 904
no, I cannot replicate it.
Code:
(lxpanel:3819): Gtk-CRITICAL **: gtk_box_pack: assertion `GTK_IS_BOX (box)' failed
this is maybe related to the gtk theme
Code:
** (process:3821): WARNING **: removed previous socket file /tmp/.menu-cached-:0-testuser
I think the interesting line (but maybe unrelated to the flashing problem) might be this, so the culprit for the disappearing menu seems menu-cache, but being you the only one reporting this behaviour I tend to believe it's some problem related to your installation.

BTW, I'm testing new packages for slackware64-14.0 ATM, if you feel like to try upgrading them (really dunno if they will solve your problems) they're here (be sure to read README.txt)

http://ponce.cc/slackware/testing/lx...ckware64-14.0/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] My panel icons are all shifted left and open windows aren't mentioned in the panel SharpyWarpy Fedora 0 02-07-2013 09:45 AM
network monitor in lxde panel interndan Linux - Desktop 5 03-31-2012 06:38 PM
Xfce and LXDE Panel Menu Descriptions Woodsman Linux - Desktop 1 05-11-2011 05:56 PM
Opensuse 11.2 lxde or PclinuxOs 2009.4 lxde damipereira Linux - Distributions 1 02-16-2010 03:51 AM


All times are GMT -5. The time now is 09:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration