LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-01-2011, 03:10 AM   #91
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,458

Original Poster
Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888

sorry ricky for the late reply, I missed your message

yes, I reverted this patch and the revert slipped somehow when I updated the script, now should be fixed.

I'm working on some updated LXDE packages for 13.37, stay tuned
 
Old 05-01-2011, 05:09 AM   #92
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
Your latest Slackware64-current packages work beautifully on 13.37 anyway Many thanks!

-A
 
Old 05-01-2011, 10:42 AM   #93
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,458

Original Poster
Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
I hope these work fine too
here is a complete LXDE desktop for slackware 13.37

- slackware-13.37
- slackware64-13.37

be aware that the following packages shouldn't be needed anymore (gvfs, that should have no dependencies, is used by libfm instead of gnome-vfs)
Code:
gnome-mime-data
ORBit2
GConf
libbonobo
gnome-vfs
also, configuration files in /etc are changed so, if you are updating a previous installation, I suggest to have a look at the new ones and customize them accordingly (or something may break ): in this case, also note that some packages finally regained their original name, so no more lxappearance-new, libfm-new, pcmanfm-new and their original counterparts return in the set.

have fun and happy workers day to all

Last edited by ponce; 05-01-2011 at 10:57 AM.
 
Old 05-13-2011, 11:44 AM   #94
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,458

Original Poster
Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
FYI:
In the near future there will be only marginal updates to lxde as in git are being merged some patches for gtk+3 support.
I'm preparing a gtk+3.SlackBuild based on the gtk+2 one by Pat and the one in gnomeslackbuild.org by Steve Kennedy (when it'll hit -current, I'll switch to that) and I'll use it to build and test the new git versions on slackware current: it surely will need some testing/debugging by the lxde people so I think some time will pass before I'll start to use new tarballs to make packages.

Last edited by ponce; 05-13-2011 at 11:52 AM.
 
Old 06-08-2011, 11:22 PM   #95
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 62
ponce, I've just installed your packages in 13.37 and I'm glad to see that LXDE has come a long wat since I last tried it. Thanks for making it available.

There's one thing bothering me, though. I haven't figured out how to start lxterminal in a login shell. I've changed /usr/share/applications/lxterminal.desktop's Exec line to lxterminal -l, but I still keep getting non-login shells. Any ideas?
 
Old 06-09-2011, 12:26 AM   #96
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,458

Original Poster
Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
to do that you need a little trick, because lxterminal invocation expects parameters and seems like there's no configure options to set in ~/.config/lxterminal/lxterminal.conf for that.

create an /usr/bin/lxterminal-login file with this content
Code:
/usr/bin/lxterminal -l "$@"
make it executable and use lxterminal-login in the Exec line of the .desktop file.

you can also copy the pristine to /usr/share/applications/lxterminal-login.desktop, modify it and then load this new desktop file in ~/.config/lxpanel/LXDE/panels/panel, so things can go smoother between package updates

Last edited by ponce; 06-09-2011 at 01:09 AM.
 
1 members found this post helpful.
Old 06-10-2011, 10:44 PM   #97
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 62
Thank you ponce, that did the trick. I am putting the custom settings in /usr/local/share/applications because I find it more pleasant to make such choices valid system-wide.
 
Old 06-26-2011, 03:22 PM   #98
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
Ponce, thanks for your work on bring LXDE to Slackware! I used your guide with a slightly modified version of your queue file on the SBo tree to build my DE.

For the most part everything work really well. One thing that I had to learn is that if you have a custom autostart file at ~/.config/lxsession/LXDE/autostart that it is run in addition to the file at /etc/xdg/lxsession/LXDE/autostart.

There are two issues I am having currently:

1) PCManFM does not mount removable media
When I try to mount something I get a message saying
Quote:
Failed to execute child process "gnome-mount" (No such file or directory)
Is PCManFM not using udisks correctly?


2) Computer lockups
This is not necessarily caused by LXDE, but it only occurs when I am using LXDE. I used KDE4 for a month without this issue. There weren't any helpful messages that I saw in messages, syslog, or Xorg log. I did notice some stability issues when I first started using oxygen-gtk, so perhaps that is related. Or perhaps, the PCManFM problem above is an indicator that something further below is the issue. I used KDE again last night without any problems, so I doubt it is a system wide issue. It is really strange for my Slackware box to be behaving this way! It's usually rock solid.


Below are the LXDE packages that I have installed:
Code:
libatasmart-0.17-i486-1_SBo
sg3_utils-1.31-i486-1_SBo
udisks-1.0.2-i486-1_SBo
upower-0.9.9-i486-1_SBo
leafpad-0.8.18.1-i486-1_SBo
xarchiver-0.5.2-i486-3_SBo
openbox-3.4.11-i486-2_SBo
gpicview-0.2.1-i486-1_SBo
lxappearance-0.5.0-i486-1_SBo
obconf-2.0.3-i486-2_SBo
lxde-common-20110313_736ded3-i486-1_SBo
lxrandr-20100906_9aaca42-i486-1_SBo
lxterminal-0.1.9-i486-1_SBo
menu-cache-0.3.2-i486-1_SBo
lxmenu-data-20100825_5e1e8e1-i486-1_SBo
lxpanel-0.5.6-i486-2_SBo
lxtask-0.1.3-i486-1_SBo
lxpolkit-20100726_0ce3d64-i486-1_SBo
lxsession-0.4.4-i486-1_SBo
lxsession-edit-20100906_0ed54f3-i486-1_SBo
gvfs-1.6.7-i486-1_SBo
libfm-20110316_c604674-i486-1_SBo
pcmanfm-20110316_9c4603d-i486-1_SBo
lxshortcut-20100905_132b97e-i486-1_SBo
lxinput-0.3.0-i486-1_SBo
Note, that I uninstalled lxlauncher, lxmusic (etc), and lxdm since I don't use them.

Thanks again for your help in bringing LXDE to Slackware!

Edit:
I thought I should also mention that I am using the following:
Quote:
oxygen-gtk-1.0.4-i486-1_SBo
GConf-2.32.1-i486-1 (from /extra)

Last edited by shadowsnipes; 06-26-2011 at 03:32 PM.
 
Old 06-26-2011, 03:57 PM   #99
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,458

Original Poster
Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
can it be you got still traces of an old installation of gnome-vfs around: gnome-mount uses hal.
if you don't have a gnome-vfs package still installed, I would check if it behaves the same with a new fresh user account.

if that fails, can you please try to build (temporary remove GConf first) gvfs, libfm and pcmanfm from the following scripts?

http://cgit.ponce.cc/slackbuilds/tre...em/gvfs?h=gvfs
http://cgit.ponce.cc/slackbuilds/tre.../libfm?h=libfm
http://cgit.ponce.cc/slackbuilds/tre...anfm?h=pcmanfm

I strongly doubt lxde can cause any lockups, this is the first report I got about it...

oxygen-gtk should work fine, I'm using it too here (1.0.5)

regarding /etc/xdg/autostart, check that you got polkit-gnome-authentication-agent-1.desktop or lxpolkit.desktop. you can check if the authentication agent started with the command ck-list-sessions: it should show just one session.

Last edited by ponce; 06-26-2011 at 04:34 PM.
 
1 members found this post helpful.
Old 06-26-2011, 10:10 PM   #100
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
Quote:
Originally Posted by ponce View Post
can it be you got still traces of an old installation of gnome-vfs around: gnome-mount uses hal.
if you don't have a gnome-vfs package still installed, I would check if it behaves the same with a new fresh user account.
I have never installed gnome-vfs before. The problem was the same with a new user account.

Quote:
Originally Posted by ponce View Post
if that fails, can you please try to build (temporary remove GConf first) gvfs, libfm and pcmanfm from the following scripts?

http://cgit.ponce.cc/slackbuilds/tre...em/gvfs?h=gvfs
http://cgit.ponce.cc/slackbuilds/tre.../libfm?h=libfm
http://cgit.ponce.cc/slackbuilds/tre...anfm?h=pcmanfm
That fixed it! I suspect the addition of "--disable-hal" in the gvfs build was part of the solution. Either that or something was fixed in those versions. I hope in future versions they make it so that the media unload icon disappears after it is unmounted (like it does in dolphin).

Quote:
Originally Posted by ponce View Post
I strongly doubt lxde can cause any lockups, this is the first report I got about it...

oxygen-gtk should work fine, I'm using it too here (1.0.5)
Went ahead and upgraded to 1.0.5...we'll see how it goes...

Quote:
Originally Posted by ponce View Post
regarding /etc/xdg/autostart, check that you got polkit-gnome-authentication-agent-1.desktop or lxpolkit.desktop. you can check if the authentication agent started with the command ck-list-sessions: it should show just one session.
There was not a problem there. I think I did previously have to make a change earlier to the lxpolkit desktop file so that it did not load in XFCE. OnlyIn=LXDE...I believe you fixed this in your newest SlackBuild.

Thanks again, Ponce!!
 
Old 07-02-2011, 12:14 PM   #101
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,605

Rep: Reputation: 142Reputation: 142
ponce, I just installed your pre-compiled binaries on Slackware64-13.37. Like it!
Thanks for sharing them with us!

One little snag, that I have with some other WMs/DEs, too (so it may be a bit OT, as it is not LXDE specific): The global keyboard setting is not honoured. LXDE always starts up with the default US keyboard, and I have to issue

Code:
$ setxkbmap de nodeadkeys
in order to get my keyboard working properly, although I have selected "de nodeadkeys" already during system installation. As I said: Some DEs use this global setting, others ignore it.

The general question obviously is: Where would I set the keyboard for the machine, globally, so that LXDE and all other WMs/DEs use it?

Cheers

gargamel
 
Old 07-02-2011, 12:58 PM   #102
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 62
@gargamel
This may be a stupid question, but have you looked at /etc/X11/xorg.conf.d/90-keyboard-layout.conf. That's how I got the DEs/WMs to follow my layout. It's in CHANGES-AND-HINTS.TXT
 
1 members found this post helpful.
Old 07-02-2011, 04:37 PM   #103
gargamel
Senior Member
 
Registered: May 2003
Distribution: Slackware, SLAX, OpenSuSE
Posts: 1,605

Rep: Reputation: 142Reputation: 142
Quote:
Originally Posted by bonixavier View Post
@gargamel
This may be a stupid question, but have you looked at /etc/X11/xorg.conf.d/90-keyboard-layout.conf. That's how I got the DEs/WMs to follow my layout. It's in CHANGES-AND-HINTS.TXT
Sometimes I feel, I am so lame...
That did the trick, and I should have known it. Thanks a lot for your patience.

Soemehow I was expecting that setting the keyboard during setup would be good enough, at least 13.37. But obviously this install time setting doesn't affect the 90-keyboard-layout.conf file. It would make sense, though, if it did, I think...

Thanks again!!!

gargamel
 
Old 07-03-2011, 11:28 AM   #104
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
The keyboard setting during setup is for the console keyboard, while the stuff documented in C&H is for X. One of the long-term items on my TODO list is to work up something to hit both of them during setup, but alas, no time.
 
1 members found this post helpful.
Old 07-04-2011, 09:51 PM   #105
shadowsnipes
Senior Member
 
Registered: Sep 2005
Distribution: Slackware
Posts: 1,441

Rep: Reputation: 70
One niggle I noticed recently is that lxpanel freezes when I am using Libreoffice. I can restart it, and then it works again for a bit before freezing again. If I close Libreoffice the freezing stops. It is a weird bug that I hear doesn't happen with LibreOffice 3.4.x....haven't had a chance to test that out yet...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: LXDE, the New Lightweight Linux Desktop LXer Syndicated Linux News 0 04-14-2010 10:40 PM
Do you think LXDE/OpenBox should replace ........ Wm/Desktop in Slackware? samac Slackware 7 03-14-2010 05:24 AM
[SOLVED] lxde desktop program links mark_alfred Linux - Desktop 4 12-22-2009 12:58 PM
[SOLVED] Put icon on Desktop with LXDE? kushalkoolwal Linux - Software 2 08-13-2009 01:27 PM
LXDE Hanging on desktop rightclick yah0m Linux - Desktop 0 07-21-2008 06:14 PM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration