LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-09-2010, 02:22 AM   #31
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886

it should behave correctly without any configuration.

if you've installed all the packages on the download folder on a full slackware -current and you added your user to the default slackware desktop's user groups (it's done during user creation pressing up-arrow when selecting default groups) the only thing I can think of that can cause this behaviour is your ~/.xinitirc file: can you please post it, if you have one in your $HOME?

I have doing my tests starting from a clean ~/.config folder: a thing to check is moving it elsewhere and restart the desktop session...

try also to
Code:
removepkg gnome-vfs
as it shouldn't be needed anymore (also hal shouldn't).

Last edited by ponce; 08-09-2010 at 03:41 AM.
 
Old 08-10-2010, 03:56 AM   #32
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
Here's my ~/.xinitrc:

Code:
bass@Slackware:~$ cat .xinitrc
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# Start the window manager:
if [ -z $DESKTOP_SESSION ]; then
    ck-launch-session startlxde
else
    startlxde
fi
I tried renaming .config/ and restarting, didn't help Sorry for constantly bugging you on this, I'm just out of ideas. Thanks a lot for your help!

-A
 
Old 08-10-2010, 04:59 AM   #33
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
no prob

can you try creating a new user with adduser granting him default permissions for desktop use (if you follow the procedure it will tell you when to press the up arrow) and see if it behaves the same with this new user?

some questions:

- are you using 13.1 or current?

- can you please post the output (maybe on pastebin, posting the resulting link here, can be better) of
Code:
LS_OPTIONS='' ; ls -1 /var/log/packages
 
Old 08-10-2010, 05:00 PM   #34
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
I created a test user and placed it in suggested additional groups (audio, cdrom, floppy, plugdev, video, power, netdev). Still, it's not authorized to mount external drives. It only works well if I log in to LXDE as root.

I'm using a rather up-to-date -current. Here's my list of installed packages:

http://pastebin.com/CuN6CNXg

Thanks!

-A
 
Old 08-11-2010, 01:31 AM   #35
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
at a glance packages should be ok.

but thinking well, I'll think I omitted to say one simple thing that I verified also in my tests, maybe related:

I got problems mounting as a user usb/pendrive partitions that are already in /etc/fstab: try to comment them out if you got them there.

Last edited by ponce; 08-11-2010 at 01:32 AM.
 
Old 08-11-2010, 02:16 AM   #36
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
Wow, haven't edited fstab since Fedora Core 3, ages ago But anyway, there are no entries for any external drive. I even commented out the entry for my DVD drive, but can't mount DVDs either.

Then again, on the previous version of LXDE I was using, automount wasn't supported at all, and I mounted everything by command. Since I was planning on getting a new laptop soon and installing everything from scratch, I guess I can live with this for a couple of weeks. At least my LXDE experience is, as a whole, much nicer..

Many thanks for your packages and support!

-A
 
Old 08-11-2010, 07:49 AM   #37
Pode
LQ Newbie
 
Registered: Oct 2008
Posts: 22

Rep: Reputation: 1
Run in terminal
Code:
ck-list-session
If there are two session than probably that is the problem.
I changed the /etc/X11/xinitrc/xinitrc
This:
Code:
# Start the window manager:
if [ -z $DESKTOP_SESSION ]; then
    ck-launch-session startlxde
else
    startlxde
fi
To this:
Code:
# Start the window manager:
startlxde
And now i have only one ConsoleKit session and mounting is working
 
1 members found this post helpful.
Old 08-11-2010, 05:07 PM   #38
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
Thumbs up

Awesome! That did the trick Thank you very, very much!

Now my Slackware experience is flawless. You guys rock!

-A
 
Old 08-11-2010, 05:16 PM   #39
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Whoa whoa, what DM are you running? If lxdm, does lxdm not set DESKTOP_SESSION in the environment? If not, someone *please* file a bug to make it behave like other dm implementations.
 
Old 08-11-2010, 05:32 PM   #40
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
I haven't hit this cause I always use runlevel 3

btw tnx Pode for identifying another problem
 
Old 08-12-2010, 12:48 AM   #41
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Rep: Reputation: 41
rworkman, I'm using lxdm, and
Code:
$ echo $DESKTOP_SESSION
returns 'LXDE', both with my old and new xinitrc. There doesn't seem to be a problem there. Or did you mean something else?

-A
 
Old 08-12-2010, 07:58 AM   #42
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
I found something in lxdm.c: looks like DESKTOP_SESSION is passed to env only if PAM is used.

excuse my n00bness robby, should I report pcman that maybe it's needed also in no-PAM situations?

Last edited by ponce; 08-12-2010 at 08:00 AM.
 
Old 08-12-2010, 10:10 AM   #43
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Well, I'm not sure, since I haven't used all of this (and won't have time to even download it, much less install it, in the near future). That certainly appears to be the case though.

I can't help but wonder if the $HOME copy of xinitrc and the system copy were out of sync though -- i.e. the copy at $HOME/.xinitrc still had the hardcoded use of ck-launch-session (without checking for DESKTOP_SESSION), while the system copy (in /etc/X11/xinit/) had the proper checking. The copy in $HOME doesn't get updated unless you re-run xwmconfig.

That being said, I don't think that's relevant with lxdm being used, so maybe we're just back where we started :-)
 
Old 08-13-2010, 12:59 AM   #44
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
they suggest to use XDG_SESSION_COOKIE.

NOTE to all: if you want to try this stuff with qemu/kvm, be sure to set in your guest's /etc/X11/xorg.conf file
Code:
DefaulthDepth 16
or, with default 24, you will hit a bug with qemu's cirrus emulated graphic board and openbox.

Last edited by ponce; 08-13-2010 at 01:27 AM.
 
Old 08-18-2010, 09:32 AM   #45
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,457

Original Poster
Rep: Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886Reputation: 886
added xmms2, lxpanel-xmms2, lxmusic, gtknetcat and lxadmin (from sidux, now on the official lxde git), to complete the LXDE components + updated thingies to latest git status + fixed xinitrc.lxde:

http://ponce.cc/slackware/testing/lxde-git/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: LXDE, the New Lightweight Linux Desktop LXer Syndicated Linux News 0 04-14-2010 10:40 PM
Do you think LXDE/OpenBox should replace ........ Wm/Desktop in Slackware? samac Slackware 7 03-14-2010 05:24 AM
[SOLVED] lxde desktop program links mark_alfred Linux - Desktop 4 12-22-2009 12:58 PM
[SOLVED] Put icon on Desktop with LXDE? kushalkoolwal Linux - Software 2 08-13-2009 01:27 PM
LXDE Hanging on desktop rightclick yah0m Linux - Desktop 0 07-21-2008 06:14 PM


All times are GMT -5. The time now is 05:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration