LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-31-2005, 07:23 AM   #16
props666999
Member
 
Registered: Oct 2003
Location: Greece
Posts: 260

Original Poster
Rep: Reputation: 30

keefaz i did it and modules are listed as normal but this Used by
still shows just - and iv tried to man lsmod to see what it means
and man pages are broken , i know when recompile kernel it usual brakes do you know which tgz package is required to restore

the man pages

Many Thanks
 
Old 05-31-2005, 07:59 AM   #17
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Try upgrade your udev package
 
Old 05-31-2005, 08:42 AM   #18
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
does it work?

Hey there,

Does it work already ?
I've got the exact same problem after buildig a kernel for Slackware 10.1.
Hotplug doesn't load modules, after starting modules that should be loaded aren't loaded, it uses the new kernel, lilo config is ok etc...
With the standard kernel modules ARE loaded. (Yet while screwing around I broke this too ... oh well )

I can also manually load certain modules yet I've got now idea why hotplug does not load modules.
I'm gonna try some of the advice here this evening. If it works I'll post it.

grtz

Last edited by svu; 10-02-2011 at 07:24 AM.
 
Old 05-31-2005, 01:52 PM   #19
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Well after all I got it working. Just had to select the RIGHT driver in de kernelconfig
phew!!

cya
 
Old 05-31-2005, 03:43 PM   #20
props666999
Member
 
Registered: Oct 2003
Location: Greece
Posts: 260

Original Poster
Rep: Reputation: 30
keefaz i upgraded udev package and everything works fine


Thanks


About alsa . I ran alsaconfig as root , found the module and sound works fine . I reboot and i have the same problem as many people

here . I know everything is unmuted and then alsactl store to store the settings . when i reboot i need to alsaconfig again to be
able to listen to music . What i did was to save alsactl restore within /rc.d/rc.local and make it executable . But it doesn't work
So far this is what i have found in similar posts

Any clue how to sort it out

Many Thanks all of you
 
Old 05-31-2005, 05:38 PM   #21
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Does alsamixer work ?
If not your should try to blacklist the module in de hotlplug config files blacklist.
After this try to reboot and run alsaconf and alsamixer to unmute everything.
Do the alsactl store thingy.
This worked for me.

grtz
 
Old 05-31-2005, 09:34 PM   #22
props666999
Member
 
Registered: Oct 2003
Location: Greece
Posts: 260

Original Poster
Rep: Reputation: 30
alsamixer works and volume is unmuted as well
 
Old 06-01-2005, 03:03 AM   #23
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Quote:
Originally posted by props666999
keefaz i upgraded udev package and everything works fine


Thanks


About alsa . I ran alsaconfig as root , found the module and sound works fine . I reboot and i have the same problem as many people

here . I know everything is unmuted and then alsactl store to store the settings . when i reboot i need to alsaconfig again to be
able to listen to music . What i did was to save alsactl restore within /rc.d/rc.local and make it executable . But it doesn't work
So far this is what i have found in similar posts

Any clue how to sort it out

Many Thanks all of you
Does the alsactl restore fail with an error ?
(maybe you can find something out with "dmesg")

grtz
 
Old 06-01-2005, 07:39 AM   #24
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Try to delete /etc/asound.state, then run
alsaconf (as root), alsamixer (as user), alsactl store (as root)
 
Old 06-01-2005, 10:35 AM   #25
props666999
Member
 
Registered: Oct 2003
Location: Greece
Posts: 260

Original Poster
Rep: Reputation: 30
i did it and still no progress
the dmsge reports the following :

Code:
 Advanced Linux Sound Architecture Driver Version 1.0.8 (Thu Jan 13 09:39:32 2005 UTC).
ALSA device list:
  No soundcards found.
 
Old 06-01-2005, 12:54 PM   #26
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Is your soundcard module not loaded ? (lsmod)
Can you load it manually ? (modprobe)

Does hotlplug find anything of could you configure the module to load in rc.modules ?

grtz
 
Old 06-01-2005, 12:54 PM   #27
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Make sure you've the file /etc/rc.d/rc.alsa as executable or your mixer settings won't be loaded on startup
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lsmod does not show all modules shanenin Linux - Software 2 04-14-2004 09:26 AM
lsmod reveals no loaded modules after new kernel src install... jdaniel Linux - General 1 03-01-2004 10:50 AM
lsmod shoot2kill Linux - General 5 04-29-2002 10:42 PM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - General 1 01-24-2002 02:50 AM
Re: modprobe: Note: /etc/modules.conf is more recent than lib/modules/2.4.9/modules.d Andy.M Linux - Newbie 2 01-24-2002 02:40 AM


All times are GMT -5. The time now is 10:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration