LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2010, 07:28 PM   #16
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 254

Rep: Reputation: 40

I have not used this script in several months and I can not remember. I do know that you need to cut and past it into kwrite and then save it with a title like sound or etc. then you need to make it executable by doing a " chmod +x sound " then I just do not remember from there but I believe that you will need to do a "./sound " to execute it. I am sure that someone will chime in with more knowledge of script writing than I have. I have been using it and it works well, it will give you more volume than you need on most any computer.
 
Old 07-19-2010, 05:32 AM   #17
Gavin Harper
Member
 
Registered: Feb 2010
Location: Finland
Distribution: Slackware
Posts: 169

Rep: Reputation: 24
run 'alsamixer' (no quotes) in terminal and boost the volume there...

then run 'rexima' and do the same.
 
Old 07-19-2010, 11:25 AM   #18
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Rep: Reputation: 23
Quote:
Originally Posted by zrdc28 View Post
I have not used this script in several months and I can not remember. I do know that you need to cut and past it into kwrite and then save it with a title like sound or etc. then you need to make it executable by doing a " chmod +x sound " then I just do not remember from there but I believe that you will need to do a "./sound " to execute it. I am sure that someone will chime in with more knowledge of script writing than I have. I have been using it and it works well, it will give you more volume than you need on most any computer.
While I never compared the volume in Windows to Slackware, the volume on my current notebook is way lower than it was with my previous. I know different machines have different hardware, but even using the headphone jack the volume was really low. Anyway, I will try this bit of code out myself when I get home. If I see it right, it is actually NOT a script but a config file that you can put in either /etc/asoundrc for global settings or ~/.asoundrc for specific user. I currently have a basic asoundrc to get my HDMI working and it looks very similar to this code.
 
Old 07-24-2010, 06:41 PM   #19
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 254

Rep: Reputation: 40
Increase volumn with kmix

This is the way to install the script or conf file whichever it is, either way it just works'

Open kwrite, copy & paste the file into kwrite. Now save the file at /etc/asound.conf. The asound.conf was not there in slack 13.1 so kwrite created it. /etc/ is the directory, asound.conf is the new file name. You must reboot and maybe even stop/restart kmix for it to work, there will be a preamp slider on kmix now, just slide it to where you need it.

Here is some real good info on this subject.

http://alsa.opensrc.org/index.php/Ho..._master_volume



pcm.!default {
type plug
slave.pcm "softvol"
}
pcm.softvol {
type softvol
slave {
pcm "dmix"
}
control {
name "Pre-Amp"
card 0
}
min_dB -5.0
max_dB 20.0
resolution 6
}

Last edited by zrdc28; 07-25-2010 at 09:08 AM.
 
Old 08-05-2010, 05:41 AM   #20
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,335

Rep: Reputation: Disabled
Quote:
Originally Posted by Finlay View Post
how do you run this script?
thanks
I think this problem is annoying enough for a lot of users, so I added some more detail here: http://alien.slackbook.org/blog/addi...-sound-levels/

Eric
 
1 members found this post helpful.
Old 08-05-2010, 07:48 AM   #21
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
I can not get Kmix to display the pre-amp slider. It is not in the list of Available Channels. My /etc/asound.conf file is a straight copy/paste of the code here. I have restarted the machine as instructed. I am running 13.1_64. I have an Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03). A screenshot of my mixer windows is shown below. Any ideas?

Thanks,
Eric

snapshot1.png
 
Old 08-05-2010, 08:21 AM   #22
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,335

Rep: Reputation: Disabled
When you change "type plug" to "type hw" and then restart the computer, does the Pre-Amp control appear?

Eric
 
Old 08-05-2010, 06:55 PM   #23
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
No hw does not make Pre-amp available. I just noticed that I have a file asound.state with the following contents:

Code:
state.Intel {
        control.1 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -3450
                comment.dbmax 1200
                iface MIXER
                name 'Master Front Playback Volume'
                value.0 31
                value.1 31
        }
        control.2 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Master Front Playback Switch'
                value.0 true
                value.1 true
        }
        control.3 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 42'
                comment.dbmin -6300
                comment.dbmax 0
                iface MIXER
                name 'Front Playback Volume'
                value.0 21
                value.1 21
        }
        control.4 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Front Playback Switch'
                value.0 true
                value.1 true
        }
        control.7 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -3450
                comment.dbmax 1200
                iface MIXER
                name 'Mic Playback Volume'
                value.0 0
                value.1 0
        }
        control.8 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Mic Playback Switch'
                value.0 false
                value.1 false
        }
        control.9 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -3450
                comment.dbmax 1200
                iface MIXER
                name 'Front Mic Playback Volume'
                value.0 0
                value.1 0
        }
        control.10 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Front Mic Playback Switch'
                value.0 false
                value.1 false
        }
        control.11 {
                comment.access 'read write'
                comment.type ENUMERATED
                comment.count 1
                comment.item.0 OFF
                comment.item.1 ON
                iface MIXER
                name 'Independent HP'
                value OFF
        }
        control.12 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 1
                iface MIXER
                name 'Smart 5.1'
                value true
        }
        control.13 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -1650
                comment.dbmax 3000
                iface MIXER
                name 'Capture Volume'
                value.0 0
                value.1 0
        }
        control.14 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Capture Switch'
                value.0 true
                value.1 true
        }
        control.15 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -1650
                comment.dbmax 3000
                iface MIXER
                name 'Capture Volume'
                index 1
                value.0 0
                value.1 0
        }
        control.16 {
                comment.access 'read write'
                comment.type BOOLEAN
                comment.count 2
                iface MIXER
                name 'Capture Switch'
                index 1
                value.0 true
                value.1 true
        }
        control.17 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 3'
                comment.dbmin 0
                comment.dbmax 3075
                iface MIXER
                name 'Mic Boost Capture Volume'
                value.0 0
                value.1 0
        }
        control.18 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 3'
                comment.dbmin 0
                comment.dbmax 3075
                iface MIXER
                name 'Front Mic Boost Capture Volume'
                value.0 0
                value.1 0
        }
        control.19 {
                comment.access 'read write'
                comment.type ENUMERATED
                comment.count 1
                comment.item.0 'Stereo Mixer'
                comment.item.1 Mic
                comment.item.2 'Front Mic'
                iface MIXER
                name 'Input Source'
                value 'Stereo Mixer'
        }
}
perhaps I have to add a control.20?
 
Old 08-06-2010, 04:17 AM   #24
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
Quote:
Originally Posted by em21701 View Post
No hw does not make Pre-amp available. I just noticed that I have a file asound.state with the following contents:

Code:
state.Intel {
        control.1 {
                comment.access 'read write'
                comment.type INTEGER
                comment.count 2
                comment.range '0 - 31'
                comment.dbmin -3450
                comment.dbmax 1200
                iface MIXER
                name 'Master Front Playback Volume'
                value.0 31
                value.1 31
        }

[snipped the rest off ...]
I have a very similar asound.state for my card, which is also recognized as "Intel" (the Chip is a "Realtek ALC268"). And I have the same problem with the softvol plug -- no matter if I call it "plug" or "hw", I don't get an extra volume slider.

EDIT: Somehow ALSA has a problem with this card. dmix is not working, too, when I try "speaker-test". The second instance just tells me that the resource is busy.

Last edited by titopoquito; 08-06-2010 at 04:21 AM.
 
Old 08-06-2010, 12:49 PM   #25
Munra
LQ Newbie
 
Registered: Mar 2008
Location: Colombia
Distribution: slackware64 14
Posts: 27

Rep: Reputation: 1
ncmpcpp dont work with that

Quote:
Originally Posted by em21701 View Post
I can not get Kmix to display the pre-amp slider. It is not in the list of Available Channels. My /etc/asound.conf file is a straight copy/paste of the code here. I have restarted the machine as instructed. I am running 13.1_64. I have an Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03). A screenshot of my mixer windows is shown below. Any ideas?

Thanks,
Eric

Attachment 4245
I have the same video card:
Code:
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
and Slackware 13.1 64-bit x86_64, with multilib.

and i first try with the
Code:
type plug
reboot and .... didn't work, so i try with the
Code:
type hw
reboot and didn't work.

Was late so i turn off my laptop a go to sleep, then when i come back to my laptop, i launch ncmpcpp and didn't work, so i try to use the command play and didn't either. So i went to alsamixer and see the Pre-Amp thing, i wasn't expecting that, Then i edit the file
Code:
vim /etc/asound.conf
and change, again,
Code:
type hw
for
Code:
type plug
reboot a there it is. It's amazing how much sound i was wasting in my laptop.

With the happiness of have the things working, i went back to ncmpcpp and works, but the volume was to high, and when i try to change the volume (you know with the arrow keys) didn't work now a can't change the volume inside the ncmpcpp will i have to go to alsamixer for that? i don't thing so, so much work, so i remove the /etc/asound.conf and reboot, just for see if that was the problem, and yes that's the problem.

Anyone have a suggestion for this problem?, with the ncmpcpp volume that don't work with the asound.conf fix of this thread.

Last edited by Munra; 08-06-2010 at 12:55 PM.
 
Old 08-06-2010, 08:14 PM   #26
em21701
Member
 
Registered: Feb 2008
Location: Rhode Island, USA
Distribution: Slackware12.2 & Slackware64-13
Posts: 247

Rep: Reputation: 40
Munra,
After reading your post I checked alsamixer again and there it was! I still don't have it in Kmix but I cranked it all the way up and stored it....nice now I can make some noise.
 
Old 08-06-2010, 09:06 PM   #27
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
I cannot tell what made it, but there it is too. Call it the pre-amplifier magic

Either it was jumping through the alsamixer play/record/all settings with the tab key or loading the sound module with an option for my laptop. Or my computer is just fooling me, that is what I suspect.
 
  


Reply

Tags
increase, kmix, laptop


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card deepclutch Linux - Hardware 3 09-29-2010 02:54 PM
Lenovo laptop sound low volume/Output rakris Linux - Laptop and Netbook 14 04-15-2008 04:30 AM
LXer: Jisus Laptop: 8.9" Low-cost Laptop For 300EUR LXer Syndicated Linux News 0 04-08-2008 06:00 PM
Low sound from speakers/ No sound from headphone jack with Intel ICH8 Family Audio troydclayton Linux - Hardware 2 03-28-2008 11:18 PM
Low quality sound with ALSA on a Laptop don_eros Linux - Newbie 0 05-23-2004 02:18 PM


All times are GMT -5. The time now is 07:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration