LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-18-2010, 01:46 PM   #1
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Low sound in Laptop


Using Dell Inspiron 1564. In windows 7 and other distros like ubuntu,openSUSE sound was perfect. However the sound here is pretty low. Not sure if there's some configuration I am missing. I ran alsaconf, maxed out the bars in alsamixer and did a alsactl store. But the sound is still low.

Code:
# lspci | grep Aud
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
02:00.1 Audio device: ATI Technologies Inc RV710/730
Any guidance is deeply appreciated.
 
Old 05-18-2010, 02:35 PM   #2
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,007

Rep: Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742Reputation: 742
If you're running KDE, have you turned up the volume control (should be on the right-hand side of the panel, looks like a speaker)?
 
Old 05-18-2010, 11:04 PM   #3
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by tronayne View Post
If you're running KDE, have you turned up the volume control (should be on the right-hand side of the panel, looks like a speaker)?
Yes kmix is full up. PCM, Master and speaker.
 
Old 05-18-2010, 11:16 PM   #4
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
I would be interested in what you find, as I have noticed the sound is a lot lower then general under Slack (can't say if it is true for other distros or not).
 
Old 05-19-2010, 04:29 AM   #5
GazL
Senior Member
 
Registered: May 2008
Posts: 3,323

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
I've had this issue for years. Alsa sound has always been of lesser volume than I can achieve with Windows or even OpenBSD on the same hardware even when alsa sliders are all to the max. Never found a satisfactory solution.

I think a lot of it is down to dmix software mixing. Slackware seems to use dmix by default in order to allow multiple sounds to play at once, but there's a definite loss of volume because of it.

If I configure my MPD music player daemon to use the alsa "hw:0" device directly, volume is significantly louder than when I let it default. The problem with this is that if the alsa driver for your hardware doesn't support mixing in hardware (like mine doesn't) it restricts you to playing only one sound source at a time.

Maybe the fact that other distros use sound daemons allows them to avoid this problem by giving the sound daemon exclusive use of the sound device, but then you have all the other issues relating to use of sound daemons to deal with such as reliability/latency.

The real answer is probably to put my hand in my pocket and buy a good soundcard (or just use Windows! ) that alsa supports hardware mixing on rather than relying on this on-board junk but when Windows manages just fine on the same hardware, I don't see why I should have too add another card.

Last edited by GazL; 05-19-2010 at 05:16 AM.
 
Old 05-19-2010, 04:54 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,179

Rep: Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527
I had this and someone told me about the python script they had on alsaproject.org for manipulating the privates of a HDA Intel type soundcard. A while spent turning things on, off, up & down got me a stand-off I'm happy with.
 
Old 05-19-2010, 05:04 AM   #7
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by business_kid View Post
I had this and someone told me about the python script they had on alsaproject.org for manipulating the privates of a HDA Intel type soundcard. A while spent turning things on, off, up & down got me a stand-off I'm happy with.
I suppose you don't have the script anymore?
Anyway, @Gazl,
Did you use pulseaudio or anything else to check if it works better? I will be trying out then..

I actually came accross Eric's blogpost and thought I had to tweak something: http://alien.slackbook.org/blog/upgr...epc-to-2-6-33/

But I suppose there is a possible solution since I can gurantee that I tried out Ubuntu 10.04 and sound was as loud as in 7! So there has to be some solution.

Last edited by ~sHyLoCk~; 05-19-2010 at 05:06 AM.
 
Old 05-19-2010, 05:17 AM   #8
GazL
Senior Member
 
Registered: May 2008
Posts: 3,323

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
Added a bit of detail to my post above as an afterthought.
 
Old 05-19-2010, 12:44 PM   #9
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
So there is no solution? Seriously? And I was kinda looking forward to using slack in my new lappy. Oh well. If someone finds a solution please do post it here. I am subscribing to this thread.
much appreciated!
 
Old 05-20-2010, 03:17 AM   #10
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,179

Rep: Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527Reputation: 527
I believe it is all in alsa.conf. I actually do have the scripts. Replace the _ in my handle with a '.' and send me a mail at gmail and I will attach them to a reply
 
Old 05-20-2010, 03:25 AM   #11
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,216

Rep: Reputation: 177Reputation: 177
We'll here is one explanation. Other distros use pulseaudio to do the sound mixing and I believe with this use can increase the volume to higher levels (citation?). However Slack uses alsa's own mixer (unless you have a soundcard with a hardware mixer) so in essence its really a alsa problem and not a slackware problem. Sound has always been this way on alsa, you can google it and its been a problem for a while.

You could also try OSS4. Dugan has builds at slackbuilds.org I found the sound more to my liking but my card was lacking a few features so I switched back to alsa.
 
Old 05-20-2010, 03:48 AM   #12
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
It isnt a solution, but for watching movies with mplayet I add:

-af volume=+10db


which makes any movie more than loud enough to watch. I don't have it louder than I would under windows or so, so no chance of the speakers blowing out.
 
Old 05-21-2010, 11:16 PM   #13
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Rep: Reputation: 40
Here is a script that will increase volume in kmix to louder than you want. After you run it go back to kmix and you will find a preamp setting, just move the slider up. I am not the author but it works for me.

pcm.!default {
type plug
slave.pcm "softvol"
}

pcm.softvol {
type softvol
slave {
pcm "dmix"
}
control {
name "Pre-Amp"
card 0
}
min_dB -5.0
max_dB 20.0
resolution 6
}
 
Old 05-22-2010, 12:52 AM   #14
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Original Poster
Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by zrdc28 View Post
Here is a script that will increase volume in kmix to louder than you want. After you run it go back to kmix and you will find a preamp setting, just move the slider up. I am not the author but it works for me.

pcm.!default {
type plug
slave.pcm "softvol"
}

pcm.softvol {
type softvol
slave {
pcm "dmix"
}
control {
name "Pre-Amp"
card 0
}
min_dB -5.0
max_dB 20.0
resolution 6
}

Ok this works but this won't kill my soundcard right? Kinda worried about that. But atleast the sound is louder now! Setting Pre-Amp to mid range works well.
@josh000

You should try this.
 
Old 07-17-2010, 04:14 PM   #15
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
how do you run this script?
thanks
 
  


Reply

Tags
increase, kmix, laptop


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
relatively low sound volume with ALC662 HDA(Realtek) onboard Sound card deepclutch Linux - Hardware 3 09-29-2010 01:54 PM
Lenovo laptop sound low volume/Output rakris Linux - Laptop and Netbook 14 04-15-2008 03:30 AM
LXer: Jisus Laptop: 8.9" Low-cost Laptop For 300EUR LXer Syndicated Linux News 0 04-08-2008 05:00 PM
Low sound from speakers/ No sound from headphone jack with Intel ICH8 Family Audio troydclayton Linux - Hardware 2 03-28-2008 10:18 PM
Low quality sound with ALSA on a Laptop don_eros Linux - Newbie 0 05-23-2004 01:18 PM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration