LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Low sound in Laptop (http://www.linuxquestions.org/questions/slackware-14/low-sound-in-laptop-808663/)

~sHyLoCk~ 05-18-2010 02:46 PM

Low sound in Laptop
 
Using Dell Inspiron 1564. In windows 7 and other distros like ubuntu,openSUSE sound was perfect. However the sound here is pretty low. Not sure if there's some configuration I am missing. I ran alsaconf, maxed out the bars in alsamixer and did a alsactl store. But the sound is still low.

Code:

# lspci | grep Aud
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
02:00.1 Audio device: ATI Technologies Inc RV710/730

Any guidance is deeply appreciated.

tronayne 05-18-2010 03:35 PM

If you're running KDE, have you turned up the volume control (should be on the right-hand side of the panel, looks like a speaker)?

~sHyLoCk~ 05-19-2010 12:04 AM

Quote:

Originally Posted by tronayne (Post 3973122)
If you're running KDE, have you turned up the volume control (should be on the right-hand side of the panel, looks like a speaker)?

Yes kmix is full up. PCM, Master and speaker.

Josh000 05-19-2010 12:16 AM

I would be interested in what you find, as I have noticed the sound is a lot lower then general under Slack (can't say if it is true for other distros or not).

GazL 05-19-2010 05:29 AM

I've had this issue for years. Alsa sound has always been of lesser volume than I can achieve with Windows or even OpenBSD on the same hardware even when alsa sliders are all to the max. Never found a satisfactory solution. :(

I think a lot of it is down to dmix software mixing. Slackware seems to use dmix by default in order to allow multiple sounds to play at once, but there's a definite loss of volume because of it.

If I configure my MPD music player daemon to use the alsa "hw:0" device directly, volume is significantly louder than when I let it default. The problem with this is that if the alsa driver for your hardware doesn't support mixing in hardware (like mine doesn't) it restricts you to playing only one sound source at a time.

Maybe the fact that other distros use sound daemons allows them to avoid this problem by giving the sound daemon exclusive use of the sound device, but then you have all the other issues relating to use of sound daemons to deal with such as reliability/latency.

The real answer is probably to put my hand in my pocket and buy a good soundcard (or just use Windows! ;) ) that alsa supports hardware mixing on rather than relying on this on-board junk but when Windows manages just fine on the same hardware, I don't see why I should have too add another card.

business_kid 05-19-2010 05:54 AM

I had this and someone told me about the python script they had on alsaproject.org for manipulating the privates of a HDA Intel type soundcard. A while spent turning things on, off, up & down got me a stand-off I'm happy with.

~sHyLoCk~ 05-19-2010 06:04 AM

Quote:

Originally Posted by business_kid (Post 3973826)
I had this and someone told me about the python script they had on alsaproject.org for manipulating the privates of a HDA Intel type soundcard. A while spent turning things on, off, up & down got me a stand-off I'm happy with.

I suppose you don't have the script anymore? :(
Anyway, @Gazl,
Did you use pulseaudio or anything else to check if it works better? I will be trying out then..

I actually came accross Eric's blogpost and thought I had to tweak something: http://alien.slackbook.org/blog/upgr...epc-to-2-6-33/

But I suppose there is a possible solution since I can gurantee that I tried out Ubuntu 10.04 and sound was as loud as in 7! So there has to be some solution.

GazL 05-19-2010 06:17 AM

Added a bit of detail to my post above as an afterthought.

~sHyLoCk~ 05-19-2010 01:44 PM

So there is no solution? Seriously? :( And I was kinda looking forward to using slack in my new lappy. Oh well. If someone finds a solution please do post it here. I am subscribing to this thread. :)
much appreciated!

business_kid 05-20-2010 04:17 AM

I believe it is all in alsa.conf. I actually do have the scripts. Replace the _ in my handle with a '.' and send me a mail at gmail and I will attach them to a reply

Daedra 05-20-2010 04:25 AM

We'll here is one explanation. Other distros use pulseaudio to do the sound mixing and I believe with this use can increase the volume to higher levels (citation?). However Slack uses alsa's own mixer (unless you have a soundcard with a hardware mixer) so in essence its really a alsa problem and not a slackware problem. Sound has always been this way on alsa, you can google it and its been a problem for a while.

You could also try OSS4. Dugan has builds at slackbuilds.org I found the sound more to my liking but my card was lacking a few features so I switched back to alsa.

Josh000 05-20-2010 04:48 AM

It isnt a solution, but for watching movies with mplayet I add:

-af volume=+10db


which makes any movie more than loud enough to watch. I don't have it louder than I would under windows or so, so no chance of the speakers blowing out.

zrdc28 05-22-2010 12:16 AM

Here is a script that will increase volume in kmix to louder than you want. After you run it go back to kmix and you will find a preamp setting, just move the slider up. I am not the author but it works for me.

pcm.!default {
type plug
slave.pcm "softvol"
}

pcm.softvol {
type softvol
slave {
pcm "dmix"
}
control {
name "Pre-Amp"
card 0
}
min_dB -5.0
max_dB 20.0
resolution 6
}

~sHyLoCk~ 05-22-2010 01:52 AM

Quote:

Originally Posted by zrdc28 (Post 3977242)
Here is a script that will increase volume in kmix to louder than you want. After you run it go back to kmix and you will find a preamp setting, just move the slider up. I am not the author but it works for me.

pcm.!default {
type plug
slave.pcm "softvol"
}

pcm.softvol {
type softvol
slave {
pcm "dmix"
}
control {
name "Pre-Amp"
card 0
}
min_dB -5.0
max_dB 20.0
resolution 6
}


Ok this works but this won't kill my soundcard right? Kinda worried about that. But atleast the sound is louder now! Setting Pre-Amp to mid range works well.
@josh000

You should try this.

Finlay 07-17-2010 05:14 PM

how do you run this script?
thanks


All times are GMT -5. The time now is 03:16 PM.