LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2008, 08:12 AM   #1
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Rep: Reputation: 31
Low nvidia driver performance on 2.6.25 (mplayer)


Slackware 12.0
Galaxy 7300GT
MB: Asrock i945G
Driver: 173.14.05
Kernel: 2.6.25.6

Hello,
I upgraded my kernel from 2.6.23.9 to 2.6.25.6. I was using the Nvidia driver 100.14.19, but it won't compile on my new kernel. I've got an error about kernel output build and src directory being wrong. I'm wiriting manually correct paths with --kernel-*-path=... and I'm getting that error again.
I've abandoned that driver and downloaded the latest version - 173.14.05. It has builded fine and now I'm using it.
However when I'm watching a movie on mplayer, the picture freezes for a moment. That is happening once per minute or two and it is really annoying.
Also mplayer gives this warning:
Code:
           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.
Omg, I haven't seen this thing from the time I was playing movies on my old Celeron 500MHz... Earlier (before I got that 7300GT) I was using the integrated video card GMA950 which is on my MB and I haven't seen such warning even there.

I've read that the old Nvidia drivers are incompatible with kernel 2.6.25. Is there a real reason for that?
Can 173.14.05 performance be fixed with some patch/trick?
 
Old 06-12-2008, 09:06 AM   #2
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,766

Rep: Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467Reputation: 1467
Quote:
Try a different -vo driver (-vo help for a list)!
Start there. See if the xv, gl2 or gl drivers (in that order) are available to MPlayer. Then use them with, say, "mplayer -vo xv". If one works, make it permanent by adding, say, "vo=xv" to your ~/.mplayer/config.
 
Old 06-12-2008, 10:10 AM   #3
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
I tried xv and it was fine. Then I looked which is the default video output (in ~/.mplayer/config) and it was x11. I tried back with x11 and it was fine again. Ofcourse I'm testing the same scene from the same movie.
Maybe the performance drop was not from the video driver, but from something else in the system? I'm playing the movie from my hard drive, so it is not from slow media like CD or network.
It can be from broken avi file as well. Now I'm downloading some dynamic movies like Armageddon to test with.
 
Old 06-14-2008, 06:07 PM   #4
Anithen
Member
 
Registered: Aug 2003
Location: Florida
Distribution: Slackware 12, Slackware 12.1, Slackware 12.2
Posts: 105

Rep: Reputation: 15
Just to add to the good help already provided -- if you need a full list of vo options available on your system, you can use -vo help.
 
Old 06-15-2008, 11:21 AM   #5
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
Okay, there is something else.
I've just find that running Diablo 2 under Wine is not going well. Game is playable, but the resolution is odd. When playing on 640x480 it is fine, but when using 800x600... the bottom end of the screen is pulled under the bottom of the viewable surface of my monitor. Like it is 800x800 instead of 800x600. All objects are also verticaly stretched.
I can run my desktop at 800x600 using xrandr, but it doesn't affect the game. When I run it trough wine, it changes the resolution to that weird value.
 
Old 06-15-2008, 12:14 PM   #6
Oliver_H
Member
 
Registered: May 2008
Distribution: Slackware, FreeBSD
Posts: 47

Rep: Reputation: 16
http://www.nvnews.net/vbulletin/foru...p?s&forumid=14

Seems there are many problems with the latest nVidia driver, especially with OpenGl.
 
Old 06-17-2008, 05:36 AM   #7
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
The next .09 driver is out I will try it now.
-----
Nope, the problem with Diablo 2 still persist.

Last edited by ivanatora; 06-17-2008 at 05:46 AM.
 
Old 06-20-2008, 12:29 PM   #8
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
So far I've found that xrandr changes resolution to wrong number.
When I try:
xrandr --output default --mode 800x600
it actually changes to 640x512 (or 800x512?).
Here is some output:
Code:
(20:27:28)[ivanatora@~]$ xrandr                                                                                      
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    51.0  
   1280x960       52.0  
   1152x864       53.0     54.0  
   1024x768       55.0     56.0     57.0  
   896x672        58.0  
   832x624        59.0  
   800x600        60.0     61.0     62.0     63.0     64.0     65.0  
   800x512        66.0  
   640x512        67.0     68.0  
   640x480        69.0     70.0     71.0     72.0  
   576x432        73.0  
   512x384        74.0     75.0     76.0  
   416x312        77.0  
   400x300        78.0     79.0     80.0     81.0  
   320x240        82.0     83.0     84.0
So that is not actually Diablo or wine problem, but Nvidia + xrandr?

Last edited by ivanatora; 06-20-2008 at 12:36 PM.
 
Old 06-20-2008, 01:26 PM   #9
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,263

Rep: Reputation: 648Reputation: 648Reputation: 648Reputation: 648Reputation: 648Reputation: 648
I don't think this specifically relates to your problem, but nVidia + xrandr is indeed a little weird. This page explains what happens:
Quote:
Why is the refresh rate not reported correctly by utilities that use the XRandR X extension (e.g., the GNOME "Screen Resolution Preferences" panel, `xrandr -q`, etc)?

The XRandR X extension is not presently aware of multiple display devices on a single X screen; it only sees the MetaMode bounding box, which may contain one or more actual modes. This means that if multiple MetaModes have the same bounding box, XRandR will not be able to distinguish between them.

In order to support DynamicTwinView, the NVIDIA X driver must make each MetaMode appear to be unique to XRandR. Presently, the NVIDIA X driver accomplishes this by using the refresh rate as a unique identifier.

You can use `nvidia-settings -q RefreshRate` to query the actual refresh rate on each display device.

This behavior can be disabled by setting the X configuration option "DynamicTwinView" to FALSE.
However, that has nothing to do with resolution, so I don't think that has much of an impact on your problem. I haven't tried the 2.6.25 kernel (I'm sticking with the default 2.6.24.5-smp kernel in Slackware 12.1 for now, using the 173.14.05 drivers), but I don't have any problems with mplayer.
 
Old 06-27-2008, 02:31 PM   #10
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
So the problem is not with mplayer - the performance is fine. The problem is with switching resolutions, and that 800x600 is not switched properly.
Let me see the frequency... According to my monitor OSD it is 60Hz. When I try switching to 800x600 it is still 60Hz, and I don't find anything odd in that.
TwinView is disabled, and I have only one monitor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System Performance is low Indianblues Linux - Newbie 5 04-19-2008 08:16 PM
Possible Radeon 9800 driver issues, really low performance (other causes possible) SeanWcisel Linux - General 7 06-18-2007 03:43 PM
Very low performance trebek Linux - Newbie 9 08-04-2005 11:18 AM
Mplayer: is playback improved by NVIDIA driver installation? J_Szucs Linux - General 5 03-09-2004 11:54 AM
nvidia driver runs at low resolution dbkluck Linux - Laptop and Netbook 4 10-26-2003 11:40 PM


All times are GMT -5. The time now is 07:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration