LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Low boot screen resolution with fglrx (http://www.linuxquestions.org/questions/slackware-14/low-boot-screen-resolution-with-fglrx-4175437375/)

eoniq 11-15-2012 11:12 PM

Low boot screen resolution with fglrx
 
After switching from open source ATI radeon driver to fglrx, my boot scren resolution became very low.
Currently vga = normal is set in lilo.conf
I tried changing vga= modes but fonts are very blurry
Do I need to add anything to append= value?
Looking for any suggestions or pointers.
Thanks.

My lilo.cfg (edited for post)
Code:

append=" vt.default_utf8=0"
boot = /dev/sda

  bitmap = /boot/slack.bmp
  bmp-colors = 255,0,255,0,255,0
  bmp-table = 60,6,1,16
  bmp-timer = 65,27,0,255

prompt
timeout = 50
change-rules
  reset

# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask # VESA framebuffer console @ 1024x768x64k
#vga=791 # VESA framebuffer console @ 1024x768x32k
#vga=790 # VESA framebuffer console @ 1024x768x256
#vga=773 # VESA framebuffer console @ 800x600x64k
#vga=788 # VESA framebuffer console @ 800x600x32k
#vga=787 # VESA framebuffer console @ 800x600x256
#vga=771 # VESA framebuffer console @ 640x480x64k
#vga=785 # VESA framebuffer console @ 640x480x32k
#vga=784 # VESA framebuffer console @ 640x480x256
#vga=769


GlennsPref 11-16-2012 12:15 AM

Hi, I set mine manually, under normal circumstances.

And I don't see it in your list, I use

vga=794

From this ...
Code:

        640x480 800x600 1024x768 1280x1024 1600x1200 Ask user at boot
8 bits        vga=769 vga=771 vga=773  vga=775  vga=796  vga=ask
16 bits vga=785 vga=788 vga=791  vga=794  vga=798  vga=ask
32 bits vga=786 vga=789 vga=792  vga=795  vga=799  vga=ask

I use nvidia, so may not help... but,
Code:

nokmsboot vga=794
my cli hack

Glenn

eoniq 11-16-2012 06:51 AM

Thanks for suggestions, however it didn't work for me.
Fonts during boot and in tty are still very blurry.


Current lilo.conf

Code:

append="nokmsboot vt.default_utf8=0"
vga=794



All times are GMT -5. The time now is 07:46 PM.