LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-14-2004, 02:01 PM   #1
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Rep: Reputation: 0
Question Lot of problems with Mplayer


I'm trying to configure my linux box to be able to do the regular stuff to show my friends that Linux is an alternative for windoze as long as you don't play a lot of computer games.

But I can't get Mplayer to work.

I've recompiled it 3 times because I forgot to install the codecs and to use the --enable-gui option.

I can get it to play it really crappy when I root, but when I'm a user it says:
"Error opening/initializing the selected video_out (-vo) device"

How do I set a a video out device? The card I'm using is an old Riva from Nvidia.
As far as I know I should be using the xvidix vo? But how do I set that?

As I start the program I also get a lot of errors that it can't read config files:

Code:
Linux RTC init error in itoctl (rtc_irqp_set 1024): Permission denied
Can't open input config file /home/ni0wn/.mplayer/input.conf: No such file or directory.
Can't open input config file /usr/local/mplayer/input.conf: No such file or directory
Then it says: No vidix driver name provided, probing available ones!
A lot of drivers with: "Operation not permitted" after each one.

It works if I'm root, but the playback really sucks. The video isn't being "smudged" or what you should call it like it's being in windows, so you won't experience the video as you should.

Anyway, how do I get rid of all those errors, and how to I get it playing under my username?

I've been searching solutions for about an hour or so, but I can't find anything

Everyone seems to just have extracted the package, ./configure, make, make install and then it works.

Anyone have any clues?

Someone should create a slackware package for mplayer or something, that would kick ass.
 
Old 09-14-2004, 03:27 PM   #2
icom158
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware-10.2
Posts: 21

Rep: Reputation: 15
You can grab a mplayer package from linuxpackages.net.
I think your error "Error opening/initializing the selected video_out (-vo) device" is because you did not change the preferences for your video device. There are like 4 options, and one will work for you. root saves preferences in the .mplayer directory, you need to copy that directory into your users home directory and make it writable for your users to save preferences.
 
Old 09-14-2004, 04:38 PM   #3
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
I got it working by copying the mplayer.conf default (along with all other files) to the root and my ni0wn home dir.
I ran a mplayer -vo when my ni0wn user was in su mode, and and then it worked.

But I'm still having problems using the gui, it can't find any skins, I've looked around but I can't find the file where I change the path to the skins directory.

This is what I get when running: "gmplayer LSD-Erik.avi"

Is there any way I can get rid of all these errors?

Code:
bash-2.05b# gmplayer  LSD-erik.avi
MPlayer 0.93-3.3.4  (C) 2000-2003 MPlayer Team
CPU: Intel Pentium III Katmai/Pentium III Xeon Tanner (Family: 6, Stepping: 2)
Detected cache-line size is 32 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf: No such file or directory
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
Reading /root/.mplayer/codecs.conf: parse error at line 78
Reading /usr/local/etc/mplayer/codecs.conf: can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found ( default ).
 
Old 09-14-2004, 04:53 PM   #4
icom158
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware-10.2
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by ni0wn
But I'm still having problems using the gui, it can't find any skins, I've looked around but I can't find the file where I change the path to the skins directory.
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
instead of changing the skin directory, why don't you just put a skin in the
/usr/local/share/mplayer/Skin/default/ directory?
you need to make a default skin and then change it later.
just rename the blue directory to default.
 
Old 09-14-2004, 04:58 PM   #5
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
Haha, what a simple solution!

I've been tampering with this box for 6-10 hours today. (I've been cleaning my house, had breakfast and dinner you know)
I guess that's why my head is so fooked up atm.

I'll try that tomorrow, now I have to install a GFX card into his familys computer. And since they aren't coming back untill friday, I think I'll install some kickass games and play a lot as well >: )

Thanks for the help! I'll post a reply when I've tried the tip
 
Old 09-15-2004, 03:50 PM   #6
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
GAH! Now get the GUI without any problems, but I still have this video out problem.
What do I have to do to get rid of the "Operation not permitted" error?
It should work as a regular user, I shouldn't have to be in su mode to view a video...

Code:
Playing /home/christer/downloads/LSD-erik.avi
AVI file format detected.
Forced NON-INTERLEAVED AVI file format.
VIDEO:  [DIV3]  320x240  24bpp  25.00 fps  715.0 kbps (87.3 kbyte/s)
Clip info:
 Software: VirtualDubMod 1.4.13
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 16000->192000 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
No vidix driver name provided, probing available ones!
[rage128] Error occured during pci scan: Operation not permitted
[pm3] Error occured during pci scan: Operation not permitted
[mga] Error occured during pci scan: Operation not permitted
[radeon] Error occured during pci scan: Operation not permitted
[mach64] Error occured during pci scan: Operation not permitted
[mga] Error occured during pci scan: Operation not permitted
[cyberblade] Error occured during pci scan: Operation not permitted
vosub_vidix: Couldn't find working VIDIX driver
Error opening/initializing the selected video_out (-vo) device.
 
Old 09-15-2004, 04:19 PM   #7
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
YAY!


I found an old thread (http://www.linuxquestions.org/questi...+name+provided)

With the command: mplayer dvd://1 -vo xv

I tried this instead: gmplayer movie.avi -vo xv
And it plays! YAY!

Now there's only one problem, how do I configure my mplayer so I can open files within the GUI? So I won't have to open up a terminal every time I want to watch something...
 
Old 09-15-2004, 04:45 PM   #8
icom158
LQ Newbie
 
Registered: Aug 2004
Distribution: Slackware-10.2
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by ni0wn

Now there's only one problem, how do I configure my mplayer so I can open files within the GUI? So I won't have to open up a terminal every time I want to watch something...
Which window manager / desktop environment are you using?
If you make the config files writeable, you can change the vo device in preferences->video so you don't have to pass -vo xv all the time.
 
Old 09-15-2004, 04:47 PM   #9
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
Regarding those operation not permitted errors,

those appear to be due to the fact that mplayer doesn't know what the heck card you have so it tries to poke around the pci bus to find out (which works in root, but, as one might expect, regular users poking around the pci bus is usually a bad sign).

Look back at the MPlayer documentation, specifically the parts about video cards.

You saw how you had to recompile because you forgot --enable-gui? My guess is if you look in documentation you will see that you are also gonna want to compile with something about your video card (for example, something like --enable-tdfxfb or something like that).
 
Old 09-19-2004, 06:05 PM   #10
ni0wn
LQ Newbie
 
Registered: Sep 2004
Location: Stockholm, Sweden
Distribution: Slackware
Posts: 17

Original Poster
Rep: Reputation: 0
Ah, thanks for the tip about looking for compile options, I'll check that one out.

I managed to get it working by putting config file in the home dir


How do I uninstall mplayer? I've searched for some info, but haven't found anything, maybe I wasn't searching that good?
I've compiled and installed it 3 times, plus that I've installed a package as well...

In windows, you just uninstall, reboot and re-install, but it doesn't work that way in Linux...

Do I have to check the install log an delete everytning manually?

Thanks for the help guys, I really appreciate it
 
Old 09-20-2004, 12:59 PM   #11
fphillips
Member
 
Registered: Sep 2004
Location: KS
Distribution: Slack 10-current
Posts: 87

Rep: Reputation: 15
If you still have the old build directory around, go into it and do a make uninstall. Otherwise just untar the source and do the same.

Then check into using checkinstall - it may already be on your system.
Next time you compile something, replace the "make install" step w/ checkinstall. This make a slack pkg out of it and you can use pkgtool to remove/upgrade it.

http://asic-linux.com.mx/~izto/checkinstall/
 
Old 09-23-2006, 12:05 AM   #12
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,441

Rep: Reputation: 81
try `make uninstall` or look for an uninstall script. you won't always have those options, but you might.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer/Mplayer-plugin problems Buffbannana049 Fedora 3 07-13-2005 12:22 AM
lot of problems with mandrake 10.0 vblondel Mandriva 0 06-08-2004 04:10 PM
a lot of problems kryckan Linux - Hardware 4 10-04-2003 08:37 AM
[HELP!]lot of problems with debian r3l4x Debian 37 09-11-2003 09:13 PM
plzzz help me out....new to linux(lot of problems) ram13apr Linux - General 4 08-26-2003 03:15 PM


All times are GMT -5. The time now is 06:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration