LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-07-2011, 05:13 PM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 733

Rep: Reputation: 64
Lost compose key after changing to utf-8


I changed my system from iso-8859-1 to utf-8 so that Amarok would play files with special characters. But now I lost my compose key in some applications. For example yakuake console, kate, and libreoffice. It still works fine in for example firefox (look: ), thunderbird, and gimp, so it seems to be a 'gtk thing'?

I defined the compose key in ~/.Xmodmap with the following line
Code:
keycode 108 = Multi_key
Why is this not honoured by all applications after changing to utf-8?

I tried to solve it by also enabling the compose key in KDE System Setting's keyboard options, but that had no effect.

I'm at a loss. Any tips?

Last edited by BroX; 03-03-2012 at 07:01 PM.
 
Old 12-22-2011, 05:25 PM   #2
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 733

Original Poster
Rep: Reputation: 64
Question

*bump*

No one? That's unbelievable in this forum!
 
Old 03-03-2012, 06:59 PM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 733

Original Poster
Rep: Reputation: 64
Order matters

Following up on my own post, since I finally solved this annoying mystery.

In qt applications, order matters!

So, in order to type , one needs to type <composekey> ' a, in that order. Before changing to utf-8, the order of the characters did not matter. gtk applications do not care about the order.

Last edited by BroX; 03-03-2012 at 07:02 PM. Reason: fixed typo
 
Old 03-04-2012, 04:15 AM   #4
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Keymapping/locale support is a bit of an ugly topic and not really well understood. It also tends to change with the specific locale and keyboard/country layout you are using so I'm not surprised people are either unable to help or shy away from the subject.

If you look at the files in /usr/share/X11/locale for your specific locale then you'll be able to see a list of accepted compose sequences. Some characters have alternative sequence combinations/orders and some don't.

Also, bear in mind that your keyboard layout might also have its own deadkeys defined to provide accented characters or direct access to certain characters via use of the AltGr key. On the gb layout I use, AltGr+punctuation keys to the left of 'enter' act as deadkeys to attach basic accents to a subsequent letter, and AltGr+C gives a copyright symbol and this is completely outside of the multi_key/compose system (which uses compose+O+c for the same character).


Rather than use xmodmap to set the Multi_key I think most folks these days use the XKB compose option either through xorg.conf or the setxkbmap command. e.g.
setxkbmap -option compose:rctrl
'rwin' is also a popular choice, but I find I never press the right control key so I use that and reserve the windows keys for my window manager functions.

Personally, I never let things like the Desktop Environment get anywhere near the keyboard settings, preferring to set such things at a lower level in xorg.conf..


I don't know why Qt would be acting differently to any other toolkit in this regard though as I'd have expected the compose functionality to all happen inside the XServer and be invisible to higher layers, but maybe that isn't the case and Qt implements its own compose sequence handler or somesuch..

As I said, it's all a bit ugly, and the above is only to the best of my understanding and I'm no expert, but I hope it helped a little, if belatedly.


P.S. I still use ISO8859-1 rather than utf8, so the key sequences I mentioned above may be different to those of a utf8 locale.

Last edited by GazL; 03-04-2012 at 04:40 AM. Reason: added P.S.
 
Old 03-04-2012, 10:30 AM   #5
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 733

Original Poster
Rep: Reputation: 64
Thanks for some clarification GazL. I changed to using setxkbmap, with the same result with respect to the order of the characters. Not really a problem (once you know).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK apps not respecting Compose Key josiah Slackware 0 02-12-2010 08:33 PM
Creating new compose and dead-key combinations DavidMcCann Linux - General 3 10-13-2007 05:01 AM
How to disable compose key (Right Control) under GNOME? wirawan0 Suse/Novell 0 10-05-2005 11:57 AM
KDE, compose key, and xkb problems nazdrowie Linux - General 0 02-24-2005 12:37 AM
compose key not working jkobrien Linux - Hardware 1 08-05-2004 08:18 AM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration