LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Loss of X keyboard and mouse with latest updates in -current (http://www.linuxquestions.org/questions/slackware-14/loss-of-x-keyboard-and-mouse-with-latest-updates-in-current-4175462976/)

rpedrica 05-22-2013 03:38 AM

Loss of X keyboard and mouse with latest updates in -current
 
I did a big update yesterday of slackware64 -current and my mouse and keyboard are non-responsive in KDE/X now.

There have been one or 2 similar issues in times past but none of those provided solutions. I've reinstalled the NVidia propietary driver as is required as part of a kernel upgrade.

Dbus is running but hal is not ( I think this is no longer required ).

Any help appreciated.

Regards, Robby

rpedrica 05-22-2013 04:54 AM

Nvidia release is 310.40

Mark Pettit 05-22-2013 05:53 AM

Just to be clear - I assume your mouse and keyboard work fine from the command-line - ie before you start the GUI. And what about another windowmanager - say XFCE ?

rpedrica 05-22-2013 06:13 AM

Yes mouse/keyb are fine at the CLI + this problem only started after the latest updates ( last week or so ). Upgraded to 319.17 but no change

Didier Spaier 05-22-2013 06:24 AM

What says /var/log/Xorg.0.log?

rpedrica 05-22-2013 07:09 AM

The log was indicating ABI mismatches and disabling evdev. I thought this may have something to do with the package updates so reinstalled the x series of packages and that seems to have done the trick. Something must have gone wrong with a package during the update process ... very wierd.

Thanks for responding in any case - it gave me some ideas.

Regards, Robby


All times are GMT -5. The time now is 07:16 AM.