LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2012, 10:17 PM   #1
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Rep: Reputation: 2
Cool Losing Wireless Connection After Logout/Sleep


Hi Slackers,

Wicd always lose connection after logout/wake up from sleep.

So I thought this is the wicd problem, then I uninstalled wicd, and configure /etc/rc.d/rc.inet1.conf and /etc/wpa_supplicant.conf according to the awesome guide from:

http://alien.slackbook.org/dokuwiki/...ckware:network

It is working just fine, but then again it loses the wireless connection when I re-login after Logout/Sleep.

I try to restart rc.inet1 and here is the result:
Polling for DHCP server on interface wlan0:
dhcpcd[3367]: version 5.2.11 starting
dhcpcd[3367]: wlan0: waiting for carrier
dhcpcd[3367]: timed out
dhcpcd[3367]: allowing 8 seconds for IPv4LL timeout
dhcpcd[3367]: timed out

Then I run bash-4.1# wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf , and here is the result:
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

After fiddling with rc.inet1.conf again and again, I still can't make it work, I have to do shutdown -r now to bring back the wireless connection and internet to live.

Moreover, even on LQ, there is only one relevant Thread when I clicked "click here to Find Similar Threads" button on the tread creating page, which I don't think it is solved yet.
http://www.linuxquestions.org/questi...-sleep-513138/

Any Linux Gurus out there has any idea what have happened? or Eric himself perhaps ?

Thanks and cheers...

RJ

Last edited by RJwen; 09-03-2012 at 10:18 PM. Reason: forget to put relevant link
 
Old 09-03-2012, 11:01 PM   #2
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64
Posts: 133

Rep: Reputation: 19
Sorry not a Linux guru, but on my laptop Wicd recovers within seconds of waking up from either suspend or hibernate. When you selected your wifi network, did you turn on the option to "Automatically connect to this network"?
 
Old 09-03-2012, 11:17 PM   #3
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Of course I do "Automatically connect to this network"

Using Wicd, short after re-login from Logout/sleep, it works for a little while then it loses connection (but If I hover it to the wicd icon try, it still says "connected to.... "

And now even I uninstall wicd, and configure rc.inet1.conf and wpa_supplicant.conf, the same phenomenon happens. It seems now it is not wicd problem, and I don't think I config rc.inet1.conf and wpa_supplicant.conf wrongly (else it will refuse to connect to internet at start-up)

However, let me just paste my relevant portion of rc.inet1.conf and wpa_supplicant.conf here.
From rc.inet1.conf:
# Default gateway IP address:
GATEWAY=""

IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="shaanxi"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]=""
#DHCP_KEEPGW[4]=""
DHCP_IPADDR[4]=""
WLAN_ESSID[4]=RJ
WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"

From wpa_supplicant.conf:
# WPA protected network, supply your own ESSID and WPAPSK here:
network={
scan_ssid=0
ssid="RJ"
proto=WPA RSN
key_mgmt=WPA-PSK
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
priority=10
#psk="mypassphrase"
psk=dc177ea22029587b327475a6563fa9cf0eb52856c47aa8b875c6cb3985695493
}
 
Old 09-04-2012, 09:41 AM   #4
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Or does anyone know where Slackware store the Sleep (Suspend to RAM) config file?
I don't seem to find it.

/etc/pm/sleep.d , /etc/pm/power.d , /etc/pm/config.d are all empty directory,
if nothing is wrong with the rc.inet1.conf and wpa_supplicant.conf then the problem might resides in the sleep config file.

This really bugs me as so little information about this even on google and LQ.

Oh yeah, to make things precise, I'm still connected to the internet after re-login from logout, but not re-login after Sleep/Suspend to RAM

Hopefully someone could enlighten me on this one.

Cheers...

RJ
 
Old 09-04-2012, 10:57 AM   #5
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
What wireless card are you using? Perhaps the wireless driver does not like suspend/resume?

After resuming, try unloading and reloading your wireless driver if it is a module and see whether you can get a wireless connection.
 
Old 09-04-2012, 07:32 PM   #6
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Turtleli

My wireless card is
Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

My wireless driver is (using the one from Slackbuilds.org)
b43-firmware
b43-fwcutter

Do you suspect any problem with this ?

Cheers...

RJ
 
Old 09-04-2012, 08:14 PM   #7
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
And btw, I just tried Hibernation (Suspend to Disk), it seems my system takes it as Shutdown, LOL. (Although I can just press spacebar to start-up the computer, but it indeed running up the whole start-up process).

Now this whole Sleep/Hibernate thing starting to get very annoying...... haha.
 
Old 09-05-2012, 03:03 PM   #8
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
Sleep/hibernate - I don't know much about it so I cannot help you there.

Wireless - There are reports of the b43 driver not working after waking from suspend. You can test whether it affects you. After resuming, if you cannot connect, use (I am assuming you are using one of the default Slackware kernels):
Code:
modprobe -r b43
modprobe b43
Then try and connect as you normally do. If it connects then the problem is most likely the b43 driver not working well with suspend.
 
Old 09-09-2012, 04:15 AM   #9
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Hi Turtleli,

Currently I'm in Tibet now, can't really try it with my wireless.

I'll try it out as soon as I get back home.

Cheers...

RJ

Last edited by RJwen; 09-09-2012 at 04:18 AM. Reason: wrong grammar
 
Old 09-09-2012, 04:50 AM   #10
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by RJwen View Post
Or does anyone know where Slackware store the Sleep (Suspend to RAM) config file?
I don't seem to find it.
Suspend to disk data in swap partition, resume will be automatic or you can specify resume= as a kernel parameter. You'd better open a new thread since this is not related to the WiFi driver.

BTW, The two checkboxes in wicd: "Connect automatically" and "Never connect to this network" have exactly the same string in their Chinese translation. Not sure if this affects you.
 
Old 10-20-2012, 10:12 PM   #11
RJwen
LQ Newbie
 
Registered: Aug 2012
Distribution: Slackware
Posts: 25

Original Poster
Rep: Reputation: 2
Now after upgrading to 14, this issue is magically automatically fixed.

Not sure what is happening behind though. haha.
 
  


Reply

Tags
wirelessnetworking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Should Microsoft Be Losing Sleep Over Chrome OS? LXer Syndicated Linux News 0 05-20-2011 08:30 AM
Losing wireless connection after switching back to Vista OS naren13 Linux - Newbie 1 02-18-2011 02:25 AM
Lucid Not losing wireless connection snif123 Linux - Networking 0 08-14-2010 07:39 PM
Wireless connection lost on sleep eric_marsh Linux - Wireless Networking 1 01-01-2007 05:28 PM
losing wireless connection merchtemeagle Linux - Wireless Networking 5 07-10-2006 03:25 PM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration