LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Logout problems with Xfce4.6 and kdm on Slackware 13.37 (http://www.linuxquestions.org/questions/slackware-14/logout-problems-with-xfce4-6-and-kdm-on-slackware-13-37-a-879759/)

malkavian 05-10-2011 12:14 AM

Logout problems with Xfce4.6 and kdm on Slackware 13.37
 
Hi, folks!

Yesterday I faced with a problem on my new Slackware 13.37. I'm using Xfce as my DE for now and kdm as a session manager. Sometimes when I logging out the system is waiting for something for a minute and then logging out. If I try to push logout button that time I'm receiving the message that session manager doesn't reply. Also I've noticed that Xfce doesn't saving a work session, so I have to launch my applications everytime I turn on my laptop.

I think that the problen is due to how kdm works with Xfce... Maybe someone know the issue? Thank you.

bogzab 05-10-2011 02:54 AM

I don't think this is new with Slackware 13.37. I have seen it with logging out of xfce on Slackware 13.1. Also with no KDM involvement. I start xfce from command line with a startx command, xfce runs fine, and then when I am finished and logout there is often a long delay before I am returned to the terminal from which I launched xfce. I have just lived with this, but there are various messages on the terminal when you do get back to it, so if I was bothered by this, those messages are what I would be reading.

business_kid 05-10-2011 03:31 AM

Quote:

Originally Posted by bogzab (Post 4351795)
I have just lived with this, but there are various messages on the terminal when you do get back to it, so if I was bothered by this, those messages are what I would be reading.

The messages on the terminal have been read here. 1000s of kbcomp errors because kbcomp apparently doesn't like the keymap, (I have sought an explanation for that without success), xrdb bellyaching about Xft.hintstyle, then a spew of complaints at shutdown as programs have the rug pulled from under them, because xfce's exit is a bit like the car disappearing from under the Flintstones, and everything goes skidding along on their rear ends:). The screensaver bellyaches about permissions, and praises me for not running as root. It hasn't copped that X has vanished.

XFCE is not saving sessions. Have you seen
menu --> Settings --> Settings Manager --> Sessions & startup --> Application Autostart?

It sounds to me (No insult intended) that you want xfce to be kde. Xfce is 'low cholesterol,' and cuts corners. KDE saves sessions, startups, knows what you had for breakfast yesterday, and helps you practise meditation by giving you an hourglass to watch for some time on any occasion you try to do anything.

malkavian 05-10-2011 06:17 AM

Quote:

Originally Posted by business_kid (Post 4351815)
XFCE is not saving sessions. Have you seen
menu --> Settings --> Settings Manager --> Sessions & startup --> Application Autostart?

Yeap. I see it can be an issue. But for what is made flag for automate saving session? :)

Quote:

It sounds to me (No insult intended) that you want xfce to be kde.
Almost surely. I prefer kde applications, but for now trying to find some lightweight environment for launch them. And I've found Qt-applications looks very nice in XFCE :) Probably, you're right and it's time for me to upgrade my machine...

atelszewski 05-10-2011 07:05 AM

Hi,

Try killing 'kglobalaccel' before loging out. This proccess causes long delays in loging out in my case. In general, I guess that the long delays are caused by some apps that are started during the session, but for some reason can't be closed on log out.

And yes, it's NOT only the 13.37 problem.

malkavian 05-10-2011 08:24 AM

Thank you! I'll try. But it seems that it'll be better for me just use KDE instead.

atelszewski 05-10-2011 01:02 PM

Hi,

Quote:

But it seems that it'll be better for me just use KDE instead.
It depends. I don't like the design of KDE 4 so much, that I forced myself to use Xfce and I liked it. Quick hack to solve the kglobalaccel problem is to remove the binaries:
Code:

/usr/lib/libkdeinit4_kglobalaccel.so
/usr/bin/kglobalaccel

I also use 'krunner' from inside Xfce and it also works very nice.

malkavian 05-11-2011 10:36 PM

Thanks one more time!


All times are GMT -5. The time now is 11:47 AM.