LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-17-2011, 10:37 AM   #1
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Rep: Reputation: 49
Logout from KDE gives a black screen - is this the correct fix?


Hello:

When I select 'Logout' from the KDE menu system, I don't get the 'Login' screen, just a black screen from which I Alt+Ctrt+ Del to reboot.

If I am in Xfce and logout, everything works fine.

Using google, I found a post where the suggested solution was to remove the comment (#) from the '#TerminateServer=true' in the kdmrc file.

This works but I don't know if it is the correct thing to do (i.e. will it cause other problems?) and why does logout work in Xfce but not in KDE?

Any recommendations or assurances would be appreciated.
 
Old 08-17-2011, 11:42 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,520

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
This is a hardware specific issue that I have experienced with an older laptop. It will do no harm. The only cost is the time delay while the X server restarts.
 
1 members found this post helpful.
Old 08-17-2011, 12:39 PM   #3
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 62
On my netbook with an Intel GMA3150, setting TerminateServer=true fixed that problem.
 
1 members found this post helpful.
Old 08-17-2011, 12:48 PM   #4
yuuko
Member
 
Registered: May 2011
Distribution: Slackware-current
Posts: 42

Rep: Reputation: 20
xf86-video-intel-2.14.0-i486-1.txz works for me.
 
1 members found this post helpful.
Old 08-17-2011, 01:12 PM   #5
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: Slackware 13.37 -32 Bit
Posts: 578

Original Poster
Rep: Reputation: 49
Thank you to all.

I just don't understand why this was not a problem before I installed 13.37 and why everything works fine with Xfce?

I guess it is a KDE thing.

Marking as SOLVED.
 
  


Reply

Tags
kde logout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Black Screen at KDE Logout with 13.37 64-bit and VirtualBox Erik_FL Slackware 1 05-03-2011 08:38 PM
[2008.1] Shutdown/restart buttons missing in KDE and black screen after logout NanakiXIII Mandriva 4 05-26-2008 07:19 AM
Using the Logout option in KDE 3.5.4 causes a crash & black screen Interdictor Linux - Software 4 09-06-2006 04:25 PM
BLACK SCREEN after logout mordox Linux From Scratch 2 01-16-2006 11:24 AM
logout kde give black screen trollman Linux - Newbie 4 01-18-2004 08:42 PM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration