LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-01-2006, 05:49 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Logitech usb mouse not working


I have a new Pc and am desperate to get slackware working on it.

I am having a problem with the logitech usb cordless mouse. The mouse will only move vertically but not side to side and there is no response to clicks. The cordless keyboard is fine. The mouse works in XP and kubuntu

Xorg.conf reads

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"

# Mouse-speed setting for PS/2 mouse.

# Option "Resolution" "256"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

EndSection

Thanks
 
Old 04-01-2006, 09:49 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
did you compare the xorg.conf you have on slackware with the one from the working distro?? what kinda differences show-up??
 
Old 04-01-2006, 10:17 PM   #3
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
try this is /etc/x11/xorg.conf

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"

works for me with logitech USB Wireless mouse..
cheers
 
Old 04-02-2006, 05:49 AM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
Thanks. I tried your suggestion but it still did not work.

Kubuntu works with


Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

I wonder if the driver is the problem
 
Old 04-07-2006, 11:50 AM   #5
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
just a thought, do you have a laptop or desktop? I have a laptop and have it set to auto - it picks PS/2 however when it works..
If you have a laptop - try PS/2
also, what is the option you have selected 'emulate 3 buttons'
 
Old 04-07-2006, 12:23 PM   #6
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
If you have 2-button mouse, pressing them both lets you emulate like you have 3 ("emulate 3 buttons").
 
Old 04-07-2006, 01:31 PM   #7
Slum
Member
 
Registered: May 2005
Location: Rhode Island, USA
Distribution: Slackware w/ bleeding edge kernel.
Posts: 37

Rep: Reputation: 15
Check to see that you're using the correct device for your USB Mouse. Perhaps /dev/mouse isn't the exact device that the driver has registered itself to.

Normally it would be /dev/input/mouse0 in a USB situation.

Unplug your mouse and plug it back in. The do a
Code:
dmesg
to see which device the driver attached itself to. Also you do not need to emulate 3 buttons in this case.
 
Old 04-08-2006, 04:58 PM   #8
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
The solution was to comment out modprobe /sbin/hid in /etc/rc.d/rc.modules
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech USB Wireless Mouse not working anymore linda Linux - Hardware 4 05-08-2008 04:40 AM
Logitech USB Mouse not working madvikas Linux - Hardware 1 02-01-2006 03:29 PM
Logitech Optical USB mouse wheel not working in games Xandor Linux - Hardware 2 11-27-2005 09:37 PM
Logitech usb mouse stooped working mtsledhead Linux - Newbie 2 03-26-2005 09:46 PM
Logitech USB Mouse Wheel not working on Slackware 9.1 Ken Ju-On Linux - Hardware 9 04-11-2004 10:39 PM


All times are GMT -5. The time now is 01:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration