LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Logitech usb mouse not working (http://www.linuxquestions.org/questions/slackware-14/logitech-usb-mouse-not-working-430771/)

arubin 04-01-2006 05:49 PM

Logitech usb mouse not working
 
I have a new Pc and am desperate to get slackware working on it.

I am having a problem with the logitech usb cordless mouse. The mouse will only move vertically but not side to side and there is no response to clicks. The cordless keyboard is fine. The mouse works in XP and kubuntu

Xorg.conf reads

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"

# Mouse-speed setting for PS/2 mouse.

# Option "Resolution" "256"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Option "SampleRate" "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

EndSection

Thanks

win32sux 04-01-2006 09:49 PM

did you compare the xorg.conf you have on slackware with the one from the working distro?? what kinda differences show-up??

-=Graz=- 04-01-2006 10:17 PM

try this is /etc/x11/xorg.conf

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "Auto"
Option "Device" "/dev/mouse"

works for me with logitech USB Wireless mouse..
cheers

arubin 04-02-2006 05:49 AM

Thanks. I tried your suggestion but it still did not work.

Kubuntu works with


Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

I wonder if the driver is the problem

-=Graz=- 04-07-2006 11:50 AM

just a thought, do you have a laptop or desktop? I have a laptop and have it set to auto - it picks PS/2 however when it works..
If you have a laptop - try PS/2
also, what is the option you have selected 'emulate 3 buttons'

Alien_Hominid 04-07-2006 12:23 PM

If you have 2-button mouse, pressing them both lets you emulate like you have 3 ("emulate 3 buttons").

Slum 04-07-2006 01:31 PM

Check to see that you're using the correct device for your USB Mouse. Perhaps /dev/mouse isn't the exact device that the driver has registered itself to.

Normally it would be /dev/input/mouse0 in a USB situation.

Unplug your mouse and plug it back in. The do a
Code:

dmesg
to see which device the driver attached itself to. Also you do not need to emulate 3 buttons in this case.

arubin 04-08-2006 04:58 PM

The solution was to comment out modprobe /sbin/hid in /etc/rc.d/rc.modules


All times are GMT -5. The time now is 04:05 AM.