LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-25-2012, 03:00 PM   #1
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Skackware
Posts: 76

Rep: Reputation: 5
Logitech C300 microphone + skype


Hello slackers!
Please help my, my webcam logitech c300 no record in skype.
Screenshot with settings.
[EDIT]Please attach images instead of using NSFLQ file hosters (pr0n 4ds, basically).[/EDIT]
Attached Images
File Type: png 1+2.png (101.8 KB, 11 views)
File Type: png 3+4.png (102.7 KB, 6 views)
File Type: png 5+6.png (128.8 KB, 4 views)

Last edited by unSpawn; 12-27-2012 at 07:16 AM. Reason: //images redir to pr0n pages with some browsers?
 
Old 12-26-2012, 05:18 PM   #2
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.14.4)
Posts: 83

Rep: Reputation: Disabled
What version of Slackware are you using (13.37, 14.0, or current)? And which kernel are you using (huge, generic, or your own kernel)?

The "uvcvideo" module would be the kernel module to use with that webcam. Is the "uvcvideo" module listed when you run this command:
lsmod | grep uvcvideo

If not, try manually loading the module (modprobe uvcvideo).

And your last screenshot was from the Phonon settings in KDE. What does the Video Recording -> Communication option show (it is the third option group). You should see something like a /dev/video0 device listed there. And there is a test button there to test your webcam video.
 
Old 12-26-2012, 11:46 PM   #3
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Skackware
Posts: 76

Original Poster
Rep: Reputation: 5
Version of SLackware is 14.00 x64 with multilib.
Kernel own build 3.7.1, config - ftp://ifconfig.com.ua/incoming/tmp/config-3.7.1
ftp://ifconfig.com.ua/incoming/tmp/screenshot10.png
Video work, but microphone not.
Microphone not analog it used only USB interface.
http://nix.ru/autocatalog/webcams_lo...8_-2_draft.jpg
 
Old 12-27-2012, 01:28 PM   #4
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.14.4)
Posts: 83

Rep: Reputation: Disabled
You have two soundcards - the Intel HDA, and the USB device (which is your webcam).

I have a similar setup, and I could not get the microphone working in Skype until I created a "~/.asoundrc", or "/etc/asound.conf", file to add a capture.pcm for the microphone on the USB card. My asound.conf looks like this:
Code:
pcm.!default {
        type asym
        playback.pcm {
                type plug
                slave.pcm "hw:0,0"
        }
        capture.pcm {
                type plug
                slave.pcm "hw:1,0"
        } 
}
Where hw:0,0 is my main sound card in slot 0, and hw:1,0 is my USB sound device in slot 1. This makes the microphone on the USB device as the default microphone. You will find lots of documentation about ALSA here http://http://alsa.opensrc.org/Main_Page

And optionally, to preserve this sound card slot order, I have an old "/etc/modprobe.d/sound.conf" file (generated by alsaconf in Slack 13.37) that has the following lines:
Code:
options snd slots=snd-intel8x0,snd-usb-audio
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio
 
Old 12-27-2012, 01:39 PM   #5
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Rep: Reputation: 56
USB mics are mysterious. I have a Logitech B500 here with a microphone that works under skype. My parents have a similar setup with a slightly different camera model, and we could not get the microphone to work. yes i'm sure it's a layer 8 problem, but i've given up.
 
Old 12-28-2012, 06:30 AM   #6
sairum
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware
Posts: 17

Rep: Reputation: 7
I've got the same Logitech camera model (C300), and the micro works well under Slack. Just try to use a different entry for the microphone on Skype's sound device configuration. In the combo-box for the microphone, well above the standard entry that you have selected [from the screenshot I read "USB Device 0x46d:0x805, USB Audio (hw:1,0)"], there is a bunch of other possibilities. I've used the first one listed for USB, which reads

"USB Device 0x46d:0x805, USB Audio Default Audio Device (Default:CARD=U0x46d0x805)"

Then, in the check-box below (which you have unchecked) I checked

"Allow skype to automatically adjust my mixer levels"

Hope this helps

Antonio
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Logitech c270 webcam Dell Vostro 410 Slackware 13.37 Skype microphone not working rhamel Linux - General 2 09-21-2012 06:36 AM
[SOLVED] Microphone will not work with Skype! darkscot Linux - Software 4 06-22-2012 08:11 PM
Microphone not working in Skype bkorb Linux - Hardware 4 03-27-2012 10:01 AM
using my microphone in skype on kubuntu 9.10 gingerkid123 Linux - Newbie 1 04-25-2010 04:23 PM
Setting up microphone for Skype. mitchell7man Linux - Hardware 1 10-31-2009 04:55 AM


All times are GMT -5. The time now is 09:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration