LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Logitech C300 microphone + skype (http://www.linuxquestions.org/questions/slackware-14/logitech-c300-microphone-skype-4175442916/)

StreamThreader 12-25-2012 03:00 PM

Logitech C300 microphone + skype
 
3 Attachment(s)
Hello slackers!
Please help my, my webcam logitech c300 no record in skype.
Screenshot with settings.
[EDIT]Please attach images instead of using NSFLQ file hosters (pr0n 4ds, basically).[/EDIT]

regis_n_bits 12-26-2012 05:18 PM

What version of Slackware are you using (13.37, 14.0, or current)? And which kernel are you using (huge, generic, or your own kernel)?

The "uvcvideo" module would be the kernel module to use with that webcam. Is the "uvcvideo" module listed when you run this command:
lsmod | grep uvcvideo

If not, try manually loading the module (modprobe uvcvideo).

And your last screenshot was from the Phonon settings in KDE. What does the Video Recording -> Communication option show (it is the third option group). You should see something like a /dev/video0 device listed there. And there is a test button there to test your webcam video.

StreamThreader 12-26-2012 11:46 PM

Version of SLackware is 14.00 x64 with multilib.
Kernel own build 3.7.1, config - ftp://ifconfig.com.ua/incoming/tmp/config-3.7.1
ftp://ifconfig.com.ua/incoming/tmp/screenshot10.png
Video work, but microphone not.
Microphone not analog it used only USB interface.
http://nix.ru/autocatalog/webcams_lo...8_-2_draft.jpg

regis_n_bits 12-27-2012 01:28 PM

You have two soundcards - the Intel HDA, and the USB device (which is your webcam).

I have a similar setup, and I could not get the microphone working in Skype until I created a "~/.asoundrc", or "/etc/asound.conf", file to add a capture.pcm for the microphone on the USB card. My asound.conf looks like this:
Code:

pcm.!default {
        type asym
        playback.pcm {
                type plug
                slave.pcm "hw:0,0"
        }
        capture.pcm {
                type plug
                slave.pcm "hw:1,0"
        }
}

Where hw:0,0 is my main sound card in slot 0, and hw:1,0 is my USB sound device in slot 1. This makes the microphone on the USB device as the default microphone. You will find lots of documentation about ALSA here http://http://alsa.opensrc.org/Main_Page

And optionally, to preserve this sound card slot order, I have an old "/etc/modprobe.d/sound.conf" file (generated by alsaconf in Slack 13.37) that has the following lines:
Code:

options snd slots=snd-intel8x0,snd-usb-audio
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio


Martinus2u 12-27-2012 01:39 PM

USB mics are mysterious. I have a Logitech B500 here with a microphone that works under skype. My parents have a similar setup with a slightly different camera model, and we could not get the microphone to work. yes i'm sure it's a layer 8 problem, but i've given up.

sairum 12-28-2012 06:30 AM

I've got the same Logitech camera model (C300), and the micro works well under Slack. Just try to use a different entry for the microphone on Skype's sound device configuration. In the combo-box for the microphone, well above the standard entry that you have selected [from the screenshot I read "USB Device 0x46d:0x805, USB Audio (hw:1,0)"], there is a bunch of other possibilities. I've used the first one listed for USB, which reads

"USB Device 0x46d:0x805, USB Audio Default Audio Device (Default:CARD=U0x46d0x805)"

Then, in the check-box below (which you have unchecked) I checked

"Allow skype to automatically adjust my mixer levels"

Hope this helps

Antonio


All times are GMT -5. The time now is 11:26 PM.