LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Loading kvm-intel module for qemu-kvm 0.11.0 (http://www.linuxquestions.org/questions/slackware-14/loading-kvm-intel-module-for-qemu-kvm-0-11-0-a-768702/)

alkos333 11-12-2009 11:54 AM

Loading kvm-intel module for qemu-kvm 0.11.0
 
Code:

root@tpx200:~# modprobe kvm-intel
FATAL: Error inserting kvm_intel (/lib/modules/2.6.31/kernel/arch/x86/kvm/kvm-intel.ko): Operation not supported

Any ideas as to what's going on here?

Chuck56 11-12-2009 12:07 PM

Is your BIOS capable of virtualization and/or is it turned on in your BIOS?

dolphin77 11-12-2009 02:47 PM

I have Sony Vaio VGN-SR11MR laptop. The processor supports VT, but it was blocked by BIOS. And there was no option in BIOS to switch this on! But...

A very dirty (actually it was very clean) hack from http://levicki.net/downloads/ (look here http://levicki.net/articles/tips/200...o_EFI_BIOS.php).
Unfortuantely I did it some long time ago and didn't write up the recepie. But after some googling you should be able to do the same.

Thanks to this I can use VT of my Intel processor now.

brgrds,
Vladimir

alkos333 11-13-2009 12:56 AM

Well, luckily I had the options to enable Virtualization support in my BIOS and I did. Everything is working just fine now. I had to work out the permission problems with /dev/kvm afterward, but that wasn't a big deal.

Thank you both for your help!

Chuck56 11-13-2009 07:11 AM

Quote:

Originally Posted by alkos333 (Post 3755177)
I had to work out the permission problems with /dev/kvm afterward, but that wasn't a big deal.

Glad you got it sorted out so quickly!

What permission problems did you encounter and how did you resolve them? It could help others that run into a similar situation.

disturbed1 11-13-2009 01:12 PM

In the source package, there's a udev rule. I followed the instructions from the SlackBuild to create the group, and add myself to that group.
http://slackbuilds.org/repository/13.0/system/qemu-kvm/

alkos333 11-13-2009 10:01 PM

Quote:

Originally Posted by Chuck56 (Post 3755524)
Glad you got it sorted out so quickly!

What permission problems did you encounter and how did you resolve them? It could help others that run into a similar situation.

Glad you got it sorted out so quickly!

What permission problems did you encounter and how did you resolve them? It could help others that run into a similar situation.


What disturbed1 said :)


All times are GMT -5. The time now is 08:38 AM.