LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-10-2007, 07:10 PM   #1
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Rep: Reputation: 15
livdvdread, xconfig not working with KDM


I recently started taking advantage of KDM, but I noticed when I started booting directly into runlevel 4, both xconfig and libdvdread stopped working. I have no idea why, and everything else works just great with KDM. I can boot the DVD, look at the contents of the drive, boot cd's (it's a combo CD-RW/DVD-ROM). Both libdvdead and xconfig work fine if I boot into a standard console and type "startx." Here are the details:

****I set up KDM by editing /etc/inittab and specifying 4 as the default runlevel. I then commented out the sections for GDM in /etc/rc.d/rc.4, leaving both the KDM and XDM entries uncommented (the script looks for KDM before XDM, so I figured that would be fine). I then made the script executable. I have not tried using XDM. I've never used XDM and I'm not sure what will happen.

****I'm running Slack 11.0, kept up to date with slapt-get tracking 11.0. Kernel 2.6.21.4 (though this problem happened using 2.6.21.3 and maybe a few more releases back). The machine is a Dell Inspiron 5150 (it's a real P.O.S, for the record) with a Pentium 4 and 512mb of memory.

****libdvdread returns this error after starting mplayer in console ("gmplayer"):
Quote:
Playing dvd://1.
libdvdread: Could not open /dev/dvd with libdvdcss.
libdvdread: Can't open /dev/dvd for reading
Couldn't open DVD device: /dev/dvd
File not found: '1'
Failed to open dvd://1.
libdvdcss is installed (using Slackbuild script). Mplayer works fine (expect in this case), and was built using a Slackbuild script as well.

****xconfig returns this error when started in console:
Quote:
user@linux:/usr/src/linux$ su
root@linux:/usr/src/linux# make xconfig
scripts/kconfig/qconf arch/i386/Kconfig
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

qconf: cannot connect to X server :0
make[1]: *** [xconfig] Error 1
make: *** [xconfig] Error 2

I don't even know where to start to diagnose this. Any help is appreciated. Thanks in advance!
 
Old 06-10-2007, 07:54 PM   #2
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
I don't know anything about the libdvdread problem, but can I suggest you try running xconfig as your regular user (or perhaps with sudo, if you really really really want root permissions on that). The problem is that you're moving into a root terminal, but root doesn't have an active xsession running on the monitor.
 
Old 06-10-2007, 08:20 PM   #3
cdale77
Member
 
Registered: Oct 2006
Location: Berekeley
Distribution: Slackware 11; 2.6.21.1
Posts: 48

Original Poster
Rep: Reputation: 15
hmm, that makes sense, but

1) If I run as a regular user, I can't save the changes to .config in the kernel source, because the regular user doesn't have permissions, and
2) This all works honky-dory if I start X manually using startx at the console. Root wouldn't have an X session going in that case, either, right?

Not trying to critique your answer, but I'm obviously missing something. . .

Last edited by cdale77; 06-10-2007 at 08:24 PM.
 
Old 06-10-2007, 10:16 PM   #4
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
I've run into the same problem, and I'm pretty sure that it has something to do with the environment variables in su, I'm just not sure what. If someone else could give some insight into that it would be awesome. As for the issues with creating the .config file, that's why I recommended sudo in parenthesis up there, although you should know that there's no longer any need to build your kernel in /usr/src/linux any more, and it's actually discouraged in the README included with every new kernel. The only thing you really need to do as root is install the kernel and modules.

Last edited by bl0tt0; 06-11-2007 at 12:32 AM.
 
Old 06-10-2007, 11:29 PM   #5
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,384

Rep: Reputation: Disabled
If you logon at the console, your account automatically gets added to several groups important for local device access. If you logon through KDM or any runlevel 4 login manager, this will not happen.
The group membership you are probably lacking at the moment is that of "cdrom" which is needed to be able to access CDROM and DVD devices.
Add yourself manually to the "cdrom" group and everything should work again (after logging out and loggin on again).

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xwmconfig and KDM not working M$ISBS Linux - Newbie 5 07-09-2006 09:16 PM
Kubuntu KDM not working properly tokyo_ Linux - Software 3 06-14-2006 05:47 PM
kdm is not working lavluda Debian 5 02-22-2006 10:17 PM
make xconfig, xconfig with weird words pakkua80 Fedora - Installation 3 11-17-2004 07:19 AM
make xconfig not working phikap6878 Debian 3 04-02-2004 11:07 PM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration