LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-30-2004, 03:33 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Rep: Reputation: 210Reputation: 210Reputation: 210
Lisa daemon


I have samba installed, because my parents are on an xp machine, with a huge hard drive, so thats where i store all my files (*grin*) , but i can't access them in Linux. I went through the control center, local network browsing, i chose the lisa daemon tab, and chose a guided setup. After that, i restarted to make sure, and tried the lan browser , but I still came up with this error message.

"The lisa daemon does not appear to be running. In order to use the LAN browser the lisa daemon must be installed and activated by the system administrator"

Ok, so I thought lisa daemon was ALREADY running, since I could configure it in the kontrol center, and i saw no option in there to make it enabled. Please help
 
Old 08-30-2004, 04:13 PM   #2
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Try running lisa in console (as root) you'll see some errors about "Can't load /etc/samba/smb.conf"

Also, make sure u have permission to run lisa as your user (or run as root)
 
Old 08-30-2004, 04:52 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Original Poster
Rep: Reputation: 210Reputation: 210Reputation: 210
great, i opened a root konsole and typed lisa , and got this output

his is the LAN Information Server LISa 0.2.3
It is free software according the GNU General Public License
Copyright (c) 2000-2003 by Alexander Neundorf
email: neundorf@kde.org


running on port 7741
Have fun ! :-)

so now i can see my computer (slacker.lazy.net) and 192.168.1.3 which is my parent's pc, but when i click on it, i don't see any shares, and i made sure to enable show hidden shares in kcontrol.

by the way, how do i get lisa to start up , without having to type the lisa command each time? and how do i set it to my normal user , instead of just root?
 
Old 08-31-2004, 12:17 AM   #4
eelriver
Member
 
Registered: May 2004
Location: san francisco
Distribution: Slackware 10.2 kernel 2.6.13, Gentoo amd64, Some mish-mash of programs that started with slack 9.0
Posts: 165

Rep: Reputation: 30
Put this in your /etc/rc.d/rc.local file:
Code:
           if  [ -x /opt/kde/bin/lisa ]; then
            echo "Starting LISa daemon..."
            /opt/kde/bin/lisa
           fi

Last edited by eelriver; 08-31-2004 at 12:18 AM.
 
Old 08-31-2004, 12:40 AM   #5
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
edit: redundant post
 
Old 08-31-2004, 07:13 AM   #6
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Original Poster
Rep: Reputation: 210Reputation: 210Reputation: 210
great, I can now use my LAN Browser , and I can see both pcs on my network, however I can't see the files from my parent's computer, and the shares on their machine ends with an $ which is an administrative share in windows NT.

I was expecting to see something like e$ or /192.168.1.3/e$ , but nothing.........what now?
 
Old 08-31-2004, 07:23 AM   #7
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
double-check the windoze box and make sure it is set up for network sharing
[not just sharing between users locally]
 
Old 08-31-2004, 03:20 PM   #8
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Original Poster
Rep: Reputation: 210Reputation: 210Reputation: 210
How am I supposed to do that? I went back in and made a conventional share , and it is still not showing up , I can't really find any other options
 
Old 09-01-2004, 12:45 AM   #9
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
I gave up with lisa and now use smb4k, which has a package on linuxpackages.net

smb has to supply a username and password that are valid on the Windows PC
The $ signs are a symtom that you have not logged in.
 
Old 09-01-2004, 03:38 AM   #10
suslik
Member
 
Registered: Jul 2004
Distribution: OpenSuse 10.x
Posts: 262

Rep: Reputation: 30
Quote:
Originally posted by davidsrsb
The $ signs are a symtom that you have not logged in.
No, he doesn't see the $'s and that may be a sign he didn't log in.

Once you get the lisa running, how do you browse the SMB network?

I usually put "smb:///" into Konquerror, which shows available workgroups. Do you at least see that? It is very strange your parent's XP machine resolves to an IP number. Supposed to be a name. A firewall on that XP may be blocking NetBUI from "advertising" itself.

If its pre-SP2 XP i think the firewall configs are Start > Control Panel > Network **** > [your network icon]+right-click > properties.

In SP2 XP i think its a separate control panel.

Last edited by suslik; 09-01-2004 at 03:45 AM.
 
Old 09-01-2004, 12:03 PM   #11
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware 14.1 64-bit with multilib
Posts: 2,075

Original Poster
Rep: Reputation: 210Reputation: 210Reputation: 210
Ok, I went back to the windows box, and made sure that the firewall in xp was disabled, and I still can't see any shares from the Linux side. Maybe I am using the wrong protocol in Linux? I usually prefer sharing files from windows through IPX/SPX-NetBeui , and not through TCP IP , i have unbound filesharing through TCP IP. So what should I try next?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LiSA Daemon desertViking Slackware 4 10-21-2005 01:23 PM
password for lisa daemon... chanlo1706 Linux - Networking 1 06-20-2005 03:57 PM
Lisa Daemon KrGAce Linux - Networking 3 06-19-2005 09:43 AM
Lisa Daemon? Abbaddon Slackware 7 09-15-2004 03:02 AM
lisa daemon huno Slackware 1 11-03-2003 08:55 AM


All times are GMT -5. The time now is 07:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration