LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2007, 10:43 PM   #1
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Rep: Reputation: 30
Linux as client on network


I am noob so please keep this in mind while reading thanks.
I am trying to setup a slackware 10.2 kernel 2.4.31 box as client via ethernet with XP as the host.. forgive me it is just until I get 10.2 running like I want. I've looked over a lot of posts as well as Slack site and linux-ip.net, but I still cant access the net. I'm not sure what the problem is because I can ping the slack box from XP but not vice versa.. I have on board lan SiS900 and the driver is loaded at boot. Here is some nfo that may help->

ifconfig
eth0 Link encap:Ethernet HWaddr 00:01:60:4a:F3:G5 inet addr:192.168.0.## Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2935 errors:0 dropped:0 overruns:0 frame:0
TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:961896 (939.3 Kb) TX bytes:4147 (4.0 Kb)
Interrupt:19 Base address:0xe000

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.# 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.# 0.0.0.0 UG 1 0 0 eth0

I also tried adding a host to the table but that didnt work either. Not sure if you need any other nfo so you can help me but if so plz let me know. The gateway matches XP gateway and the slack ip is different than the XP box and the router. Not sure if I need to set channel # or how.. haven't seen anything about that. Also, the lan and wireless are bridged on XP box and working no errors or cable unplugged issues. The bridge is not a static ip though if that makes a difference. I would've made it static but not sure about DNS address. Any help would be much appreciated..
 
Old 03-14-2007, 01:50 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Seems fine, the ping problem is probably related to XP's firewall only. Can you ping a IP address outside your LAN? Maybe it's just a DNS problem.
 
Old 03-14-2007, 09:04 AM   #3
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
  1. What is the topology of your LAN?
  2. Does "Linux (slack)...client" . . . "XP...host" mean you are trying to connect through the XP box using M$ ICS?
  3. Do you have a hardware router or real firewall?
  4. How are you handling DHCP -- server (where), or static assignment?
Feel free to answer by # & not have to quote my Q's
 
Old 03-14-2007, 09:15 AM   #4
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,204
Blog Entries: 3

Rep: Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433Reputation: 1433
Quote:
Originally Posted by Rollo69
I am noob so please keep this in mind while reading thanks.
I am trying to setup a slackware 10.2 kernel 2.4.31 box as client via ethernet with XP as the host.. forgive me it is just until I get 10.2 running like I want. I've looked over a lot of posts as well as Slack site and linux-ip.net, but I still cant access the net. I'm not sure what the problem is because I can ping the slack box from XP but not vice versa.. I have on board lan SiS900 and the driver is loaded at boot. Here is some nfo that may help->

ifconfig
eth0 Link encap:Ethernet HWaddr 00:01:60:4a:F3:G5 inet addr:192.168.0.## Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2935 errors:0 dropped:0 overruns:0 frame:0
TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:961896 (939.3 Kb) TX bytes:4147 (4.0 Kb)
Interrupt:19 Base address:0xe000

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.# 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.# 0.0.0.0 UG 1 0 0 eth0

I also tried adding a host to the table but that didnt work either. Not sure if you need any other nfo so you can help me but if so plz let me know. The gateway matches XP gateway and the slack ip is different than the XP box and the router. Not sure if I need to set channel # or how.. haven't seen anything about that. Also, the lan and wireless are bridged on XP box and working no errors or cable unplugged issues. The bridge is not a static ip though if that makes a difference. I would've made it static but not sure about DNS address. Any help would be much appreciated..
Hi,

First, why tag out the IP in the ifconfig and route table information?
If your IP is correct and the route is correct then the problem could be that you don't have the /etc/resolv.conf setup properly. When you ping, use the IP address of the gateway then ping the XP boxen with the IP. If successful then try the name. Do you have your hosts setup?

You are using wired at this point so channels would not be a problem.
 
Old 03-14-2007, 09:16 AM   #5
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Hi Rollo69! I have the same setup, and it did indeed take a while to get my Slack machine to connect through the WinXP machine by ethernet. Windows is fussy and particular, when it comes to this situation.
I am no expert, so bear with me if I am unclear or if something makes no sense.
I see from ifconfig you posted that the default gateway is not statically defined. It reads
192.168.0.##., Now, here is the data I get when I type ifconfig:

Quote:
root@darkstarSSI:/home/Sasha# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0C:76:0F:A5:ED
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:20695 errors:0 dropped:0 overruns:0 frame:0
TX packets:18651 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:24925599 (23.7 MiB) TX bytes:1912981 (1.8 MiB)
and now route -n:
Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 1 0 0 eth0
Notice that the addresses are all statically defined.
First, Do you have KDE desktop installed? If so, then select Control Center, then Network & Internet, and finally Network Settings. Now ignore the box asking you to pick a distro, and click the Administrator-Mode button and give the root password.
And NOW, select your distro (Either Slack 10.2, which I think is there, or select SuSE 7.0, which I use because Slack 11 is not listed and the others won't work for me.)
You should now see your eth0 interface listed, and it will be either enabled or disabled.
Click the routes tab, and verify that 192.168.0.1 is in the Default Gateway box.
Click the Domain Name System tab. Your machine name should be in the first box, in my case darkstarSSI.
Your Microsoft network name goes into the second box, in my case mshome.net (note: no leading dot/period, only the network name.)
Now, the nameservers; I am connected by dialup to Sympatico.ca, and in my area, I got the IP addresses of the 2 Sympatico DNS servers for my area, and put them into the Domain Name Servers box.
Now, below all this, is the STATIC HOSTS section. The only thing that should be in there is your local loopback address,in my case like this: 127.0.0.1 localhost darkstarSSI
Apply and save this information, and click on the first tab again, to see your interface. Select it, and click configure. Make sure that YOUR IP address is set to 192.168.0.2, and set to MANUAL, NOT AUTOMATIC. The netmask should be 255.255.255.0. Do NOT click the box for "Start this connection automatically" because that will mess up your rc.inet1 file.
Finally, if you click the Advanced button, you should see the broadcast address of 192.168.0.255, which I think you already have correct.
Now save/apply everything. Select your network card on the screen from the first tab, disable it, and now re-enable it.
With any luck, it will turn green and enable, and you will have internet connection
NOTE: Before all this, MAKE SURE that the silly Windows machine has been Wizarded for home networking (I'm pretty sure you have already got this part, but it is worth mentioning for the benefit of someone out there!).
Files to pay attention to in relation to this setup are as follows (incase you either are not using KDE Control Panel, and/or you want to check all the config files manually, which I do recommend):
Quote:
etc/rc.d/rc.inet1 - startup script
etc/rc.d/rc.inet2 - startup script
etc/inet1.conf - mostly commented out
etc/host.conf - contents vary
etc/hostname - contains ONLY your machine name (mine = darkstarSSI)
etc/HOSTNAME - contains full machine name (e.g.: darkstarSSI.mshome.net)
etc/networks - contains:
loopback 127.0.0.1 and
localnet 192.168.0.1
etc/resolv.conf - contains your 2 nameservers and your domain, like:
nameserver 123.456.789.123
nameserver 123.456.789.123
domain mshome.net
etc/rc.d/rc.inet1.conf - should contain, among other stuff, your:
IPADDR[0]="192.168.0.2"
NETMASK[0]="255.255.255.0"
DHCP_HOSTNAME[0]=""
GATEWAY="192.168.0.1"
etc/nsswitch.conf - contents vary widely; if needed I can post mine but it may or may not help.
Hopefully this info will get you closer to functional net connection, perhaps even will get you connected right away after you verify that your system contains the correct stuff as mentioned above.
Best of luck If I can help further, or if I have missed something, please do ask again!
Sasha

Last edited by GrapefruiTgirl; 03-14-2007 at 09:38 AM.
 
Old 03-14-2007, 07:15 PM   #6
Rollo69
Member
 
Registered: Sep 2005
Location: Charlotte, NC
Distribution: Slack 12.0
Posts: 190

Original Poster
Rep: Reputation: 30
linux as client

thank you all for your quick responses to my post. I've posted b4 on here without a response. I work w/ a guy that is a Linux person and thats why I use Slackware. He's a computer person from the 80's and he has helped me with this situation. It turns out that Slack is configured right. The ## in my post was were I was leaving my numbers blank. My problem wasn't with Slack but with XP. My friend said he had a similar problem and that I should make sure my firewall in XP was set to accept Slack, which is what gbonvehi pointed out as well. Well that was the problem. The firewall wasn't though I thought it was. I'm now responding back to you guys via my Slack box. Again thanks alot.

Next is to setup Slack for wireless. I'm not sure which way to go. Should I use madwifi or ndiswrapper?? I apologize if this should be asked in different area or in different post. The card is a dlink wda-2320. I have Slack 9.0 ,on its on hd, setup on the XP box. I use it to dual boot Slack 9 and XP. I tried madwifi. I researched and read madwifi noob setup but to no avail. If you need more nfo I'll be more than glad to assist.

Thanks again you guys.!!!

Last edited by Rollo69; 03-14-2007 at 07:34 PM.
 
Old 03-14-2007, 07:20 PM   #7
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Awesome, good to hear you got it sorted out!
I too had to mess with the XP machine a few times before it would work, but now it's just like the XP machine isn't even there and... LOL, my Linux machine hogs ALL the bandwidth bwaaahaaahaa :P, we're on dialup here, out in the country, so the bandwidth is the pits to begin with.
Anyhow, happy slacking!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Client to Windows 2003 Network. Help rpdalton Linux - Networking 2 02-19-2004 11:01 PM
Refresh client user list at autentication client/server network. robertoneto123 Linux - Networking 0 11-11-2003 10:38 AM
Linux as a network CLIENT Citizen Bleys Linux - Networking 3 07-23-2003 10:11 AM
Booting Linux client through network anilkumarby Linux - Networking 1 08-01-2001 05:35 AM
Booting Linux client through network anilkumarby Linux - General 1 08-01-2001 05:34 AM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration