LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-05-2006, 07:04 PM   #1
Anonymo
Member
 
Registered: Dec 2004
Location: The Woodlands, Texas
Distribution: Slackware, Archlinux, CentOS
Posts: 183

Rep: Reputation: 27
Linksys Wireless-G USB Adapter


I have the Linksys Wireless-G USB Adapter (WUSB54GC).

I am running Slackware -current (May 1st) with a 2.6 kernel.

Wondering how I could get this working if anyone already has or point me in a good direction. Never done this before.

Oh I am going to install Gnome Dropline, the newest one in a few minutes. It has automounting.
 
Old 05-06-2006, 05:20 AM   #2
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
i just had a quick snoop around google and your card seems to use the RALINK RT2501 chipset..
I have not seen this particular chip before - i have a card that uses the rt2570 chip and i have seen rt2500 as well... (but not 2501)
Im not sure if this helps but you can try: http://rt2x00.serialmonkey.com
these guys make the linux driver for the 25xx series chips (the one that i use works perfect) - if your card is Ralink then you will find ppl talking about it on the forum here..

btw - my stick is DLink DWL-122 USB 54Mbit adaptor

Last edited by -=Graz=-; 05-06-2006 at 05:21 AM.
 
Old 05-06-2006, 05:29 AM   #3
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Also - on Ralink's page there is a device called WUSB54G (not quite WUSB54Gc)
getting close =)
if the serial monkey drivers do not work you could try Madwifi- i know nothing about this though as have not tried
http://ralink.rapla.net/
 
Old 05-06-2006, 10:17 AM   #4
Anonymo
Member
 
Registered: Dec 2004
Location: The Woodlands, Texas
Distribution: Slackware, Archlinux, CentOS
Posts: 183

Original Poster
Rep: Reputation: 27
thanks

Will try.
 
Old 07-14-2006, 08:37 PM   #5
aqau
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Rep: Reputation: 0
I found a website that seems to know whta they are talking about. It's a step by step guide for that particular adapter...check it out.

http://www.passivemode.net/updates/2...4gc-linux.html
 
Old 07-14-2006, 09:13 PM   #6
Anonymo
Member
 
Registered: Dec 2004
Location: The Woodlands, Texas
Distribution: Slackware, Archlinux, CentOS
Posts: 183

Original Poster
Rep: Reputation: 27
cool

Can anyone translate this to Slackware?

I have tried it but don't know exactly the steps for Slackware.
 
Old 07-16-2006, 03:14 PM   #7
aqau
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Rep: Reputation: 0
okay i had something here but then i figured out that i had no idea what i'm talking about....anyways...hope you get real help f

Last edited by aqau; 07-17-2006 at 11:45 PM.
 
Old 07-17-2006, 11:44 PM   #8
aqau
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Rep: Reputation: 0
whoops...didn't mean to post this here and can't figure out how to delete a post
 
Old 07-18-2006, 01:00 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Firstly, you should have the kernel source installed already so you won't need to install a package for it (or the kernel headers). Slack usually comes with those installed.

Also check that you have gcc, make and wireless-tools installed. You can do a "ls -l /var/log/packages | grep gcc" to check that gcc is installed for example.

All the unpacking the archive, building the source, loading the module and creating an alias for it are the same (that's done where /etc/modprobe.conf is edited to add the "alias rausb0 rt73" line).

After that though, you might want to look at editing /etc/rc.d/rc.inet1.conf. Scroll down and there's a section for wireless cards. If there's a line that specifies the interface name as wlan0, then you'll need to change that to rausb0.

HTH a bit.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys USB Wireless Adapter - WUSB54GC StarbuckZero Linux - Wireless Networking 6 07-31-2006 06:39 AM
Linksys Wireless Usb Adapter--cannot connect klasact Linux - Wireless Networking 0 04-02-2006 09:14 PM
Linksys USB Wireless Adapter Help... JediDB Linux - Wireless Networking 1 08-04-2005 12:00 PM
Trouble with Linksys wireless usb adapter phirefenix Linux - Wireless Networking 4 02-17-2005 11:57 PM
Linksys Wireless USB adapter won't work pilot1 Linux - Wireless Networking 24 10-16-2002 08:41 AM


All times are GMT -5. The time now is 08:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration