LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-01-2012, 03:57 AM   #1
commandlinegamer
Member
 
Registered: Dec 2007
Posts: 81

Rep: Reputation: 12
Lilo strangeness with -current


Am using a Toshiba Satellite L500 laptop with a 120 GB sata hard disk as a replacement after the original failed. Memtest has found no issues, and there are no bad blocks on the hard disk. It had Windows 7 installed previously, and reinstalling this proved to be no problem.

So I tried installing both Slackware 14.0 RC3, and -current from mid-June. It proceeds normally, during fdisk, setup, configuration etc. Restart after installation and the system fails to boot.

I've varied the partition setup. Currently, I have sda1 as swap and sda2 as /, so lilo.conf has

boot = /dev/sda
...
root = /dev/sda2

I can get it to boot by making the second partition active and changing lilo.conf to

boot = /dev/sda2
...
root = /dev/sda2

So, it's not a big deal, but I don't recall having done anything differently from previous installs of 13.1, 13.37, etc. At this stage I haven't got as far as setting up an initrd, so am just using the huge.smp kernel.

Just wondered if there were anything obvious I'd missed.
 
Old 09-01-2012, 04:06 AM   #2
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Rep: Reputation: 56
"fails to boot": where exactly does it get stuck?

There must be some boot code in the MBR, otherwise the "root=/dev/sda2" scenario wouldn't work. Maybe from prior experiments? Care to show the whole lilo.conf?
 
Old 09-01-2012, 05:09 AM   #3
commandlinegamer
Member
 
Registered: Dec 2007
Posts: 81

Original Poster
Rep: Reputation: 12
I'm at work so I'll post the complete lilo.conf later.

If I don't have the active partition set, then I get a split-second message (IIRC) saying "[hard drive identifier] boot failure" then it jumps to the BIOS boot selection menu: DVD drive, hard drive, network, floppy. If I do have the active partition set with "boot = /dev/sda2" then the error msg still appears but it manages to then jump to the lilo menu, and boot normally.
 
Old 09-01-2012, 05:14 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 755

Rep: Reputation: 226Reputation: 226Reputation: 226
This laptop doesn't have the annoying virus protection thing in it's BIOS settings does it?
 
Old 09-01-2012, 10:33 AM   #5
comet.berkeley
Member
 
Registered: Dec 2009
Location: California
Distribution: Slackware current
Posts: 151

Rep: Reputation: Disabled
Quote:
Originally Posted by commandlinegamer View Post
...
Just wondered if there were anything obvious I'd missed.
Make sure that you have the "current" version of LILO, 23.2.

The old Slackware 13.37 version of LILO, 22.8, does not work with the newer kernels:

http://www.linuxquestions.org/questi...el-4175423582/
 
Old 09-01-2012, 05:20 PM   #6
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, FreeBSD 10.0
Posts: 3,180
Blog Entries: 15

Rep: Reputation: 823Reputation: 823Reputation: 823Reputation: 823Reputation: 823Reputation: 823Reputation: 823
You may have to rerun liloconfig to regenerate the script from scratch and reinstall LILO to wherever you normally install LILO like the master boot record. Normally this works best anyway.
 
Old 09-01-2012, 06:30 PM   #7
commandlinegamer
Member
 
Registered: Dec 2007
Posts: 81

Original Poster
Rep: Reputation: 12
No virus protection in the BIOS.

Took some more time doing a reinstall, and the "boot = sda2" line isn't the critical option, it definitely seems to be the active flag that makes the difference.

lilo.conf:

boot = /dev/sda
bitmap = /boot/slack.bmp
bmp-colors = 255,0,255,0,255,0
bmp-table = 60,6,1,16
bmp-timer = 65,27,0,255
append=" vt.default_utf8=0"
prompt
timeout = 50
vga = normal
image = /boot/vmlinuz
root = /dev/sda2
label = linux
read-only

Above works as long as partition 2 is set active. Turn the flag off, no boot.

My PC (Asus A8N5X motherboard) running Slack 13.37 also had the second partition set active (the first partition contained an XP install). Turning that flag off, made no difference: both Slack and Windows continue to start up normally on that machine.

So I think now it must be some BIOS peculiarity on the laptop.

And of course, I've now found someone who had a similar problem:

http://www.linuxquestions.org/questi...tition-805403/

Thanks for the help, guys.
 
Old 09-01-2012, 07:00 PM   #8
storkus
Member
 
Registered: Jun 2008
Posts: 310

Rep: Reputation: 45
Yes, laptop BIOS problems are a royal headache: I can't boot up *ANY* of the BSD's without a kernel panic during early boot, and the only reason I can think of is the stupid Acer BIOS with all the "MSFT"isms all over the place inside the tables. Further, I think (but my memory is fuzzy) that I had trouble with Grub and Ubuntu a several years ago, but I don't remember well enough anymore.

Off-topic, you may want to add "resume=/dev/<swap_partition>" to your append line above so you can use hibernation. This discussion still applies even though we're at 14 now:

http://people.ucalgary.ca/~cdkyle/sl...d_to_disk.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo inconsistent partition table on current with ssd zux Slackware 7 03-30-2011 12:32 PM
Lilo Install Error in Current-64 Biggen Slackware 1 08-20-2009 09:38 AM
[SOLVED] Lilo set-up to dual boot Slackware 12.2 with Slackware64 -current? hitest Slackware 19 08-10-2009 05:31 AM
Lilo hangs on /dev/hda in -current Uncle_Theodore Slackware 4 09-13-2008 09:53 PM
Typo in slackware-current/source/a/lilo/liloconfig drumz Slackware 7 02-22-2008 12:53 PM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration