LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Lilo help (http://www.linuxquestions.org/questions/slackware-14/lilo-help-537209/)

IMOBoss 03-13-2007 05:51 PM

Lilo help
 
I'm running slackware 11 and I need help. I generate lilo.conf with liloconfig but when I boot lilo doesn't show to chose windows. This is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hdb1
#compact # faster, but won't work on all systems.
prompt
#timeout = 300
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdb1
label = Linux
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
table = /dev/sda
# Windows bootable partition config ends

What to do?
Thanks

kilgoretrout 03-13-2007 06:42 PM

Open a console, su to root and run:

# lilo -v

Post back any error messages that you get. If the command completes without spitting out any error messages, you should have a boot entry for windows next time you boot up.

H_TeXMeX_H 03-13-2007 10:34 PM

So you have 2 hard-drives ?

IMOBoss 03-14-2007 09:55 AM

Yes I have 2 hard drives. Sata with windows and Ide with Linux. Lilo is on IDE, and Bios is setup to boot IDE. And every time when I want to load windows i must enter bios and boot sata.

#lilo -v returns
LILO version 22.7.1, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2005 John Coffman
Released 17-Sep-2005 and compiled at 00:33:53 on Aug 8 2006.

Warning: LBA32 addressing assumed
Reading boot sector from /dev/hdb1
Using MENU secondary loader
Calling map_insert_data

Boot image: /boot/vmlinuz -> vmlinuz-generic-2.6.17.13
Added Linux *

Boot other: /dev/sda1, on /dev/sda, loader CHAIN
Added Windows

Writing boot sector.
/boot/boot.0341 exists - no boot sector backup copy made.

onebuck 03-14-2007 11:12 AM

Hi,

Quote:

I'm running slackware 11 and I need help. I generate lilo.conf with liloconfig but when I boot lilo doesn't show to chose windows. This is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hdb1

should be;
<<<<<<<<<<<

boot = /dev/hdb #unless you chainload
>>>>>>>>>>>>>>>>

#compact # faster, but won't work on all systems.
prompt
<snip>
Why are you writing the lilo to the superblock? Write the lilo to the 'MBR'.

Once you edit the lilo.conf file as root then;
Code:

#lilo -v -t -b /dev/hdb      #test the lilo.conf no write
#lilo -v -b /dev/hdb        #write 'MBR'

You will have written the lilo.conf file to the 'MBR' of /dev/hdb in the second command line above.

EDIT: BTW, place any log config files or other information in a vbcode, either the # or quote. This will make reading easier.

IMOBoss 03-14-2007 12:57 PM

Now I can see Windows in Lilo menu :)

Do I need everytime do this

#lilo -v -b /dev/hdb

when I change lilo.conf.

Thanks

onebuck 03-14-2007 01:25 PM

Quote:

Originally Posted by IMOBoss
Now I can see Windows in Lilo menu :)

Do I need everytime do this

#lilo -v -b /dev/hdb

when I change lilo.conf.

Thanks

Hi,

No, only if you make changes to your /etc/lilo.conf file. If 'man lilo' then you will see the switch options.

I'm glad you got the system up and going.


All times are GMT -5. The time now is 10:35 PM.