LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-16-2007, 04:54 PM   #1
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Rep: Reputation: 15
Lilo dual boot - slackware and fedora core 6


Hello all,

I have googled this problem, read the Lilo docs and searched this forum, so if anyone can help I really would appreciate it.

Problem:

I have Windows XP and Slackware on one hard drive with Lilo as the boot loader on the MBR and it all works like a dream. I have created another partition and have recently installed Fedora Core 6 on it (to see what the all the fuss is about).

During the Fedora installation I told it NOT to install Grub, as I already have Lilo (also Fedora did not recognise my other Slackware partition which did not fill me with confidence).

Now I have an installation of Fedora Core 6 that I want to add it to my lilo.conf. The problem is that I cannot get Lilo to boot Fedora, the closest I have got is the following:

-------------------------------------------------------------------------
# Start LILO global section
boot = /dev/sda
message = /boot/boot_message.txt
prompt
timeout = 600
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda2
label = Linux
read-only
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends

# FEDORA CORE
other = /dev/sda7
image = /boot/vmlinuz-2.6.18-1.2798.fc6
label = FedoraCore
initrd = initrd-2.6.18-1.2798.fc6.img


--------------------------------------------------------------------

Which results in:

Fatal: First sector of /dev/sda7 doesn't have a valid boot signature

BTW - this lilo.conf lives in the /boot directory of my Slackware install.

Now, the only boot sector on my disk is sda. But if lilo can pick up /dev/sda1 (windows) and /dev/sda2 (Slackware), why can't it understand /dev/sda7 (Fedora)?

Please help me out with this right kerfuffle!

Moschops.
 
Old 04-16-2007, 05:20 PM   #2
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Oh, I'd like to let you all know why I have posted this problem on the Slackware board. It is because I consider this a Lilo issue that I have on my Slackware partition.

I have looked at the Grub docs on Fedora Core and I think that persuing the Fedora / Grub way of thinking will just cause problems for booting Slackware.

So, what I really want is a Slacker's perspective on this Linux dual boot (triple boot if you count Windows).
 
Old 04-16-2007, 05:26 PM   #3
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
# Linux bootable partition config begins
image = /boot/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends

...should work. rtfm
 
Old 04-16-2007, 06:14 PM   #4
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Hi erklaerbaer

Thanks for the reply, but unfortunately it doesn't work (I've tried this before). I get this message:

Fatal: open /boot/vmlinuz-2.6.18-1.2798.fc6: No such file or directory

The Fedora core part of /etc/lilo.conf :

------------------------------------

# Linux bootable partition config begins
image = /boot/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends

------------------------------------

I understand why this error is thrown, because the FC6 kernel is not (and shouldn't) be in the /boot directory of my Slackware 11 install. So when I run lilo from the prompt, it looks in the boot directory of Slackware and cannot find the Fedora kernel (because it is in /dev/sda7/boot/vmlinuz-2.6.18-1.2798.fc6 )

Any other suggestions will be gratefully recieved.

moschops
 
Old 04-16-2007, 06:30 PM   #5
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
So...for a complete answer you should tell us how did you "split" FC6 installation.
Possible scenarios are:
a) FC6 on a single partition (/dev/sda7) sharing the swap ptn with Slackware
b) FC6 is spread on several partitions, one is /boot (let's say /dev/sdax) on which you have kernel image and initrd image
c) You copied your FC6 kernel image and initrd image on Slackware's /boot partition/directory
So, before you edit your /etc/lilo.conf you have to mount the file system where FC6 kernel image and initrd image resides (for the purpose you should create a mount point first (say /FC6).
So, case:
a) mount /dev/hda7 /FC6 and edit /etc/lilo.conf like

# Linux bootable partition config begins
image = /FC6/boot/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /FC6/boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends

b) mount /dev/hdx /FC6 and edit /etc/lilo.conf like

# Linux bootable partition config begins
image = /FC6/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /FC6/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends

c) Mounting the the Slackware /boot partition isn't required as it should be already mounted and edit /etc/lilo.conf like

# Linux bootable partition config begins
image = /boot/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends

From slack of course...lilo -v -t , just to see there's nothing wrong and then lilo -v
Hope this helps
Ciao

Last edited by urka58; 04-16-2007 at 06:37 PM.
 
Old 04-16-2007, 07:16 PM   #6
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Hi urka58,

Thanks for the reply. I have my partitions as follows:

sda1 Windows xp

sda2 / slackware
sda3 extended partition -
sda5 swap (slackware)
sda6 /home (slackware)

sda7 / (fedora core 6)
sda8 swap (fedora core)
sda9 /home (fedora core)



BTW, I realise that I needn't have created another home and swap for the fedora install.

I have tried both option A and B that you suggested (I've tried these before, sob!) and they result in a kernel panic. This is because Slackware still tries to load (even though I selected Fedora from the Lilo menu). In my mind, Slackware shouldn't be loading at all.

My new lilo.conf entry for fedora core:

# Linux bootable partition config begins
image = /mnt/fedora-core/boot/vmlinuz-2.6.18-1.2798.fc6
root = /dev/sda7
initrd = /mnt/fedora-core/boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends


I have also tried putting an entry in the /etc/fstab file of Slackware to mount /dev/sda7 on the /mnt/fedora-core directory at startup.

On a lighter note though, rather amusingly, while Slackware tries to load the Fedora core kernel (or cannot find it) there are TWO images of tux on the boot screen instead of one! The coolest looking kernel panic I've ever seen!


moschops.
 
Old 04-16-2007, 07:34 PM   #7
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Hi urka58,

Just tried option C. I copied both the kernel (vmlinuz-2.6.18-1.2798.fc6) and initrd (initrd-2.6.18-1.2798.fc6.img) to slackware's /boot directory, then chmod 777 both.

And then changed my lilo.conf to:

# Linux bootable partition config begins
image = /boot/vmlinuz-2.6.18-1.2798.fc6
# append = whatever
root = /dev/sda7
initrd = /boot/initrd-2.6.18-1.2798.fc6.img
label = FC6
read-only
# Linux bootable partition config ends


And got the same kernel panic (with the very cool double tux pictures on boot up).

Sob! Has no one solved this lilo dual Linux boot problem?

Moschops
 
Old 04-16-2007, 09:53 PM   #8
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Hey,
Been There done that!

AFAIK, you can't do anything through lilo.

First Of ... what you should have done is while installing FC6 you should have said "Install Grub" in the partition where you are installing FC6 (not the MBR). Then in lilo you could have done other=/dev/sda7 .

Only thing you CAN do now is :
chroot to the FC6 partition. Reinstall grub (copy the rpm there beforehand if it doesn't have it). Remember to reinstall it to the partition sda7. Then in lilo do
label=FC6
other=/dev/sda7

thats it . It should work now.

If you are unable to reinstall grub after chrooting , then try installing it through your present slackware install itself. IIRC, all this was a BIG pain.. I just reinstalled FC6 with the correct options selected.
 
Old 04-16-2007, 10:06 PM   #9
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
BTW, you couldn't have searched enough :P ... here is my old thread . It is quite a good read (a few page later)

http://www.linuxquestions.org/questi...d.php?t=522925

Last edited by duryodhan; 04-16-2007 at 10:09 PM.
 
Old 04-17-2007, 03:50 AM   #10
Thomas Lemmens
Member
 
Registered: Sep 2006
Location: European Union (BE)
Distribution: Ubuntu, Slackware
Posts: 49

Rep: Reputation: 16
Quote:
Originally Posted by moschops

Please help me out with this right kerfuffle!

Moschops.
You have to undertake only 2 actions:
1. Make a lilo boot loader in your Fedora partition. This boot loader needs only one choice: fedoracore. Write this boot loader in the boot sector of your fedora partition, NOT IN THE MBR. Don't forget to execute lilo.
2. Now open the lilo.conf (slack) for your lilo boot loader on the MBR. Delete 2 lines in the FEDORA-section of your MBR boot loader.
The result will be:
# FEDORA CORE
other = /dev/sda7
label = FedoraCore

Don't forget to execute lilo.

That's it.

Now, when starting your computer, first the MBR will be loaded. When choosing FedoraCore, the computer will load the lilo boot loader on your fedora partition. There you can choose your beloved fedora. To speed up, you can set a minimum wait time (timeout) in your fedora lilo.conf.

Since some linux flavours have patched packages (custom patched kernels and so on) and possibly different editions and configurations of the same packages, it is very important that there will be no interaction between the different linux flavours at boot time. In this setup, the boot process excludes unwanted interaction between the different linux flavours.

Last edited by Thomas Lemmens; 04-18-2007 at 04:46 AM.
 
Old 04-17-2007, 11:44 AM   #11
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
When you mount /dev/sda7 to /mnt/fedora..do you get any warning/error ?
lilo -v -t gives you any error ?
I'm very surprised you can't boot fedora. What filesystems did you choose while formatting fedora ?
Ciao
 
Old 04-17-2007, 02:54 PM   #12
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
Maybe re-run mkinitrd to make sure your initrd.img is correct?
 
Old 04-24-2007, 04:04 PM   #13
moschops
LQ Newbie
 
Registered: Oct 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Well, firstly, I'd like to say 'thank you' to all who posted and helped me out. I do not post here often, but every time I do, I always do so out of need and I always get some excellent help and advice. So thank you all.

Secondly, I have solved the problem with all of your help. I simply stuck my Fedora Core disc into my machine, then asked it to upgrade Fedora. When the Grub option finally arrived I told it to install on the same partition as Fedora Core. I then put the following into my /etc/lilo.conf

other = /dev/sda7
label = FedoraCore

and then I ran lilo.

Grrrrrrrrrrr!!!!!! The reason I didn't install Grub originally was because I already had Lilo.

I admit my ignorance, I thought that Lilo and Grub could boot as many OSs that you asked it to, through config files alone. From reading all the docs of Lilo and Grub; the most that they tell you about is dual booting Linux and Windows. None of the official docs tell you about triple boots.

I thought that if you just told Lilo or Grub where things were, they'd just work. Well, no. I now know that if I want to triple boot, the easiest thing to do is to install a boot loader on each Linux install.

Well I live and learn. I hope Fedora is worth it. (Slackware forever!!!!!!!!!!)

Thanks,

Moschops.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware 10.2 with fedora core 6 (lilo problems) unq Slackware 8 10-29-2006 02:08 PM
dual boot (xp pro and slackware 10.2) using lilo creeper_lin Slackware 4 06-06-2006 06:02 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 02:44 PM
How to set up dual-boot in LILO for Slackware 10.0 Shockshell Linux - Newbie 3 02-12-2005 10:39 PM
Slackware dual boot, lilo troubles... lt1derful Linux - Newbie 2 07-01-2003 09:58 PM


All times are GMT -5. The time now is 02:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration