LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-02-2002, 04:50 PM   #1
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
Lightbulb lilo


Hi
Maybe I repeating.....sorry in advance
I an not going to compile my kernel in soon time, so practically I won't need LILO booting every time. I wan to close it:
Can I do it commenting 'prompt' line in lilo.conf and setting timeout=1 (if I'll need that)?
ideas?
 
Old 11-02-2002, 05:10 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
what do you mean "every time"?? just leave it there, it's always useful incase something goes wrong. wether you are going to compile a kernel or not is pretty irrelevant.
 
Old 11-02-2002, 05:27 PM   #3
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
Acid I just want to hide LILO for a some weeks. How can I do it?
 
Old 11-02-2002, 05:37 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
hide? well set the timeout to zero then... or change the boot message to be text, it'll at least look a lot more subtle. but like i said, you should *always* be able to get into lilo in case of problems
 
Old 11-02-2002, 05:45 PM   #5
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
I am wondering if commenting 'prompt' line will help?
 
Old 11-02-2002, 05:50 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
tried reading the manpage??
 
Old 11-02-2002, 06:23 PM   #7
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
Right now once again I have read the man........You mean I can comment 'prompt' or 'timeout'?
 
Old 11-02-2002, 06:25 PM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
look, the manpage says that without prompt it will instantly boot to the default. but that is a pretty dumb thing to do, especially for a newbie like yourself.
 
Old 11-02-2002, 06:27 PM   #9
lopezjo49
Member
 
Registered: Jun 2002
Location: NJ
Distribution: Mainly Kubuntu 8.10
Posts: 44

Rep: Reputation: 15
man lilo.conf

/delay

delay=tsecs
Specifies the number of tenths of a second the boot loader should wait before booting the first image. This is useful on systems that immediately boot from the hard disk after enabling the keyboard. The boot loader doesn't wait if `delay' is omitted or is set to zero.

suggest you make a boot disk for future
 
Old 11-02-2002, 06:42 PM   #10
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
I think you cannot get my idea.......anyway thnx
 
Old 11-02-2002, 06:46 PM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967Reputation: 1967
the idea that you want to lock yourself out of your system...?
 
Old 11-03-2002, 04:13 AM   #12
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
uhhhhhh....
Ok here it is:
If you ever seen winbloze it starts automatically after BIOS initializes all hardware, blahblah (I think you know this routine) So I want Linux to start the same way.....
 
Old 11-03-2002, 05:49 AM   #13
moses
Senior Member
 
Registered: Sep 2002
Location: Arizona, US, Earth
Distribution: Slackware, (Non-Linux: Solaris 7,8,9; OSX; BeOS)
Posts: 1,152

Rep: Reputation: 46
edit your /etc/lilo.conf file and comment out any reference to a delay,
prompt, or timeout, and when you are done with that, run /sbin/lilo

from the man page:
(man lilo.conf)
Code:
.
.
.
delay=<tsecs>
              Specifies the number of tenths of a second the boot
              loader should wait before automatically  booting  a
              locked  command  line, a command line pre-stored by
              "lilo -R", or the  default  `image='  or  `other='.
              When `delay' is non-zero, the boot loader will wait
              for an interrupt for the specified interval. If  an
              interrupt  is  received, or is already waiting, the
              boot: prompt will be be issued,  and  no  automatic
              boot  will  take place. The setting of CAPS LOCK or
              SCROLL LOCK, or any  of  the  keys  ALT,  CTRL,  or
              SHIFT, when held down, are taken as interrupts.

              This action is modified by specifying `prompt' (see
              below).
.
.
.
       prompt Automatic booting (see `delay' above) will not take
              place unless a locked  or  pre-stored  ("lilo  -R")
              command  line  is present. Instead, the boot loader
              will issue the boot: prompt and wait for user input
              before  proceeding (see timeout below).  Unattended
              default image reboots are impossible if `prompt' is
              set  and  `timeout' is not, or the default image is
              password  protected  at   a   higher   level   than
              `restricted'.
.
.
.
       timeout=<tsecs>
              sets a timeout (in tenths of a second) for keyboard
              input  at  the  boot:  prompt.   "timeout" only has
              meaning if "prompt" is mentioned.   If  no  key  is
              pressed  for  the specified time, the default image
              is automatically booted.  The  default  timeout  is
              infinite.
 
Old 11-03-2002, 06:17 AM   #14
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
Yes that's the thing I wanted to hear to make sure I am right...thnx Moses and everyone else
 
Old 11-04-2002, 11:46 AM   #15
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Just so you know, Windows doesn't just boot immediatly after bios, it goes through it's own boot loader but covers it with a graphic. A good idea is probably to cover yours with a graphic (like you said you wanted to in a previous post). Get ride of prompt, and make a short delay (but not 0). That way if you do have a problem you can hit tab and boot off another kernel if you wish.

As was said before, it is very dangerous to not leave yourself any way of getting into lilo and doing something manually.....

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 02:15 PM
Upgraded kernel, lilo.conf, didn't run /sbin/lilo dtashima Linux - Newbie 4 10-18-2004 12:21 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
new kernel causes lilo crash; /sbin/lilo = Warning: device 0x0305 exceeds 1024 cylind dandysf Linux - Software 0 08-26-2003 05:50 PM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration