LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-01-2010, 07:33 AM   #1
inman
LQ Newbie
 
Registered: May 2009
Distribution: slackware
Posts: 12

Rep: Reputation: 1
Unhappy libv4l error!


hi,
i have Slackware 64 installed on my Labtop. today i installed VLC package from slacky.eu, and i installed all his dependencies too!!! one of them was libv4l.
first off all as many packages on slacky.eu, it doesn't even open! but this is not all, now i can open nothings. pkgtool opens just first page, and on clicking on menu, it gives error backs. the same things for sbopkg, and slapkpkg!! or by installing or removing any other Packages!!! ( i tried to install a package to test if the installation is possible, i think it is, but each prompt comes with this error! )
PHP Code:
ld.soobject '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloadedignored.
ERRORld.soobject '/usr/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloadedignored
thanking you in anticipation,
inman.

new: it seems that i installed a 32 bit package on my 64! thank guys, for no hint on slacky.eu!!

Last edited by inman; 02-01-2010 at 08:00 AM.
 
Old 02-01-2010, 09:08 AM   #2
inman
LQ Newbie
 
Registered: May 2009
Distribution: slackware
Posts: 12

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by inman View Post
hi,
i have Slackware 64 installed on my Labtop. today i installed VLC package from slacky.eu, and i installed all his dependencies too!!! one of them was libv4l.
first off all as many packages on slacky.eu, it doesn't even open! but this is not all, now i can open nothings. pkgtool opens just first page, and on clicking on menu, it gives error backs. the same things for sbopkg, and slapkpkg!! or by installing or removing any other Packages!!! ( i tried to install a package to test if the installation is possible, i think it is, but each prompt comes with this error! )
PHP Code:
ld.soobject '/usr/lib/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloadedignored.
ERRORld.soobject '/usr/lib/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloadedignored
thanking you in anticipation,
inman.

new: it seems that i installed a 32 bit package on my 64! thank guys, for no hint on slacky.eu!!
id read the man completely and i use this command ldconfig!
new: but it doesn't help!!! (

Last edited by inman; 02-01-2010 at 09:13 AM.
 
Old 02-01-2010, 10:02 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,313

Rep: Reputation: Disabled
You should have picked the other VLC package URL on http://www.videolan.org/vlc/download-slackware.html which is the one I made... well OK the URL is broken at the moment. Use ftp://ftp.slackware.org.uk/people/al...ackbuilds/vlc/ instead.

My package is more recent than that of slacky.eu (1.0.5 instead of 1.0.2) and it has no dependencies at all - because I have compiled all those libraries into the VLC package. It "just works".

Eric
 
Old 02-02-2010, 04:13 AM   #4
inman
LQ Newbie
 
Registered: May 2009
Distribution: slackware
Posts: 12

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Alien Bob View Post
You should have picked the other VLC package URL on http://www.videolan.org/vlc/download-slackware.html which is the one I made... well OK the URL is broken at the moment. Use ftp://ftp.slackware.org.uk/people/al...ackbuilds/vlc/ instead.

My package is more recent than that of slacky.eu (1.0.5 instead of 1.0.2) and it has no dependencies at all - because I have compiled all those libraries into the VLC package. It "just works".

Eric
hi Eric,
i used longtime yours, but i forgot this time, that you built it too!
thank you for the link. do you have a script or built package of pidgin with webcam too?


Just for protocol, for those who would do the same! i solved my issue by a making a new ld.so.conf, with ldconfig!! read the man of ld.so, there is a good explanation written!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libv4l-0.1 compiule problem business_kid Linux - Software 4 12-20-2009 02:52 AM
Memory error: extended error chipkill ecc error rajivdp Linux - Hardware 1 12-07-2009 08:26 AM
libv4l will not compile. tethysgods Linux - Software 3 04-05-2009 07:52 AM
Sendmail: eocket wedge , 504 error , dsn error, mail relay connection error djcs Debian 0 03-03-2009 12:41 AM
Suse CUPS error: cups(File)DoRequest error:client-error-bad-request smdonelan Linux - Hardware 6 04-17-2007 06:46 PM


All times are GMT -5. The time now is 10:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration