LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-17-2013, 10:47 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,064

Rep: Reputation: 45
libusb: how do I mount usbfs?


Slackware 14.0 (x86_64).

Hi: Regarding package libusb-1.0.9-x86_64-1, it has been installed when installing slackware 14.0. However, usbfs is not mounted at boot time. I would like to know how I could mount it. See http://www.libusb.org/.
 
Old 09-17-2013, 11:36 AM   #2
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware
Posts: 74

Rep: Reputation: 34
See: https://www.kernel.org/doc/Documenta...c_usb_info.txt

"In many modern systems the usbfs filesystem isn't used at all. Instead
USB device nodes are created under /dev/usb/ or someplace similar. The
"devices" file is available in debugfs, typically as
/sys/kernel/debug/usb/devices."

mount debugfs by this line in /etc/fstab:
Code:
debugfs          /sys/kernel/debug debugfs    defaults         0   0

Last edited by ml4711; 09-17-2013 at 11:37 AM.
 
Old 09-17-2013, 11:46 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,064

Original Poster
Rep: Reputation: 45
OK. But I need to do it the old way, that is with usbfs, because I'm trying to develop a USB driver. Is there a way to mount it, in spite of udev?
 
Old 09-17-2013, 12:32 PM   #4
ml4711
Member
 
Registered: Aug 2012
Location: Ryomgård, Danmark
Distribution: Slackware
Posts: 74

Rep: Reputation: 34
Then you need to recompile the kernel with usbfs support.

In the kernel source tree call:
Code:
make menuconfig
you find the option here:
Device Drivers ---> USB support ---> USB device filesystem (DEPRECATED)

then compile and install kernel and modules, (read the README file for kernel-source)

setup lilo.conf and then run lilo

in fstab:
Code:
none  /proc/bus/usb  usbfs  defaults  0  0

Last edited by ml4711; 09-17-2013 at 12:37 PM.
 
1 members found this post helpful.
Old 09-17-2013, 12:35 PM   #5
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,064

Original Poster
Rep: Reputation: 45
I'll do that, or perhaps I'll use slackware 12.0. Thank you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's none means in command mount -t usbfs none /proc/bus/usb ? viktor2000 Linux - Newbie 1 08-30-2012 07:53 AM
usbfs greplinux Programming 2 11-15-2010 09:32 AM
[SOLVED] ubuntu 9.10 - #include <libusb/libusb.h> stonehinge03 Linux - Newbie 5 04-20-2010 09:02 AM
rc.S: # Mount usbfs if we're not using udev? pdw_hu Slackware 2 05-02-2007 01:12 PM
mount usbfs? yusufozk Linux - General 2 03-23-2005 06:01 PM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration