LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-27-2005, 12:59 PM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
libtool error


Hmm, i'm not sure what to do here..

Trying to compile, but i keep getting this error
Code:
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
My ld.so.conf file
Code:
/usr/local/lib
/usr/X11R6/lib
/usr/i486-slackware-linux/lib
/opt/kde/lib
/usr/lib/qt/lib
/usr/lib/firefox
And i have libtool 1.5.14 installed.

Searching for these missing files, they are all found in
/usr/lib/

So i'm kind of in a mint twister here... heh

EDIT:
Sorry for not mentioning this, but everything does compile successfully.. I just get tons and tons of the above messages every time. That's why i'm asking (incase if its something serious)

Last edited by xushi; 07-27-2005 at 01:08 PM.
 
Old 07-27-2005, 01:09 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
What error? Libtool warnings are not errors, that's just libtool being flaky as usual
 
Old 07-27-2005, 01:51 PM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,343

Rep: Reputation: 73
Try add /usr/lib in /etc/ld.so.conf, then run ldconfig
 
Old 07-27-2005, 01:54 PM   #4
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Original Poster
Rep: Reputation: 45
Quote:
Originally posted by Andrew Benton
What error? Libtool warnings are not errors, that's just libtool being flaky as usual
This error
Code:
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
g++: ../../../../../subversion/libsvn_repos/.libs/libsvn_repos-1.so: No such file or directory
g++: ../../../../../subversion/libsvn_client/.libs/libsvn_client-1.so: No such file or directory
g++: ../../../../../subversion/libsvn_wc/.libs/libsvn_wc-1.so: No such file or directory
g++: ../../../../../subversion/libsvn_ra/.libs/libsvn_ra-1.so: No such file or directory
g++: ../../../../../subversion/libsvn_delta/.libs/libsvn_delta-1.so: No such file or directory
g++: ../../../../../subversion/libsvn_subr/.libs/libsvn_subr-1.so: No such file or directory
make: *** [subversion/bindings/java/javahl/native/libsvnjavahl-1.la] Error 1
edit:
Adding /usr/lib to ld.so.conf seems to have solved it. I'll double check now.
Thanks

EDIT:
Quote:
Libtool warnings are not errors, that's just libtool being flaky as usual
But is that normal/safe ? Because what i get is somewhat like this
Code:
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libgdbm.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libdb-4.2.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libexpat.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc-lib/i486-slackware-linux/3.3.6/../../..//libxml2.la' seems to be moved
/download/subversion-1.2.1/ac-helpers/install-sh -c .libs/libsvnjavahl-1.so.0.0.0T /usr/local/lib/libsvnjavahl-1.so.0.0.0
(cd /usr/local/lib && rm -f libsvnjavahl-1.so.0 && ln -s libsvnjavahl-1.so.0.0.0 libsvnjavahl-1.so.0)
(cd /usr/local/lib && rm -f libsvnjavahl-1.so && ln -s libsvnjavahl-1.so.0.0.0 libsvnjavahl-1.so)
/download/subversion-1.2.1/ac-helpers/install-sh -c .libs/libsvnjavahl-1.lai /usr/local/lib/libsvnjavahl-1.la
/download/subversion-1.2.1/ac-helpers/install-sh -c .libs/libsvnjavahl-1.a /usr/local/lib/libsvnjavahl-1.a
ranlib /usr/local/lib/libsvnjavahl-1.a
chmod 644 /usr/local/lib/libsvnjavahl-1.a
PATH="$PATH:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------

Last edited by xushi; 07-27-2005 at 02:12 PM.
 
Old 01-27-2009, 02:28 PM   #5
djmitche
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
There's nothing wrong with these warnings - they're spurious. libtool's getting confused by the "../" in the library paths, but these are entirely normal and come from using multilib.

Hopefully libtool will fix this warning soon, as the warnings are verbose and make it hard to spot real errors. However, note that upgrading a piece of software to a new version of libtool is *very* difficult and developers usually won't undertake to do so unless they must to solve a significant error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeBSD PHP5 ports error - libphp5.la is not a valid libtool archive BizHat.com *BSD 2 08-18-2005 10:27 AM
libtool error (openobex) gallan Linux - Software 1 07-15-2005 11:27 PM
libtool link error tibbar66 Linux - Newbie 1 04-09-2005 05:14 PM
GTK+-2.6.2 compile error: libtool looking in wrong place for libglib-2.0.la Locura Linux - Software 5 02-17-2005 03:51 PM
make error "libtool: link: cannot find the library `' " jdolluc Linux - Software 2 10-15-2003 09:51 PM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration