LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-22-2013, 09:59 AM   #1
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 184

Rep: Reputation: 27
libtinfo.so.5 requirement for GnuGo?


@willysr (or anyone else who knows the answer): I went to Willy's SlackHacks repository to copy the GnuGo SlackBuild. After I compiled the program and tried to execute it,however, I had two dependencies crop up. The one I took care of with a simple soft link. However, the second one has proven to be tricky. The command

Code:
 ldd $(which gnugo) | grep "not found"
revealed this:

Code:
libtinfo.so.5 => not found
I cannot come up with a package that contains this library, no matter how much I Google for it. Any suggestions would be greatly appreciated.

Regards,

Matt

Last edited by mattallmill; 06-22-2013 at 10:02 AM.
 
Old 06-22-2013, 10:10 AM   #2
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 184

Original Poster
Rep: Reputation: 27
After rephrasing my Google search, I found the answer here: http://forums.opensuse.org/english/get-technical-help-here/64-bit/446927-missing-library-libtinfo-so-5-a.html

Thanks in advance for the help.

Regards,

Matt
 
Old 06-22-2013, 10:11 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
It looks like you are running the program on another computer than the one where you compiled it.
You compiled it on an ARM host? Or on a machine which used my Slackware bootstrap scripts previously to build a ncurses package with libtinfo.so separated from libncurses.so?

Eric
 
Old 06-22-2013, 10:48 AM   #4
mattallmill
Member
 
Registered: Nov 2009
Location: Salina,Kansas
Distribution: Slackware64-current
Posts: 184

Original Poster
Rep: Reputation: 27
Greetings Eric.

I compiled GnuGo on the same machine I am running it on (x86_64). However, I found that the information required in libtinfo.so.5 was contained in libncurses.so.5 in /lib64. Symlinking them solved the problem for me.

cd /lib64
ln -s libncurses.so.5 libtinfo.so.5

I am now running Kigo, the KDE version of Go.

Thanks.

Last edited by mattallmill; 06-22-2013 at 10:51 AM. Reason: Added code for example
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem to install spice3, ncurses (libtinfo.so.5) is requried anujkaushal Linux - Software 6 09-02-2011 04:29 AM
can not find libtinfo.so.5 needed to install an rpm in opensuse 11.1 64bit sirius57 Linux - Software 2 07-24-2010 05:46 AM
libtinfo.so.5 chicken76 Slackware 1 05-18-2009 03:52 PM
what is the requirement tony2666 Fedora - Installation 1 05-20-2004 02:58 PM
libtinfo.so.5??? maskim7 Linux - General 0 04-07-2002 02:42 PM


All times are GMT -5. The time now is 01:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration