LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-03-2013, 11:35 AM   #1
nates1
LQ Newbie
 
Registered: Oct 2011
Location: OH -wish did not
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 5

Rep: Reputation: 0
libSDL-1.2.so.0.11.4 from slackware64-current "undefined symbol" _XGetRequest


After upgrading to sdl-1.2.15-x86_64-1 I get failed: /usr/lib64/libSDL-1.2.so.0: undefined symbol: _XGetRequest

Specifically when running /opt/VirtualBox/VirtualBox.so.
Whole error is:
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: /usr/lib64/libSDL-1.2.so.0: undefined symbol: _XGetRequest

Sure enough:
# objdump -T /usr/lib64/libSDL-1.2.so.0 |grep XGetRe
0000000000000000 DF *UND* 0000000000000000 _XGetRequest

sdl-1.2.15-x86_64-1.txz (from slackware64-current)
/usr/lib64/libSDL-1.2.so.0 -> libSDL-1.2.so.0.11.4 (Not work)

sdl-1.2.14-x86_64-5.txz (from slackware64-14.0)
/usr/lib64/libSDL-1.2.so.0 -> libSDL-1.2.so.0.11.3 (works)

Is sdl-1.2.15 missing something?
 
Old 04-03-2013, 02:49 PM   #2
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 236

Rep: Reputation: 55
Code:
fskmh@workstation:/usr/local/src/SDL-1.2.15> grep -r XGetReq
src/video/x11/SDL_x11sym.h: * libX11 1.4.99.1 added _XGetRequest, and macros use it behind the scenes.
src/video/x11/SDL_x11sym.h:SDL_X11_SYM(void *,_XGetRequest,(Display* a,CARD8 b,size_t c),(a,b,c),return)
src/video/x11/SDL_x11dyn.c:static void *SDL_XGetRequest_workaround(Display* dpy, CARD8 type, size_t len)
src/video/x11/SDL_x11dyn.c:              *  that _XGetRequest() is available, even on older systems.
src/video/x11/SDL_x11dyn.c:                     p_XGetRequest = SDL_XGetRequest_workaround;
Looks like this symbol comes from libX11, and libSDL definitely links to it:

Code:
fskmh@workstation:~> ldd /usr/lib64/libSDL-1.2.so.0.11.4 
        linux-vdso.so.1 (0x00007fff0d22a000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f599f143000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00007f599ef39000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f599ed28000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f599eb1f000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f599e7e6000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f599e5c8000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f599e3c5000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007f599e1bf000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f599dfbb000)
        libvga.so.1 => /usr/lib64/libvga.so.1 (0x00007f599dd42000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f599db25000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f599d75e000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f599f744000)
On my slack64-current, libX11-1.5.0 appears to originate from Slackware 14 release.
 
Old 04-08-2013, 09:40 AM   #3
nates1
LQ Newbie
 
Registered: Oct 2011
Location: OH -wish did not
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks to fskmh. That lead me on the right track of upgrading libX11, and others while at it. Didn't even think of it as I don't run X locally, only over SSH.
Now I know how to trace lib dependencies more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get install snmpd gives error" undefined symbol: boot_DynaLoader" renuaseri Linux - Newbie 8 10-20-2013 11:41 PM
Error message "undefined symbol" when executing the command import from gasrine Linux - Software 1 11-23-2010 10:43 AM
libSDL problems "Could not initialize libSDL" & "No available video device" DarkPlexus Linux - Newbie 1 11-02-2007 08:55 PM
plesk + php 4.3.2 upgrade error - "undefined symbol: ap_signal" p_s_shah Linux - Server 0 10-30-2007 01:41 PM
avgscan "relocation error" "undefined symbol: __dynamic_cast_2" Monster_user Linux - Software 0 02-22-2006 12:57 PM


All times are GMT -5. The time now is 03:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration