LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-25-2012, 02:30 PM   #1
lethal_lee
LQ Newbie
 
Registered: Nov 2012
Posts: 6

Rep: Reputation: Disabled
libsasl not found?


I'm trying to install rtorrent from slackbuilds. The install fails because: libtool: link: cannot find the library `/usr/lib/libsasl2.la' or unhandled argument `/usr/lib/libsasl2.la'.

I thought maybe I didn't have that library installed, so after doing some research I found that I needed qca-cyrus-sasl-2.0.0_beta3-i486-1 for that library. I installed that through slackpkg from the official slackware package.

However, when trying to install rtorrent again, I still get the same error. Any thoughts on what I'm missing?
 
Old 11-25-2012, 02:51 PM   #2
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by lethal_lee View Post
I'm trying to install rtorrent from slackbuilds. The install fails because: libtool: link: cannot find the library `/usr/lib/libsasl2.la' or unhandled argument `/usr/lib/libsasl2.la'.

I thought maybe I didn't have that library installed, so after doing some research I found that I needed qca-cyrus-sasl-2.0.0_beta3-i486-1 for that library. I installed that through slackpkg from the official slackware package.

However, when trying to install rtorrent again, I still get the same error. Any thoughts on what I'm missing?
Did you do a full Slackware install? The missing library is already provided by the following package:
Code:
cyrus-sasl-2.1.23-i486-4
That is for Slackware 14.
 
Old 11-25-2012, 03:50 PM   #3
lethal_lee
LQ Newbie
 
Registered: Nov 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks, I was looking under the /l/ directory not the /n/.

Last edited by lethal_lee; 11-25-2012 at 03:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg, no screens found; no devices found (after Virtualbox install) Archytas Linux - General 6 03-06-2013 03:41 PM
404 Not Found The requested URL '/zm' was not found on this server. mickeyboa Ubuntu 8 07-26-2012 11:02 AM
Directory not found; -xzvf not found; Makefile not found RealGomer Linux - Software 4 09-20-2010 10:02 AM
Fedora Core 6 boot No medium found No volume groups found awadhut Linux - Hardware 1 02-22-2007 01:15 AM
PDC 20276 - Promise Fasttrack 133 found but still not found.. FransE Linux - Hardware 3 02-16-2004 07:44 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration