LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   LibreOffice SlackBuild (from SBO) Missing Files? (http://www.linuxquestions.org/questions/slackware-14/libreoffice-slackbuild-from-sbo-missing-files-4175456025/)

tronayne 03-29-2013 11:05 AM

LibreOffice SlackBuild (from SBO) Missing Files?
 
Trying to build LibreOffice from SlackBuils.org.

Downloaded LibO-SDK_3.6.5_Linux_x86-64_install-rpm_en-US.tar.gz (the only stable version I could find). Symbolically-linked to LibO_3.6.5_Linux_x86-64_install-rpm_en-US.tar.gz (so I didn't have to edit libreoffice.SlackBuild for the "SDK" part).
Code:

VERSION="3.6.5" libreoffice.SlackBuild
LibO-SDK_3.6.5.2_Linux_x86-64_install-rpm_en-US/
LibO-SDK_3.6.5.2_Linux_x86-64_install-rpm_en-US/RPMS/
LibO-SDK_3.6.5.2_Linux_x86-64_install-rpm_en-US/RPMS/libobasis3.6-sdk-3.6.5.2-2.x86_64.rpm
mv: cannot stat 'desktop-integration/libreoffice3.6-freedesktop-menus-3.6*.noarch.rpm': No such file or directory

Huh? Where the heck is 'desktop-blah'?

I also tried this with 3.6.4 (the one the SlackBuild expects) and got the same result.

Did I download the wrong package? Do I need to get something else, too?

Thanks.

willysr 03-29-2013 11:06 AM

Why don't you use LibreOffice from Eric?

tronayne 03-29-2013 11:14 AM

Quote:

Originally Posted by willysr (Post 4921120)
Why don't you use LibreOffice from Eric?

Well, basically, because Eric wants to install stuff in /usr instead of /opt (I'm just picky that way) and I don't want to struggle with it to get it in /opt where I keep "optional" software.

'Course it might be easier that way...

phenixia2003 03-29-2013 11:44 AM

Hello,

Quote:

Originally Posted by tronayne (Post 4921118)
Trying to build LibreOffice from SlackBuils.org.

Downloaded LibO-SDK_3.6.5_Linux_x86-64_install-rpm_en-US.tar.gz (the only stable version I could find). Symbolically-linked to LibO_3.6.5_Linux_x86-64_install-rpm_en-US.tar.gz (so I didn't have to edit libreoffice.SlackBuild for the "SDK" part).

I guess this is because you have downloaded the libreoffice SDK package instead of the libreoffice package.

Here is the link for libreoffice 3.6.5 : http://download.documentfoundation.o...m_en-US.tar.gz

--
SeB

tronayne 03-29-2013 01:50 PM

Man, I don't know where you found that package, but it did the job -- thank you!


All times are GMT -5. The time now is 02:08 AM.