LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Libreoffice doesn't print files with language specific charakters in filename (http://www.linuxquestions.org/questions/slackware-14/libreoffice-doesnt-print-files-with-language-specific-charakters-in-filename-4175453449/)

integrale16 03-09-2013 07:22 PM

Libreoffice doesn't print files with language specific charakters in filename
 
Hi,

I set up a box with Slackware64 14.0 with all updates until now. I also installed AlienBobs Libreoffice 4.0.1 packages.

My problem is now that Libreoffice does not print any file (I tried only .odt so far) which has a language specific (German) character in the filename.
I can open, modify and save the file and I can export it to pdf.

But if I try to print it, nothing happens, not even an error message occurs (also no console output if I start it from a terminal).

If I open the file with Calligra I can print it without any problem. Also if I export it to pdf with the same filename I can print it with Okular.

If I rename the file so that there is no language specific (German) character then I can print the file with Libreoffice, too.

Has anyone an idea what could be the problem here?

--
integrale16

bogzab 03-10-2013 05:27 AM

May or may not be related but I had a similar problem with names of font files/folders. I installed a number of fonts in /usr/local/share/fonts and fixed a /etc/fonts/local.conf to tell fc-cache to look additionally in this folder for fonts. I found that fc-cache found all the fonts except the ones that were in a folder named including accented character. This one folder was ignored. I renamed the folder to use only regular 7-bit ascii characters and everything worked fine. Looks as though something along the way does not recognise unicode characters - not sure exactly where the fault lies.

integrale16 03-10-2013 11:44 AM

Thanks for your answer, but I'm not sure if this is related to my problem.

The weird thing is, that it seems that only Libreoffice has a problem with the filenames if I try to print it. Other activities like open, modify, save work as expected.

At my other box with Slackware64 13.37 and AlienBobs Libreoffice 3.5.4 this problem does not exist.

Does Libreoffice use another way to print or another command or interface than other programs?

dwblas 03-10-2013 12:29 PM

Check the locale setting under Tools, Options, Language Settings. You have to have it set to what ever character set you want to use.

integrale16 03-10-2013 12:58 PM

The language settings in Libreoffice are set to German.
And the language specific characters like , , are printed correctly, if the document is printed.

The problem is, that the documents with a language specific characters in the filename (not in the text) does not get printed by Libreoffice. If I rename it, so that there is no special character left in the filename, Libreoffice prints it without any problem.

I could verify the behavior with another user account and another Display Manager (Fluxbox).

My LANG variable in /etc/profile.d/lang.sh is set to de_DE@euro.
And i have tried it with setting LANG=C in a terminal and starting Libreoffice from within the terminal. Libreoffice then showed up with menus in english then (as expected) but the behavior regarding the printing was the same.

I have still no idea what the problem is.

ljb643 03-10-2013 04:35 PM

Have you tried print-to-file from Libreoffice? This might help narrow it down, by eliminating CUPS from the process. (I assume you are using CUPS as your printing system. Did you check your CUPS log files to see if it got the document that failed to print?)

integrale16 03-10-2013 09:40 PM

lib643, thanks for your hint.
Seems that there was some problem with the printer setup.
First time I set up the printer with HP Device manager.
This time I set the printer up over the CUPS webadmin (localhost:631).

Now I can print files with special characters in filename out of Libreoffice.


All times are GMT -5. The time now is 12:55 AM.