LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-22-2013, 07:50 AM   #31
BratPit
Member
 
Registered: Jan 2011
Posts: 46

Rep: Reputation: 6

I've tried it with LXDE -

No problem with Format Cells . The dialog presents itself correctly.
 
Old 12-22-2013, 01:01 PM   #32
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
I've tried it on a fresh install of Slackware 14.1 with KDE 4.11.4 -

Same problem with the Format Cells dialog
The File Save dialog is a lot speedier.

Alex
 
Old 12-22-2013, 05:46 PM   #33
enine
Member
 
Registered: Nov 2003
Distribution: Slackware 14.1
Posts: 820
Blog Entries: 3

Rep: Reputation: 91
so is it the KDE theme integration that's causing it?
 
Old 12-23-2013, 03:42 AM   #34
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
The slackbuild.org LibreOffice works for me whereas AlienBob's doesn't.

Alex
 
Old 12-23-2013, 09:28 AM   #35
coldbeer
Member
 
Registered: May 2006
Distribution: Slackware 14.1 + multilib
Posts: 144

Rep: Reputation: 49
I can confirm the SlackBuild script does not exhibit the transparent format dialog on a large spreadsheet.

1. Downloaded Slackbuild.org script for 4.1.3 for 14.1.
http://slackbuilds.org/repository/14...e/libreoffice/
2. Changed line inside libreoffice.SlackBuild script to VERSION=${VERSION:-"4.1.4"}
3. Downloaded LibreOffice_4.1.4_Linux_x86-64_rpm.tar.gz
4. sudo ./libreoffice.SlackBuild script.
5. Used pkgtool to remove libreoffice-4.1.4-x86_64-1alien.txz
6. sudo installpkg libreoffice-4.1.4-x86_64-1_SBo.tgz

Got a bunch of warnings about zero length htm files in
/tmp/SBo/package-libreoffice/opt/libreoffice4.1/share/extensions/nlpsolver/help
but they were indeed 0 length in LibreOffice_4.1.4_Linux_x86-64_rpm.tar.gz

put =rand()*10000 in cells out to HS:1200 - No dialog issue.

I did notice on the alien package that I would have to manually copy in the =rand()*10000 in cells for it to mess up. If I saved the spreadsheet then reloaded it, the dialog boxes didn't have an issue. Probably irrelevant since it seems to work in non-kde desktops.

Last edited by coldbeer; 12-23-2013 at 10:21 AM.
 
Old 12-23-2013, 06:45 PM   #36
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
I've compared the parameters used to compile the download from LibreOffice with those used by AlienBob.

LibreOffice uses -

--disable-kde4
--enable-kde


AlienBob uses -

--enable-kde4
--disable-kde

The exact opposite. I've subsequently asked this of the LibreOffice Developers and got this response -

Quote:
Hi there,

On Mon, 2013-12-23 at 21:10 +0000 wrote:
> Why does the autogen.sh that is used to compile the build, Linux - rpm (x86),
> version 4.1.4, English (US) have the flags -

Sure - this is because the rather old system we compile the generic
linux builds on (which needs to be that old so we can run on all newer
systems) can't feasibly have KDE4 installed. I tried to make a magic
assembler tool to stub the libraries to overcome that without success -
it's a bit of a pain.

> --disable-kde4
> --enable-kde
>
> in the file LibreOfficeLinux.conf.

Sure - and also --enable-gnome-vfs as well as --disable-gio is a
similar disaster caused by the same issue.

> Is it because in the standard build kde integration of LibreOffice is
> still at KDE3?

It's all to do with what we can get to install on a reasonably vanilla
CentOS 5 (IIRC).

HTH,

Michael.

--
michael.meeks@collabora.com <><, Pseudo Engineer, itinerant idiot
I'm not sure what conclusion to draw from this.

Alex
 
Old 12-24-2013, 08:22 AM   #37
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Can you try what happens if you rename/move/delete the following two files (on 32-bit Slackware the lib directory will be "lib" not "lib64"):
Code:
/usr/lib64/libreoffice/program/libkde4be1lo.so
/usr/lib64/libreoffice/program/libvclplug_kde4lo.so
These two libraries are all that comprises the KDE4 integration.
If your issues are solved with these out of the way, then I can split them off into a separate libreoffice-kde4 package.

Eric
 
Old 12-24-2013, 09:26 AM   #38
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
I'm 32bit. I did this -

Code:
/usr/lib/libreoffice/program$ mv libkde4be1lo.so libkde4be1lo.so.aik
/usr/lib/libreoffice/program$ mv libvclplug_kde4lo.so libvclplug_kde4lo.so.aik
My very quick test shows that the transparent "Format Cells" dialog and the slow "Save" dialog issues have been resolved.

With the removal of those two files Libreoffice appears to have adopted the gtk "Save" dialog.

Alex
 
Old 12-24-2013, 11:15 AM   #39
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by Alien Bob View Post
Can you try what happens if you rename/move/delete the following two files (on 32-bit Slackware the lib directory will be "lib" not "lib64"):
Code:
/usr/lib64/libreoffice/program/libkde4be1lo.so
/usr/lib64/libreoffice/program/libvclplug_kde4lo.so
These two libraries are all that comprises the KDE4 integration.
If your issues are solved with these out of the way, then I can split them off into a separate libreoffice-kde4 package.
I suppose this does solve my problem because then it uses GTK dialogs. I can't reproduce my original issue at all (of course, there's no up button or anything like that).

It seems like we've narrowed down the problem. Something in 4.1.x's KDE integration is broken, or there's a bug with Slackware's default KDE that is triggering the problem.
 
Old 12-24-2013, 11:16 AM   #40
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by metaschima View Post
Are you sure you don't have the package 'gcc-java-4.8.2-x86_64-1' installed ? If you do, then I think it is the problem.
All that does is allow you to compile Java code. It doesn't provide Java itself.
 
Old 12-24-2013, 02:24 PM   #41
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,536

Rep: Reputation: Disabled
Quote:
Originally Posted by marnold View Post
All that does is allow you to compile Java code. It doesn't provide Java itself.
I'm not convinced. In the options it says it finds FSF Java 1.5.0 at '/usr/lib64/jvm/jre'. Going to that directory and using ls:

Code:
bash-4.2$ ls -l /usr/lib64/jvm/jre/bin
total 0
lrwxrwxrwx 1 root root 19 Dec  6 00:09 java -> ../../../../bin/gij
lrwxrwxrwx 1 root root 24 Dec  6 00:09 keytool -> ../../../../bin/gkeytool
lrwxrwxrwx 1 root root 21 Dec  6 00:09 orbd -> ../../../../bin/gorbd
lrwxrwxrwx 1 root root 21 Dec  6 00:09 rmid -> ../../../../bin/grmid
lrwxrwxrwx 1 root root 28 Dec  6 00:09 rmiregistry -> ../../../../bin/grmiregistry
lrwxrwxrwx 1 root root 26 Dec  6 00:09 tnameserv -> ../../../../bin/gtnameserv
bash-4.2$ grep 'usr/bin/gij' /var/log/packages/*
/var/log/packages/gcc-java-4.8.2-x86_64-1:usr/bin/gij
So, yes it definitely provides java. I also know this because I opened a bug report on it and I got what I said as the answer. I just can't seem to find it anymore because they reorganized the site. I'll look again and post it if I find it.
 
Old 12-30-2013, 07:52 AM   #42
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
I've raised a bug report, with libreoffice, for the transparent "Format Cells" dialog.

https://bugs.freedesktop.org/show_bug.cgi?id=73115

Alex
 
Old 04-18-2014, 08:40 PM   #43
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Original Poster
Rep: Reputation: 32
The good news is that Libreoffice 4.2.3.3 seems to be dramatically better with the file manager in KDE (and, yes, I installed AlienBob's libreoffice-kde package). The file manager is still slightly laggy after using it literally all day today, but it is very minor. I feel I can now comfortably use 4.2.3.3 with the KDE integration.
 
Old 04-20-2014, 08:11 AM   #44
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 396

Rep: Reputation: 41
I've tried AlienBob's Libreoffice 4.2.3.3 packages. I've found that libreoffice to be slow starting up. With the libreoffice-kde package calc won't start.

I think I'll wait a few more weeks. Having read 77128 in bugzilla I can't work out where they've been rolled out to.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Impress (libreoffice 4.1.2) F5 Freeze on Slackware Current f4lc0n Slackware 2 10-10-2013 11:53 PM
How to install only Writer from Libreoffice package"libreoffice-4.0.3-i486-1alien.txz just.srad Slackware 10 05-30-2013 03:37 PM
[SOLVED] Has anyone else found LibreOffice to be very, very slow? rnturn Linux - Software 8 03-17-2013 02:02 AM
LibreOffice and KDE dialogs Woodsman Slackware 4 03-08-2013 01:57 PM
LXer: Build Your Business Around LibreOffice, LibreOffice Certification Program Announced LXer Syndicated Linux News 0 05-07-2012 01:10 PM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration