LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-11-2011, 08:16 PM   #106
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119

Quote:
Originally Posted by Alien Bob View Post
Indeed, I do not add dictionaries into my libreoffice packages, you will have to download and install those from http://extensions.services.openoffic...n/dictionaries. Subscribe to my blog posts and/or read http://alien.slackbook.org/blog/get-...eoffice-3-3-0/ where I explain more about the packages I create.

Eric
Hi Eric,

Actually, I'm a big fan of your blog and read it regularly. Just for some reason I thought you built Libreoffice with an English dictionary with others needing to be downloaded. This is an example of my sometimes fuzzy-headed thinking.

Thanks for the link to the dictionaries, though. I tried to search for "libreoffice dictionaries" and pretty much came up blank. I didn't think to look for them at Openoffice.org.

I'm going to mention a couple of bugs here in the interest of hopefully getting a cure and helping the general cause (i.e., these aren't complaints ):

1) What about the problem with settings not staying put, but reverting to the defaults?

2) Libreoffice's menus look funny in my bone-stock Slackware 13.1 23-bit installation. See the attached picture.

Regards,
Attached Images
File Type: png Libreoffice funny menus.png (112.0 KB, 65 views)
 
Old 02-17-2011, 02:08 AM   #107
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
My Libreoffice ( Alien package 3.3.0 64-bit ) has recently started behaving strangely when opening odt files ( only ). It pops up a dialogue box with "General Error' and then after clicking the ok button, proceeds to open the file. I could be mistaken, but this may have started after a recent round of -current updates ( ~ 12 Feb 2011 ). ODS and other office files are fine.

The only similar item I've found relates to JAVA and OpenOffice - mine seems to be fine though. I've tried reinstalling and removing my .libreoffice dir but makes no difference. Any ideas welcome ...
 
Old 02-17-2011, 06:41 AM   #108
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Rep: Reputation: 64
Quote:
Originally Posted by rpedrica View Post
My Libreoffice ( Alien package 3.3.0 64-bit ) has recently started behaving strangely when opening odt files ( only ). It pops up a dialogue box with "General Error' and then after clicking the ok button, proceeds to open the file. I could be mistaken, but this may have started after a recent round of -current updates ( ~ 12 Feb 2011 ). ODS and other office files are fine.
Just to confirm I have noticed the same behaviour. Have not yet diagnosed it further.
 
Old 02-25-2011, 09:09 AM   #109
bl0tt0
Member
 
Registered: Aug 2005
Posts: 145

Rep: Reputation: 21
Quote:
Originally Posted by trillobyte View Post
I'm attempting to install libreoffice build-3.3.0.4. (Alien Bob's slackbuild)
onto my 32-bit slackware 13.1 system. I'm running KDE 4.4.3.

The build is failing with the following:

Code:
./package-ooo: line 9:
/tmp/build/tmp-libreoffice/libreoffice-build-3.3.0.4/build/libreoffice-3.3.0.4/*
.[sS]et.sh: No such file or directory
libreoffice.SlackBuild: line 720: cd:
/tmp/build/package-libreoffice/usr/lib/libreoffice/basis-link/share/fonts/
truetype/: No such file or directory
libreoffice.SlackBuild FAILED at line 725
Thanks in advance
I was having this same problem, until I found this post on alienbob's blog: http://alien.slackbook.org/blog/libr...ate-for-3-3-0/

The gist of it is that you need to remove the seamonkey and seamonkey-solibs packages and install xulrunner, apache-ant, and perl-archive-zip before building libreoffice. After that I was able to compile without any problems.
 
Old 03-02-2011, 12:34 PM   #110
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
I was hoping Eric's 3.3.1 package build would fix the problem but unfortunately not. I still get the General Error when opening ( only ) odt files or when saving new odt files. Help?
 
Old 03-02-2011, 01:24 PM   #111
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Rep: Reputation: 64
Quote:
Originally Posted by rpedrica View Post
I was hoping Eric's 3.3.1 package build would fix the problem but unfortunately not. I still get the General Error when opening ( only ) odt files or when saving new odt files. Help?
That's strange, the upgrade seems to have fixed the error message for me.
 
Old 03-02-2011, 01:47 PM   #112
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
BroX, could you tell me your 'upgrade' procedure?
 
Old 03-02-2011, 02:02 PM   #113
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Rep: Reputation: 64
Quote:
Originally Posted by rpedrica View Post
BroX, could you tell me your 'upgrade' procedure?
Sure, nothing special:
Code:
$ wget http://connie.slackware.com/~alien/slackbuilds/libreoffice/pkg64/13.1/libreoffice-3.3.1-x86_64-1alien.txz -P /tmp
# upgradepkg /tmp/libreoffice-3.3.1-x86_64-1alien.txz
I left the newly created ~/.ooo3 directory for what it was (no links from ~/.libreoffice/3 as suggested here)

Last edited by BroX; 03-02-2011 at 02:04 PM.
 
Old 03-02-2011, 02:11 PM   #114
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
Ok have removed package(s) - includes en_GB - completely and reinstalled. Still get the same error ... grrrrrr
 
Old 03-02-2011, 02:15 PM   #115
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Rep: Reputation: 64
Aaargh... maybe the error is still there, it just doesn't pop up in a window any longer? When run from command line, the following appears when opening a .odt file:
Code:
$ libreoffice 
$ X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6a00d46
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x6a00d46
No such messages when opening .ods or .odp files.
 
Old 03-02-2011, 02:19 PM   #116
rpedrica
Member
 
Registered: Nov 2008
Location: Cape Town
Distribution: Slackware64 -current
Posts: 208

Rep: Reputation: 27
Hmmm, I get the popup window and no cli errors.
 
Old 03-03-2011, 09:13 PM   #117
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 300

Rep: Reputation: 35
Wink Thanks a lot Eric!

Thanks a lot! I downloaded your package and i'm using it right now.

I normally make custom installers, so I used to repackage the OpenOffice.org installers, tweaking some things.

LibreOffice in general feels a lot faster than OOO. It hasn't crashed a lot lately, but my workload is not as high as last year, so I have to test it more.

I did have some problems when repackaging your package (can't help it, let's call it a vice I have). I use English as my primary language, but I use metric units and A4 as my default page size. I need to replicate metric units as defaults in my installers. Most installations are intended to be as unattended as possible and with as little user interaction as possible. (one of the final users is an aunt who is an accountant and "has little time to learn new things", so telling her to open any configuration window is not an option).

I achieved that in the past (with OOO) editing individual XCU files. In LibreOffice the registry happens to be a single line XML so using a diff file would not be helpful. After wandering a bit in the LibreOffice IRC channel and being told the registry was an autogenerated file (yes I did intend to use some "source registry" with line breaks I could find), I decided to modify the file by sedding it with long search strings. First I wanted to set the default metric units so I changed MeasureUnit in proper places.

The next thing I wanted to do was to set an A4 default template. I used to do that in the past by modifying the starter scripts to detect custom templates in the proper place. Luckily this wasn't needed this time, for I got it to work by setting ooSetupSystemLocale to en-AU (Australia uses metric units and A4). I modded the registry and it worked. No custom templates needed, but I enabled the scripts anyway just in case.

I just downloaded the newest version. It is huge so I kept just the localizations I needed. I trimmed my installed package size to about 320MB instead of about 550MB.

Anyway, I will post the registry modifications in case someone wants to use metric units with the precompiled package (tested with AlienBob's package only)

XCDREGISTRY=/usr/lib/libreoffice/basis3.3/share/registry/main.xcd

Code:
# Force metric units in Calc.
sed -i 's#oor:name="StatusbarFunction" oor:type="xs:int"><value>9</value></prop><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>8</value>#oor:name="StatusbarFunction" oor:type="xs:int"><value>9</value></prop><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>2</value>#' $XCDREGISTRY
Code:
# Force metric units in Draw.
sed -i 's#oor:name="Draw" oor:package="org.openoffice.Office" xml:lang="en-US"><component><group oor:name="Layout"><group oor:name="Display"><prop oor:name="Ruler" oor:type="xs:boolean"><value>true</value></prop><prop oor:name="Helpline" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Guide" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Bezier" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Contour" oor:type="xs:boolean"><value>true</value></prop></group><group oor:name="Other"><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>8</value>#oor:name="Draw" oor:package="org.openoffice.Office" xml:lang="en-US"><component><group oor:name="Layout"><group oor:name="Display"><prop oor:name="Ruler" oor:type="xs:boolean"><value>true</value></prop><prop oor:name="Helpline" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Guide" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Bezier" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Contour" oor:type="xs:boolean"><value>true</value></prop></group><group oor:name="Other"><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>2</value>#' $XCDREGISTRY
Code:
# Force metric units in Impress.
sed -i 's#</templates><component><group oor:name="Layout"><group oor:name="Display"><prop oor:name="Ruler" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Helpline" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Guide" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Bezier" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Contour" oor:type="xs:boolean"><value>true</value></prop></group><group oor:name="Other"><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>8</value>#</templates><component><group oor:name="Layout"><group oor:name="Display"><prop oor:name="Ruler" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Helpline" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Guide" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Bezier" oor:type="xs:boolean"><value>false</value></prop><prop oor:name="Contour" oor:type="xs:boolean"><value>true</value></prop></group><group oor:name="Other"><group oor:name="TabStop"><prop oor:name="Metric" oor:type="xs:int"><value>1250</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>1270</value></prop></group><group oor:name="MeasureUnit"><prop oor:name="Metric" oor:type="xs:int"><value>2</value></prop><prop oor:name="NonMetric" oor:type="xs:int"><value>2</value>#' $XCDREGISTRY
Code:
# Force metric units in Writer.
sed -i 's#<group oor:name="Other"><prop oor:name="MeasureUnit" oor:type="xs:int"/><prop oor:name="TabStop" oor:type="xs:int"><value>1250</value>#<group oor:name="Other"><prop oor:name="MeasureUnit" oor:type="xs:int"><value>2</value></prop><prop oor:name="TabStop" oor:type="xs:int"><value>1250</value>#' $XCDREGISTRY
Code:
# Force metric units in Writer/Web.
sed -i 's#<group oor:name="Other"><prop oor:name="MeasureUnit" oor:type="xs:int"/></group>#<group oor:name="Other"><prop oor:name="MeasureUnit" oor:type="xs:int"><value>2</value></prop></group>#' $XCDREGISTRY
Code:
# Force the en-US language and en-AU locale (this will change the default page size to A4):
sed -i 's#<prop oor:name="ooLocale" oor:type="xs:string"><value/></prop><prop oor:name="ooSetupSystemLocale" oor:type="xs:string"><value/></prop>#<prop oor:name="ooLocale" oor:type="xs:string"><value>en-US</value></prop><prop oor:name="ooSetupSystemLocale" oor:type="xs:string"><value>en-AU</value></prop>#' $XCDREGISTRY
 
1 members found this post helpful.
Old 03-03-2011, 09:32 PM   #118
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 300

Rep: Reputation: 35
Thumbs up 2:17 seconds

By the way, I haven't tried the preloader. Writer loads in an average of 00:02:17 (a little more than 2 seconds). I don't think I'll be needing the preloader, as I tested it on a less powerful machine and it still loads reasonably fast (less than 3 seconds).

Calc loads a really huge sheet almost instantly. No flickering using the arrows or the mouse wheel. It rocks.

I just tried some heavy presentations and it lacks the memory hunger of OOO. It actually runs below 400MB, including FF with streaming videos. Writer and Impress running at the time. 331MB of RAM in use.
 
Old 03-04-2011, 10:56 AM   #119
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
In LibreOffice, prior to 3.3.0, I had the notification box with I/O Error show up, also the ruler (in Writer) would always come up in Char horizontally & Lines vertically. Version 3.3.0 fixed the ruler problem, but not the I/O Error problem. Version 3.3.1 fixed the I/O Error problem, but reintroduced the ruler problem. I have made my own default template, using Inch in both rulers. But even though it is saved with the ruler set to Inch & Tools->Options->LibreOffice Writer->View->Horizontal/Vertical Ruler are saved to Inch, if I open a document (new or otherwise), the rulers come up in Char & Line. This is not a showstopper, it is easy to change, it is just irritating. Anyone know how to make my chosen ruler settings stick?
Regards,
Bill
 
Old 03-23-2011, 09:16 AM   #120
hplgonzo
LQ Newbie
 
Registered: Jun 2008
Location: austria
Distribution: arch
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by TSquaredF View Post
In LibreOffice, prior to 3.3.0, I had the notification box with I/O Error show up, also the ruler (in Writer) would always come up in Char horizontally & Lines vertically. Version 3.3.0 fixed the ruler problem, but not the I/O Error problem. Version 3.3.1 fixed the I/O Error problem, but reintroduced the ruler problem. I have made my own default template, using Inch in both rulers. But even though it is saved with the ruler set to Inch & Tools->Options->LibreOffice Writer->View->Horizontal/Vertical Ruler are saved to Inch, if I open a document (new or otherwise), the rulers come up in Char & Line. This is not a showstopper, it is easy to change, it is just irritating. Anyone know how to make my chosen ruler settings stick?
Regards,
Bill
I built up an entirely new Arch Linux System some time ago and yesterday was the first time I needed an office application. After using ooo on earlier systems, this time LibreOffice was my first choice and I guess I will continue using it instead of ooo, whenever I have to write something small. First of all the application is quite easy to configure and easy to use.

The only thing that is a little bit annoying is the "ruler problem" you mentioned in your posting. As you said definitely no showstopper, as you can change it easily to the preferred setting. but it's for sure a little bit annoying.

Have you found out any solution for the "ruler problem" by now? There should be way to change it permanently. I guess it would be no problem to change a setting file manually, but i haven't found any file that contains the ruler settings. Would be nice if anyone could post a solution to solve that little problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to install libreoffice in Ubuntu using PPA LXer Syndicated Linux News 1 10-05-2010 06:05 AM
LXer: How to Install LibreOffice in Ubuntu LXer Syndicated Linux News 1 10-03-2010 10:47 AM
LXer: Libreoffice will set free OpenOffice LXer Syndicated Linux News 0 10-03-2010 05:41 AM
LXer: Goodbye OpenOffice. LibreOffice, Here I Come! LXer Syndicated Linux News 0 09-30-2010 01:50 AM
LXer: LibreOffice Is The New OpenOffice.org LXer Syndicated Linux News 5 09-29-2010 05:25 PM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration