LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2007, 11:44 PM   #1
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Rep: Reputation: 33
libpng problem with xfe file manage


Hello all:

Decide to take a break from networking my computers and was looking around at file managers available in GUI. The xfe looked good so to make a long store short I'm having problems.

It was listed on "SlackBuilds.org" but could not get the source to load so I downloaded the only version I could find from "sourceforge" which was 1.00. I changed the slackbuild version number and it would not work.

So, next step was to try out the src2pkg tool and I got the following errors on it.

Code:
bash-3.1# src2pkg xfe-1.00.tar.gz 
Found source archive: xfe-1.00.tar.gz
Deleting old build files - Done
Creating working directories:
   PKG_DIR=/tmp/xfe-1.00-pkg-1
   SRC_DIR=/tmp/xfe-1.00-src-1
Unpacking source archive - Done
Found 'rpm2tgz' format:
Correcting source permissions - Done
Checking for patches - None found
Found configure script - Configuring sources using:
   CFLAGS=-O2 -march=i486 -mtune=i686 ./configure --prefix=/usr
Configuration has been - Successful!
Compiling sources - Using: 'make'
ERROR! Compiling source code has failed.
This usually happens because of missing libraries, or
badly written Makefiles or configure scripts.
Found an RPM .spec file which shows this:
Requires: fox >= 1.6 libpng >= 1.2
BuildRequires: fox-devel >= 1.6 libpng-devel >= 1.2

src2pkg FAILURE in compile_source
I check on the libpng and that's the newest version I can find. I don't understand this one so could someone point me in the right direction.

Note: The fox-toolkit worked great on the "slackbuild" and according to the doc's this was the only dependency mentioned.

Thanks for the help.
 
Old 09-04-2007, 02:05 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Do you have the fox libraries already installed? If not install them first.
You can run src2pkg with the -VV or -R options to see the full output of 'configure' and 'make' whioch should give more clues.
 
Old 09-04-2007, 12:36 PM   #3
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Original Poster
Rep: Reputation: 33
gnashley,
At work now, but yes the fox libraries were installed.. I'll try it
again when I get home and get more info... I really like the src2pkg and its worked everytime except this one... I must be doing something wrong.
 
Old 09-04-2007, 10:36 PM   #4
davimint
Member
 
Registered: Jan 2006
Distribution: Slackware Current
Posts: 272

Original Poster
Rep: Reputation: 33
Rebuilt the fox libraries just to make sure with src2pkg and they built fine just like the slackbuild did. Next I Installed and then tried to build xfe with src2pkg again and it filed again. I used the -VV switch to get this information.

Code:
++  -O2   -o xfe  icons.o StringList.o File.o FileDict.o FileList.o FileDialog.o DirList.o DirBox.o DialogBox.o MessageBox.o Bookmarks.o HistInputDialog.o InputDialog.o OverwriteBox.o TextWindow.o CommandWindow.o Properties.o Preferences.o FilePanel.o DirPanel.o DirHistBox.o XFileExplorer.o PathLinker.o BrowseInputDialog.o ArchInputDialog.o FontDialog.o main.o  -lpng -lFOX-1.6 
main.o: In function `FX::FXDCWindow::drawText(int, int, char const*, unsigned int)':
main.cc:(.text+0xf93): undefined reference to `XftDrawStringUtf8'
main.cc:(.text+0xfce): undefined reference to `XftDrawString8'
main.o: In function `FX::FXFont::getTextWidth(char const*, unsigned int) const':
main.cc:(.text+0x105b): undefined reference to `XftTextExtentsUtf8'
main.cc:(.text+0x1095): undefined reference to `XftTextExtents8'
collect2: ld returned 1 exit status
make[2]: *** [xfe] Error 1
make[2]: Leaving directory `/tmp/xfe-1.00-src-1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/xfe-1.00-src-1'
make: *** [all] Error 2
ERROR! Compiling source code has failed.
This usually happens because of missing libraries, or
badly written Makefiles or configure scripts.
Found an RPM .spec file which shows this:
Requires: fox >= 1.6 libpng >= 1.2
BuildRequires: fox-devel >= 1.6 libpng-devel >= 1.2

src2pkg FAILURE in compile_source

Maybe someone can make since of this, it is above my knowledge at this point.

Thanks
 
Old 09-05-2007, 02:26 AM   #5
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
Last night I had a look at this. If you look at the spec file that comes with the sources it uses these options for configure:
--with-included-gettext --enable-release

It's the gettext that is causing the build to fail, but the other option is probably also useful someway.
Try this:'src2pkg -e='--with-included-gettext --enable-release' xfe-1.00.tar.gz'

The need for --with-included-gettext is one of the most comon causes of build failure. Sometimes it can also be corrected with --disable-nls. These options have to do with the compiling of the language translation files included with the software. Usually you can see that this is the case because builds will fail with errors about 'po' or 'mo' files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libpng and libpng-devel driving me crazy latino Linux - Server 6 06-27-2007 06:15 PM
error while loading shared libraries: libpng.so.2: [I reinstalled libPNG!] Shioni Linux - Software 1 09-09-2006 07:21 PM
libpng and libpng-devel missing in mplayer configure mmarkvillanueva Linux - Software 2 11-29-2005 10:40 PM
missing file libpng.so.2 SurfCHimp Linux - Software 11 02-26-2005 04:17 PM
MPlayer install problems with libpng & libpng-devel Trey2501 Linux - Newbie 18 03-05-2004 11:24 PM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration