LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Libevent errors w/tmux on Slackware64 -current (http://www.linuxquestions.org/questions/slackware-14/libevent-errors-w-tmux-on-slackware64-current-886879/)

tallship 06-17-2011 08:44 AM

Libevent errors w/tmux on Slackware64 -current
 
I haven't actually had a chance to build a 13.37 Slack64 machine yet (shame on me), but I've seen a couple of references to the following or similar errors wrt Libevent 2.0.x

I didn't get these before, but then again on 13.1 I'm running libevent 1.4.13

Code:

[warn] event_del: event has no event_base set.
I haven't had any serious problems yet, but I don't want to have several sessions and this blow up on me, so I'm thinking maybe just use screen or ask here if this is anything critical I need to worry about, and if so, might I just consider uninstalling the package and using the 1.x.x version of libevent instead?

Thanks :)

sahko 06-17-2011 09:28 AM

Where do you get those? In the terminal? I dont.
Its been working flawlessly here with tmux 1.4 and libevent 2.0.12

tallship 06-17-2011 10:46 PM

Yes, in the terminal. On more than one machine.

Okay Sahko....

I showed you mine now you show me yours ;)

I gather you're not getting these errors in Slackware64 -current, but what about the other questions I had about this?

I just did a Slackware64 13.37 install earlier and it's giving me md5sum errors w/apr, apr-utils, and httpd when I try to slackpkg upgrade-all.

So there's some network issues going on where those machines are, for starters.

Crap.

sahko 06-18-2011 02:16 AM

Quote:

Originally Posted by tallship (Post 4389069)
Yes, in the terminal. On more than one machine.

Okay Sahko....

I showed you mine now you show me yours ;)

I gather you're not getting these errors in Slackware64 -current, but what about the other questions I had about this?

I didnt notice any other questions.
Are you by any chance using tmux 1.3 and *not* 1.4? The version in slackbuilds.org is outdated and 1.4 should work fine with libevent-2.x.

tallship 06-19-2011 12:55 AM

Quote:

Originally Posted by sahko (Post 4389155)
The version in slackbuilds.org is outdated and 1.4 should work fine with libevent-2.x.

Bingo!

Thanks for pointing that out to me Sahko :) I built and upgraded to 1.4 and all is better now.

Kindest regards,

sahko 06-19-2011 03:53 AM

Glad it works. You could mark the thread as solved. :)


All times are GMT -5. The time now is 01:32 AM.