LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2010, 08:28 AM   #31
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51

Just tried with a Puppy live cd. Getting the same errors now with Puppy. Now I must look elsewhere.

Sheeesh!

Bob
 
Old 04-18-2010, 09:20 AM   #32
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,140
Blog Entries: 3

Rep: Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405
Hi,

You did disable ipv6?

What about the Ethernet (wired) static IP setup? Did it work?
A sample static IP configuration;
Code:
~#ifconfig -a                      #get recognized devices
~#ifconfig eth0 192.168.0.10       #set to a available IP
~#route add default gw 192.168.0.1 #set to your gateway
~#route -n                         #show the route table
~#ifconfig eth0 up                 #should be up already
~#ping 192.168.0.1                 #ping your gateway
~#ping 208.69.32.130               #google.com IP
~#ping google.com                  #test DNS, if fail then
                                   #check /etc/resolv.conf
You should have your '/etc/resolv.conf' setup with your 'ISP DNS' nameservers. If the static IP works for Ethernet then move to setup the wireless network device. If that doesn't work then reboot or restart the inet.

Then show us the output;

Code:
~#ifconfig -a
~#route -n
~#cat /etc/rc.inet1.conf
~#lsmod

~#lspci -vv |grep -i network
~#lspci -vv |grep -i Ethernet

or

~#lspci -vv -s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]]
For the last command take the 'device address' from the output of the 'lspci -vv |grep -i network'.

Which driver is shown for Network(wireless) & Ethernet device for the 'lspci' output?
 
Old 04-18-2010, 10:36 AM   #33
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thanks onebuck,

The wired connection gives me the same output, it doesn't connect either. I don't know why this will not work with Slackware (and now Puppy as well) when it has worked with Windows and others distros.

I don't believe this one can be fixed.

Bob


EDIT: Your instructions for setting up the manual WIRED configuration WORKED! I was able to ping the other machines and the router, but could not get a net connection (DNS). The /etc/resolv.conf was empty so I copied the information from a working machine. Still could not reach the net. BUT, at least I know the router works, It is something in DHCP and wpa_supplicant, I am convinced.

Last edited by BobNutfield; 04-18-2010 at 11:14 AM.
 
Old 04-18-2010, 11:39 AM   #34
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Sorry, onebuck. It took me a while to copy all of it over.

ifconfig -a:

Quote:
eth0 Link encap:Ethernet HWaddr 00:00:f0:84:c1:3f
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1480 (1.4 KiB) TX bytes:1480 (1.4 KiB)

wlan0 Link encap:Ethernet HWaddr 00:11:50:91:22:5c
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:74 errors:0 dropped:0 overruns:0 frame:0
TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18865 (18.4 KiB) TX bytes:21813 (21.3 KiB)

wmaster0 Link encap:UNSPEC HWaddr 00-11-50-91-22-5C-6C-6F-00-00-00-00-00-00-00-00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
route -n:

Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 wlan0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
cat /etc/rc.d/rc.inet1.conf

Quote:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="bob-laptop1"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="wext"
WLAN_WPACONF[1]="/etc/wpa_supplicant.conf"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0" # Use a different interface name nstead of
# the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
#MTU[4]="" # The default MTU is 1500, but you might need
# 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
# your default gateway
#DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
# server
#WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
# defined in rc.wireless.conf, by prepending
# 'WLAN_' to the parameter's name. Useful for
# those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
# Some drivers require a private ioctl to be
# set through the iwpriv command. If more than
# one is required, you can place them in the
# IWPRIV parameter (separated with the pipe (|)
# character, see the example).
lsmod:

Quote:
Module Size Used by
snd_seq_dummy 2464 0
snd_seq_oss 29792 0
snd_seq_midi_event 5980 1 snd_seq_oss
snd_seq 47984 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6088 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 37728 0
snd_mixer_oss 14300 1 snd_pcm_oss
ipv6 243508 12
cpufreq_ondemand 6632 0
speedstep_lib 3840 0
freq_table 3420 1 cpufreq_ondemand
lp 9316 0
fuse 54008 1
rt2500pci 14780 0
rt2x00pci 7004 1 rt2500pci
rt2x00lib 26972 2 rt2500pci,rt2x00pci
rfkill 9296 2 rt2x00lib
led_class 3392 1 rt2x00lib
mac80211 155588 2 rt2x00pci,rt2x00lib
cfg80211 36468 2 rt2x00lib,mac80211
eeprom_93cx6 1692 1 rt2500pci
pcmcia 33772 0
joydev 9504 0
ppdev 7200 0
snd_intel8x0 28696 2
snd_ac97_codec 100128 1 snd_intel8x0
yenta_socket 23848 2
e100 30660 0
rsrc_nonstatic 10876 1 yenta_socket
parport_pc 24036 1
ac97_bus 1372 1 snd_ac97_codec
pcmcia_core 32016 3 pcmcia,yenta_socket,rsrc_nonstatic
mii 4380 1 e100
snd_pcm 68128 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
parport 30700 3 lp,ppdev,parport_pc
snd_timer 19108 2 snd_seq,snd_pcm
thermal 15096 0
snd 50820 13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd _timer
processor 38600 2 thermal
intel_agp 25628 1
soundcore 5824 1 snd
fan 4064 0
video 16492 0
rtc_cmos 10124 0
i2c_i801 8784 0
thermal_sys 10756 4 thermal,processor,fan,video
agpgart 29256 1 intel_agp
rtc_core 15992 1 rtc_cmos
shpchp 31888 0
psmouse 41676 0
snd_page_alloc 7972 2 snd_intel8x0,snd_pcm
output 2396 1 video
rtc_lib 2332 1 rtc_core
hwmon 2104 1 thermal_sys
button 5708 0
container 3132 0
ac 3840 0
battery 9856 0
serio_raw 5024 0
evdev 9152
lspci -vv | grep network:

Quote:
lspci -vv | grep network:

03:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
Subsystem: Belkin F5D7010 Wireless G Notebook Network Card
lspci -vv |grep -i Ethernet

Quote:
02:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (LOM) Ethernet Controller (rev 82
Hope that can get clarity on it. Thank you very much for looking at this.

Bob
 
Old 04-18-2010, 01:44 PM   #35
fancylad
Member
 
Registered: Mar 2008
Distribution: slackware
Posts: 175

Rep: Reputation: 19
Quote:
EDIT: Your instructions for setting up the manual WIRED configuration WORKED! I was able to ping the other machines and the router, but could not get a net connection (DNS). The /etc/resolv.conf was empty so I copied the information from a working machine. Still could not reach the net. BUT, at least I know the router works, It is something in DHCP and wpa_supplicant, I am convinced
Can you ping the ip that is in /etc/resolv.conf? If not then the default gateway is probably not setup. run: netstat -rn. You should see a line like:

0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Which means that all ip address that don't match any other route get sent to 192.168.1.1 (this should be the ip of your router). If you don't see a line like this then you don't have a default gatweway and that's why you can't reach your ISp's dns servers.
 
Old 04-18-2010, 02:03 PM   #36
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Thank you for your post, but the gateway is active and recognized. Just and cannot get an IP address.

Bob
 
Old 04-18-2010, 02:28 PM   #37
keng
LQ Newbie
 
Registered: Mar 2010
Posts: 2

Rep: Reputation: 1
I also had a problem with DHCP not playing nice with my router.
Run 'dhclient' from a prompt and see if you get an IP address.
 
Old 04-18-2010, 02:41 PM   #38
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Quote:
Originally Posted by keng View Post
I also had a problem with DHCP not playing nice with my router.
Run 'dhclient' from a prompt and see if you get an IP address.
I have tried that as well. It simply times out. To tell you the truth, I am losing the will to go on with this. The purpose of the whole things was to install a stable system for my to use Linux. She was not willing to learn it in the past, but said if I could set this laptop up, she would give it a try. That has been blown out of the water. I don't think I will be able to convince her anytime soon that Linux is "easy" now.

Thank you for you post.

Bob
 
Old 04-18-2010, 02:53 PM   #39
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Quote:
Originally Posted by keng View Post
I also had a problem with DHCP not playing nice with my router.
Run 'dhclient' from a prompt and see if you get an IP address.
keng, I have been going crazy with this for a week now. I tried dhclient at least a dozen times before. Just for the heck of it I tried it again just now and it WORKED!!! I got an IP address for this machine for the first time.

I will just have to see if it is a freak success and won't withstand a reboot, but it has worked for the first time, so that is proof that it will work.

Thank you very much for taking the time to post. And if this fixes it, thank you to each and every one who posted trying to help. I have learned a lot from this and I hope I can share that with someone else who may have the same issue.

For anyone else dealing with this issue regarding dhcpcd and the "option 43" error, there is additional very good information in this thread:

http://www.linuxquestions.org/questi...173/page2.html

Bob

Last edited by BobNutfield; 04-23-2010 at 04:25 PM.
 
Old 04-18-2010, 03:00 PM   #40
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Just disconnected and reconnected using dhclient. Worked for the second time, so I am marking this thread SOLVED. I really am going to endeavor to find out why dhcpcd would not work when it does with one other laptop running Slack current. But for now I am thrilled to see the end of this one.

Thanks again to everyone, particularly keng.

Bob
 
Old 04-18-2010, 03:58 PM   #41
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,140
Blog Entries: 3

Rep: Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405
Hi,

Quote:
Originally Posted by BobNutfield View Post
Thanks onebuck,

The wired connection gives me the same output, it doesn't connect either. I don't know why this will not work with Slackware (and now Puppy as well) when it has worked with Windows and others distros.

I don't believe this one can be fixed.

Bob


EDIT: Your instructions for setting up the manual WIRED configuration WORKED! I was able to ping the other machines and the router, but could not get a net connection (DNS). The /etc/resolv.conf was empty so I copied the information from a working machine. Still could not reach the net. BUT, at least I know the router works, It is something in DHCP and wpa_supplicant, I am convinced.
When you set this did you place the nameservers from your ISP in '/etc/resolv.conf'?

You will set the DNS up. I sometimes test with a third level DNS;

Code:
'/etc/resolv.conf';

#verizon third level
nameserver 4.2.2.1
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
Plus be sure to setup the default route for the eth0 device;
Code:
~#route add default gw 192.168.1.1      #set this to your gateway
~#route -n                              #show kernel route table

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    1      0        0 eth0
Notice the gateway for my sample output.
 
Old 04-18-2010, 04:23 PM   #42
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Yes, thank you onebuck. I followed your directions and the results are as you described. It appears as the dhcpcd was the cultprit after all. I am still going to see if I can figure why dhclient works and dhcpcd doesn't

All the best

Bob
 
Old 04-18-2010, 05:12 PM   #43
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,140
Blog Entries: 3

Rep: Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405Reputation: 1405
Hi,

I would be sure to disable ipv6 as shown
. Once you confirm the wired Ethernet works statically you can then proceed to setup the wireless network device. I would setup the wireless device in the same as the Ethernet;

I would setup a static IP first, do as root from cli;

Code:
~#ifconfig -a                      #get recognized devices
~#ifconfig wlan0 192.168.0.10      #set to a available IP
~#route add default gw 192.168.0.1 #set to your gateway
~#route -n                         #show the route table
~#ifconfig wlan0 up                #should be up already
~#ping 192.168.0.1                 #ping your gateway
~#ping 208.69.32.130               #google.com IP
~#ping google.com                  #test DNS, if fail then
                                   #check /etc/resolv.conf
Don't forget the '/etc/resolv.conf' setup. Once you confirm that the static is working then you can either setup via the '/etc/rc.d/rc.inet1.conf' or use wicd. I sometimes just use a script when I want to change;

Code:
wlan.sh

#!/bin/bash
#
#10-26-09 13:30 
#setup the wlan0 device
#
/sbin/ifconfig wlan0 192.168.1.18       #set to your IP
/sbin/route add default gw 192.168.1.1  #your gateway
/sbin/iwconfig wlan0 essid "your essid"
/sbin/iwconfig wlan0 'key put your key here'
/sbin/iwconfig wlan0 ap 00:0F:66:E1:67:07  #this would be from 'iwlist wlan0 scan'
Once you have the static working then proceed to setup encryption.

BTW, I would be changing my key if the post you posted above is the current key. You don't need to post keys for us to aid in diagnosis.

 
Old 04-19-2010, 03:09 AM   #44
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Original Poster
Rep: Reputation: 51
Quote:
TW, I would be changing my key if the post you posted above is the current key. You don't need to post keys for us to aid in diagnosis.
Thanks, onebuck. That was not my actual key. It is stored in wpa_supplicant, which I did not post. I tried your method and it does infact get me connected with an IP address. I still could not get online even though I had correctly configured /etc/resolv.conf. However, if I disconnect with wicd and receconnect with wicd, I am assigned the same IP address, and I am online.

I will continue to investigate these issues, but for now I can connect and that was the biggest issue.


Thank you for your help.

Bob
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Slack...Just a couple of questions BobNutfield Slackware 13 03-12-2006 11:01 AM
Newbie learned his lesson... doody Linux - Newbie 4 09-02-2004 11:48 PM
Installing softwares : a question, and important lesson OmniXBro Mandriva 2 04-20-2004 09:15 PM
Lesson learned... Beware of this software... Nichole_knc Slackware 3 04-15-2004 04:56 AM
bunch of questions after installing slack 9.1 slack_is_good Slackware 5 12-08-2003 11:45 AM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration