LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Latest zoneminder install on Slack64-14 (http://www.linuxquestions.org/questions/slackware-14/latest-zoneminder-install-on-slack64-14-a-4175468814/)

lpallard 07-07-2013 09:06 PM

Latest zoneminder install on Slack64-14
 
I am trying to install ZM onto Slack64-14 but there are no slackbuilds available for 14 on Slackbuilds.org and as a result I have tried different ways but its not working

Slackbuilds package for 13.37 on 14 (I know not good :o )

Code:

checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking for sys/param.h... (cached) yes
checking for sys/socket.h... (cached) yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking values.h usability... yes
checking values.h presence... yes
checking for values.h... yes
checking linux/videodev.h usability... no
checking linux/videodev.h presence... no
checking for linux/videodev.h... no
configure: error: zm requires Video4Linux to be installed

From sources

If all else fails, I will push this way a bit more but there are million of dependencies for ZM's so I am scared running a simple

Code:

./configure
make
make test
make install

wont pickup all dependencies and options I have enabled and installed on the machine. I have literally installed everything including their sub dependencies and so on..

The Slackbuild for 13.37 still uses ZM 1.24.2 which I believe is from 2009! Somebody has managed to install ZM 1.25 on Slackware64-14 or current??

Id prefer installing ZM using a well written slackbuilds script since its the best way not to screw up the install... ;)

Thanks!

jostber 07-08-2013 11:32 AM

Maybe you can check with the maintainer if he wants to build the 14.0 SlackBuild package? The dependencies for Zoneminder are described in the 13.37 README files:

http://slackbuilds.org/slackbuilds/1...ADME.SLACKWARE
http://slackbuilds.org/slackbuilds/1...EADME.PERLDEPS
http://slackbuilds.org/slackbuilds/1...eMinder/README

lpallard 07-08-2013 12:23 PM

Ive already contacted him to ask.. I invited him to either reply to my email or on this thread!

So lets stay tuned but im still wondering if someone successfully built it on 14??

ponce 07-08-2013 12:33 PM

it has already been asked here: you can build it with the 13.37 slackbuild (and that version, not 1.25) but you have to use ffmpeg-0.10.x as a dependency, as it's incompatible with ffmpeg >= 0.11.x.

lpallard 07-08-2013 07:08 PM

Quote:

it has already been asked here: you can build it with the 13.37 slackbuild (and that version, not 1.25) but you have to use ffmpeg-0.10.x as a dependency, as it's incompatible with ffmpeg >= 0.11.x.
you mean zoneminder 1.25 is incompatible with ffmpeg >=0.11.x ?

ponce 07-08-2013 10:46 PM

yes, too.

alex.pujols 07-18-2013 12:17 AM

Running into the same issue
 
I'm running into the same issue and would rather not downgrade FFMPEG since that would break another dependency. =[

ap

ponce 07-18-2013 01:05 AM

you should complain for this to zoneminder devs: it has been removed from the repositories of many distributions for this reason.

if they don't want to port to more recent ffmpegs, maybe they could embed a compatible version.

lpallard 07-18-2013 08:55 AM

Quote:

Originally Posted by ponce (Post 4992338)
you should complain for this to zoneminder devs: it has been removed from the repositories of many distributions for this reason.

if they don't want to port to more recent ffmpegs, maybe they could embed a compatible version.

I concur. I will complain to the zoneminder devs.

The former Slackbuild maintainer kindly contacted me and he decided to stop maintaining the slackbuild script. Apparently no-one has stepped up to take over for him.

Too bad there is so much disparity in the linux world... some projects are too much bleeding edge while others are trailing behind..


All times are GMT -5. The time now is 10:13 PM.